summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-action/clanbomber/clanbomber-1.05.ebuild16
-rw-r--r--games-arcade/methane/methane-1.4.6.ebuild14
-rw-r--r--games-puzzle/pingus/pingus-0.6.0-r1.ebuild13
-rw-r--r--games-sports/trophy/trophy-1.1.3.ebuild16
4 files changed, 28 insertions, 31 deletions
diff --git a/games-action/clanbomber/clanbomber-1.05.ebuild b/games-action/clanbomber/clanbomber-1.05.ebuild
index 7504ba821fa3..d7281b9d1c85 100644
--- a/games-action/clanbomber/clanbomber-1.05.ebuild
+++ b/games-action/clanbomber/clanbomber-1.05.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/clanbomber/clanbomber-1.05.ebuild,v 1.2 2004/06/24 21:53:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/clanbomber/clanbomber-1.05.ebuild,v 1.3 2004/08/15 08:55:06 vapier Exp $
-inherit eutils games
+inherit games eutils flag-o-matic
DESCRIPTION="Bomberman-like multiplayer game"
HOMEPAGE="http://clanbomber.sourceforge.net/"
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/clanbomber/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 amd64"
IUSE=""
RDEPEND="sys-libs/zlib
@@ -19,27 +19,25 @@ RDEPEND="sys-libs/zlib
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
-pkg_setup() {
- clanlib-config 0.6.5
-}
-
src_unpack() {
unpack ${A}
cd ${S}
sed -i \
-e 's:\(@datadir@/clanbomber/\):$(DESTDIR)\1:' \
clanbomber/{,*/}Makefile.in \
- || die "sed failed"
+ || die "sed failed"
epatch "${FILESDIR}/${PV}-no-display.patch"
}
src_compile() {
+ append-flags -I${ROOT}/usr/include/clanlib-0.6.5
+ append-ldflags -L${ROOT}/usr/lib/clanlib-0.6.5
egamesconf || die
emake -j1 || die "emake failed"
}
src_install() {
make DESTDIR=${D} install || die "make install failed"
- dodoc AUTHORS ChangeLog IDEAS QUOTES README TODO || die "dodoc failed"
+ dodoc AUTHORS ChangeLog IDEAS QUOTES README TODO
prepgamesdirs
}
diff --git a/games-arcade/methane/methane-1.4.6.ebuild b/games-arcade/methane/methane-1.4.6.ebuild
index f5c334f7514a..f542f1141531 100644
--- a/games-arcade/methane/methane-1.4.6.ebuild
+++ b/games-arcade/methane/methane-1.4.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/methane/methane-1.4.6.ebuild,v 1.8 2004/08/03 11:51:19 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/methane/methane-1.4.6.ebuild,v 1.9 2004/08/15 08:53:17 vapier Exp $
-inherit games
+inherit games flag-o-matic
DESCRIPTION="Port from an old amiga game"
HOMEPAGE="http://www.methane.fsnet.co.uk/"
@@ -18,10 +18,6 @@ RDEPEND="=dev-games/clanlib-0.6.5*
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
-pkg_setup() {
- clanlib-config 0.6.5
-}
-
src_unpack() {
unpack ${A}
cd ${S}/source/linux
@@ -29,11 +25,13 @@ src_unpack() {
sed -i \
-e 's/^\(MIKMOD_LIBS\)/#\1/g' \
-e 's/^\(METHANE_FLAGS\)/#\1/g' makefile \
- || die "mikmod sed failed"
+ || die "mikmod sed failed"
fi
+ sed -i "s:-lclanCore:-lclanCore -L${ROOT}/usr/lib/clanlib-0.6.5:" makefile
}
src_compile() {
+ append-flags -I${ROOT}/usr/include/clanlib-0.6.5
cd source/linux
emake -j1 || die "emake failed"
}
@@ -42,7 +40,7 @@ src_install() {
dogamesbin source/linux/methane || die "dogamesbin failed"
dodir "${GAMES_STATEDIR}"
touch "${D}/${GAMES_STATEDIR}/methanescores"
- dodoc authors copying history install todo
+ dodoc authors history install todo
dohtml ${S}/docs/*
prepgamesdirs
fperms g+w "${GAMES_STATEDIR}/methanescores"
diff --git a/games-puzzle/pingus/pingus-0.6.0-r1.ebuild b/games-puzzle/pingus/pingus-0.6.0-r1.ebuild
index 73669f4c683a..3f14500bc311 100644
--- a/games-puzzle/pingus/pingus-0.6.0-r1.ebuild
+++ b/games-puzzle/pingus/pingus-0.6.0-r1.ebuild
@@ -1,33 +1,32 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.6.0-r1.ebuild,v 1.6 2004/06/24 23:08:44 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.6.0-r1.ebuild,v 1.7 2004/08/15 08:53:52 vapier Exp $
-inherit eutils games
+inherit games eutils flag-o-matic
DESCRIPTION="free Lemmings clone"
HOMEPAGE="http://pingus.seul.org/"
SRC_URI="http://pingus.seul.org/files/${P}.tar.bz2"
-KEYWORDS="x86"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 amd64"
IUSE="nls opengl"
DEPEND=">=media-libs/hermes-1.3.2-r2
=dev-games/clanlib-0.6.5*
>=dev-libs/libxml2-2.5.6"
-pkg_setup() {
- clanlib-config 0.6.5
-}
-
src_unpack() {
unpack ${A}
cd ${S}
epatch "${FILESDIR}/${PV}-gcc3.patch"
+ autoconf || die
}
src_compile() {
+ append-flags -I${ROOT}/usr/include/clanlib-0.6.5
+ append-ldflags -L${ROOT}/usr/lib/clanlib-0.6.5
egamesconf \
--with-bindir="${GAMES_BINDIR}" \
--with-datadir="${GAMES_DATADIR_BASE}" \
diff --git a/games-sports/trophy/trophy-1.1.3.ebuild b/games-sports/trophy/trophy-1.1.3.ebuild
index 7797e4d3ba5f..7c584631cd84 100644
--- a/games-sports/trophy/trophy-1.1.3.ebuild
+++ b/games-sports/trophy/trophy-1.1.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/trophy/trophy-1.1.3.ebuild,v 1.5 2004/06/24 23:25:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/trophy/trophy-1.1.3.ebuild,v 1.6 2004/08/15 08:54:21 vapier Exp $
-inherit games
+inherit games flag-o-matic
MY_P="${P}-src"
S="${WORKDIR}/${MY_P}"
@@ -12,26 +12,28 @@ SRC_URI="mirror://sourceforge/trophy/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 amd64"
IUSE=""
DEPEND="=dev-games/clanlib-0.6.5*
>=media-libs/hermes-1.3.2
>=sys-libs/zlib-1.1.3"
-pkg_setup() {
- clanlib-config 0.6.5
-}
-
src_unpack() {
unpack ${A}
cd ${S}
find -name ".cvsignore" -exec rm -f \{\} \;
+ sed -i \
+ -e '/^EXTERN_LIBS/s:= := ${LDFLAGS} :' \
+ -e 's:-O3::' \
+ trophy/Makefile.in
}
src_compile() {
cd trophy
autoconf || die "autoconf failed"
+ append-flags -I${ROOT}/usr/include/clanlib-0.6.5
+ append-ldflags -L${ROOT}/usr/lib/clanlib-0.6.5
egamesconf || die
emake || die "emake failed"
}