summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-22 20:21:06 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-22 20:21:06 +0000
commit1623049786c92dc05810fadd9a010e73c7d2df7c (patch)
treea62c10f34a5ee56d5ab55b34f36f485ca41e1e48 /games-simulation/crashtest
parenttransition to the non-no* use flags in libsdl (diff)
downloadgentoo-2-1623049786c92dc05810fadd9a010e73c7d2df7c.tar.gz
gentoo-2-1623049786c92dc05810fadd9a010e73c7d2df7c.tar.bz2
gentoo-2-1623049786c92dc05810fadd9a010e73c7d2df7c.zip
EAPI=2; re-roll patch; work around for bug #237135
(Portage version: 2.1.6.4/cvs/Linux 2.6.28.1 i686)
Diffstat (limited to 'games-simulation/crashtest')
-rw-r--r--games-simulation/crashtest/ChangeLog8
-rw-r--r--games-simulation/crashtest/crashtest-1.0.ebuild18
-rw-r--r--games-simulation/crashtest/files/crashtest-1.0-gentoo.patch102
3 files changed, 84 insertions, 44 deletions
diff --git a/games-simulation/crashtest/ChangeLog b/games-simulation/crashtest/ChangeLog
index 946785aebd6f..4464aa652d44 100644
--- a/games-simulation/crashtest/ChangeLog
+++ b/games-simulation/crashtest/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/crashtest
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/crashtest/ChangeLog,v 1.4 2008/11/14 18:43:38 coldwind Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/crashtest/ChangeLog,v 1.5 2009/01/22 20:21:06 mr_bones_ Exp $
+
+ 22 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ files/crashtest-1.0-gentoo.patch, crashtest-1.0.ebuild:
+ EAPI=2; re-roll patch; work around for bug #237135
14 Nov 2008; Santiago M. Mola <coldwind@gentoo.org> crashtest-1.0.ebuild:
Restrict fltk dependency to SLOT 1.1 (bug #246445).
diff --git a/games-simulation/crashtest/crashtest-1.0.ebuild b/games-simulation/crashtest/crashtest-1.0.ebuild
index 73eb9d8a78a6..37b5211cd49c 100644
--- a/games-simulation/crashtest/crashtest-1.0.ebuild
+++ b/games-simulation/crashtest/crashtest-1.0.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/crashtest/crashtest-1.0.ebuild,v 1.4 2008/11/14 18:43:38 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/crashtest/crashtest-1.0.ebuild,v 1.5 2009/01/22 20:21:06 mr_bones_ Exp $
-EAPI=1
-
-inherit eutils games
+EAPI=2
+inherit eutils flag-o-matic games
DESCRIPTION="Educational car crash simulator"
HOMEPAGE="http://bram.creative4vision.nl/crashtest/"
@@ -15,7 +14,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="x11-libs/fltk:1.1
+RDEPEND="x11-libs/fltk:1.1[opengl]
dev-games/ode
media-libs/alsa-lib
virtual/opengl
@@ -26,22 +25,19 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P}/src-${PN}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/${P}"-gentoo.patch
sed -i \
-e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
-e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
- -e "s:<FL/:<fltk-$(fltk-config --api-version)/FL/:" \
Makefile ${PN}.cxx \
|| die "sed failed"
+ append-flags -DHAVE_ISNANF
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc README
-
make_desktop_entry ${PN} Crashtest
prepgamesdirs
}
diff --git a/games-simulation/crashtest/files/crashtest-1.0-gentoo.patch b/games-simulation/crashtest/files/crashtest-1.0-gentoo.patch
index cd4dada56a28..48a213651a33 100644
--- a/games-simulation/crashtest/files/crashtest-1.0-gentoo.patch
+++ b/games-simulation/crashtest/files/crashtest-1.0-gentoo.patch
@@ -1,36 +1,29 @@
---- crashtest.cxx.old 2007-05-18 19:56:02.000000000 +0200
-+++ crashtest.cxx 2007-05-18 19:58:54.000000000 +0200
-@@ -607,13 +607,7 @@
-
- int main(int argc, char *argv[])
- {
-- char *bindirname = dirname(argv[0]);
-- if (!strcmp(bindirname,"."))
-- dirprefix="/usr/share/games/crashtest";
-- else
-- {
-- dirprefix = dirname(bindirname) + std::string("/share/games/crashtest");
-- }
-+ dirprefix="@GENTOO_DATADIR@";
- if (getenv("PLODE_DATADIR"))
- dirprefix = getenv("PLODE_DATADIR");
- modelmap = new ModelMap(dirprefix);
---- Makefile.old 2007-05-18 20:08:12.000000000 +0200
-+++ Makefile 2007-05-18 20:16:40.000000000 +0200
-@@ -10,19 +10,13 @@
-
- # END OF CUSTOM SETTINGS
-
+diff -ru crashtest-1.0.orig/src-crashtest/Makefile crashtest-1.0/src-crashtest/Makefile
+--- crashtest-1.0.orig/src-crashtest/Makefile 2006-10-25 12:08:52.000000000 -0400
++++ crashtest-1.0/src-crashtest/Makefile 2009-01-22 02:28:47.000000000 -0500
+@@ -1,34 +1,12 @@
+-# EDIT THESE SETTINGS
+-
+-PLIBPREFIX=/usr
+-ODEPREFIX=/usr
+-CXX=g++
+-
+-#PLIBPREFIX=$(HOME)
+-#ODEPREFIX=$(HOME)
+-#CXX=g++-4.0
+-
+-# END OF CUSTOM SETTINGS
+-
-CXXFLAGS=\
- -I$(ODEPREFIX)/include \
- -I$(PLIBPREFIX)/include \
- -I../src-common \
- -O2 -g -Wall
-
- LFLAGS=\
- -L$(PLIBPREFIX)/lib \
- -L/usr/X11R6/lib
-
+-LFLAGS=\
+- -L$(PLIBPREFIX)/lib \
+- -L/usr/X11R6/lib
+-
OBJS=staticworldobject.o crashtest.o dynamicobject.o cartobject.o
-LIBS= $(ODEPREFIX)/lib/libode.a -lplibssgaux -lplibssg -lplibsg -lplibpu -lplibfnt -lplibul -lGLU -lGL -lasound `fltk-config --use-gl --use-images --ldflags` -lglut
@@ -38,7 +31,14 @@
all: crashtest
-@@ -31,10 +31,10 @@
+
+ crashtest: $(OBJS)
+- $(CXX) -o crashtest $(OBJS) $(LFLAGS) $(LIBS)
++ $(CXX) -o crashtest $(OBJS) $(LDFLAGS) $(LIBS)
+
+ staticworldobject.o: ../src-common/staticworldobject.cxx ../src-common/staticworldobject.h ../src-common/worldobject.h
+ $(CXX) -c $(CXXFLAGS) ../src-common/staticworldobject.cxx
+@@ -37,10 +15,10 @@
$(CXX) -c $(CXXFLAGS) ../src-common/dynamicobject.cxx
cartobject.o: cartobject.cxx cartobject.h
@@ -51,7 +51,7 @@
-@@ -48,13 +42,13 @@
+@@ -48,13 +26,13 @@
PLODE_DATADIR=`pwd` ./crashtest
@@ -68,5 +68,45 @@
# Models
install -m 644 models/testground.3ds $(GAMEDIR)/models/testground.3ds
install -m 644 models/biped_torso.3ds $(GAMEDIR)/models/biped_torso.3ds
---- Makefile.old 2007-05-18 20:22:57.000000000 +0200
-+++ Makefile 2007-05-18 20:23:27.000000000 +0200
+Only in crashtest-1.0/src-crashtest: Makefile.orig
+diff -ru crashtest-1.0.orig/src-crashtest/crashtest.cxx crashtest-1.0/src-crashtest/crashtest.cxx
+--- crashtest-1.0.orig/src-crashtest/crashtest.cxx 2006-10-25 11:45:26.000000000 -0400
++++ crashtest-1.0/src-crashtest/crashtest.cxx 2009-01-22 02:32:00.000000000 -0500
+@@ -11,14 +11,14 @@
+
+ #include <GL/glu.h>
+
+-#include <FL/Fl.H>
+-#include <FL/Fl_Box.H>
+-#include <FL/Fl_Button.H>
+-#include <FL/Fl_Check_Button.H>
+-#include <FL/Fl_Chart.H>
+-#include <FL/Fl_Value_Slider.H>
+-#include <FL/Fl_Gl_Window.H>
+-#include <FL/fl_draw.H>
++#include <fltk-1.1/FL/Fl.H>
++#include <fltk-1.1/FL/Fl_Box.H>
++#include <fltk-1.1/FL/Fl_Button.H>
++#include <fltk-1.1/FL/Fl_Check_Button.H>
++#include <fltk-1.1/FL/Fl_Chart.H>
++#include <fltk-1.1/FL/Fl_Value_Slider.H>
++#include <fltk-1.1/FL/Fl_Gl_Window.H>
++#include <fltk-1.1/FL/fl_draw.H>
+
+ #include <plib/ssg.h>
+ #include <plib/ul.h>
+@@ -607,13 +607,7 @@
+
+ int main(int argc, char *argv[])
+ {
+- char *bindirname = dirname(argv[0]);
+- if (!strcmp(bindirname,"."))
+- dirprefix="/usr/share/games/crashtest";
+- else
+- {
+- dirprefix = dirname(bindirname) + std::string("/share/games/crashtest");
+- }
++ dirprefix="@GENTOO_DATADIR@";
+ if (getenv("PLODE_DATADIR"))
+ dirprefix = getenv("PLODE_DATADIR");
+ modelmap = new ModelMap(dirprefix);