summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/crashtest/crashtest-1.0.ebuild')
-rw-r--r--games-simulation/crashtest/crashtest-1.0.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/games-simulation/crashtest/crashtest-1.0.ebuild b/games-simulation/crashtest/crashtest-1.0.ebuild
index 73eb9d8a78a6..37b5211cd49c 100644
--- a/games-simulation/crashtest/crashtest-1.0.ebuild
+++ b/games-simulation/crashtest/crashtest-1.0.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/crashtest/crashtest-1.0.ebuild,v 1.4 2008/11/14 18:43:38 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/crashtest/crashtest-1.0.ebuild,v 1.5 2009/01/22 20:21:06 mr_bones_ Exp $
-EAPI=1
-
-inherit eutils games
+EAPI=2
+inherit eutils flag-o-matic games
DESCRIPTION="Educational car crash simulator"
HOMEPAGE="http://bram.creative4vision.nl/crashtest/"
@@ -15,7 +14,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="x11-libs/fltk:1.1
+RDEPEND="x11-libs/fltk:1.1[opengl]
dev-games/ode
media-libs/alsa-lib
virtual/opengl
@@ -26,22 +25,19 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P}/src-${PN}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/${P}"-gentoo.patch
sed -i \
-e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
-e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
- -e "s:<FL/:<fltk-$(fltk-config --api-version)/FL/:" \
Makefile ${PN}.cxx \
|| die "sed failed"
+ append-flags -DHAVE_ISNANF
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc README
-
make_desktop_entry ${PN} Crashtest
prepgamesdirs
}