summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-01-25 17:48:35 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-01-25 17:48:35 +0000
commit53354bcc637f6cf0d6c2e8876e14e10ff11f4f0a (patch)
tree658c864990a97813b64e8da5b58e45d0471508b1 /games-rpg
parentDon't hard-depend on gtk-doc, fixes bug 302150 (diff)
downloadgentoo-2-53354bcc637f6cf0d6c2e8876e14e10ff11f4f0a.tar.gz
gentoo-2-53354bcc637f6cf0d6c2e8876e14e10ff11f4f0a.tar.bz2
gentoo-2-53354bcc637f6cf0d6c2e8876e14e10ff11f4f0a.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/freedroidrpg/ChangeLog10
-rw-r--r--games-rpg/freedroidrpg/files/freedroidrpg-0.13-syslibs.patch102
-rw-r--r--games-rpg/freedroidrpg/freedroidrpg-0.13.ebuild55
3 files changed, 165 insertions, 2 deletions
diff --git a/games-rpg/freedroidrpg/ChangeLog b/games-rpg/freedroidrpg/ChangeLog
index c1944b4c385b..0c3ff5753fd1 100644
--- a/games-rpg/freedroidrpg/ChangeLog
+++ b/games-rpg/freedroidrpg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/freedroidrpg
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/freedroidrpg/ChangeLog,v 1.22 2009/08/29 18:10:39 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/freedroidrpg/ChangeLog,v 1.23 2010/01/25 17:48:35 mr_bones_ Exp $
+
+*freedroidrpg-0.13 (25 Jan 2010)
+
+ 25 Jan 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +freedroidrpg-0.13.ebuild, +files/freedroidrpg-0.13-syslibs.patch:
+ version bump
29 Aug 2009; nixnut <nixnut@gentoo.org> freedroidrpg-0.12.1-r1.ebuild:
ppc stable #275893
diff --git a/games-rpg/freedroidrpg/files/freedroidrpg-0.13-syslibs.patch b/games-rpg/freedroidrpg/files/freedroidrpg-0.13-syslibs.patch
new file mode 100644
index 000000000000..0e0209d78d6e
--- /dev/null
+++ b/games-rpg/freedroidrpg/files/freedroidrpg-0.13-syslibs.patch
@@ -0,0 +1,102 @@
+diff -ru freedroidrpg-0.13.orig/configure.ac freedroidrpg-0.13/configure.ac
+--- freedroidrpg-0.13.orig/configure.ac 2010-01-21 07:56:26.000000000 -0500
++++ freedroidrpg-0.13/configure.ac 2010-01-25 11:32:51.795551904 -0500
+@@ -109,6 +109,14 @@
+ AC_MSG_ERROR([SDL_image library needed for FreedroidRPG!
+ see http://www.libsdl.org/]))
+
++AC_CHECK_LIB([SDL_gfx], [rotozoomSurface],,
++ AC_MSG_ERROR([SDL_gfx library needed to run FreedroidRPG
++see http://www.ferzkopp.net/Software/SDL_gfx-2.0/]))
++
++AC_CHECK_LIB([lua], [luaL_openlibs],,
++ AC_MSG_ERROR([lua library needed to run FreedroidRPG
++see http://www.lua.org/]))
++
+ AC_MSG_NOTICE([[Checking for optional SDL libraries:]])
+ AC_CHECK_LIB([SDL_mixer], [Mix_ChannelFinished],, AC_MSG_WARN([
+ --------------------------------------------------
+diff -ru freedroidrpg-0.13.orig/src/Makefile.am freedroidrpg-0.13/src/Makefile.am
+--- freedroidrpg-0.13.orig/src/Makefile.am 2010-01-21 07:31:29.000000000 -0500
++++ freedroidrpg-0.13/src/Makefile.am 2010-01-25 11:34:48.618487853 -0500
+@@ -1,9 +1,7 @@
+ ## Process this file with automake to produce Makefile.in
+
+-freedroidRPG_LDADD = ../lua/liblua.a
+-
+ if WIN32
+-freedroidRPG_LDADD += ../win32/freedroidRPG.coff
++freedroidRPG_LDADD = ../win32/freedroidRPG.coff
+ endif
+
+ bin_PROGRAMS = freedroidRPG
+@@ -18,7 +16,7 @@
+ enemy.c input.c keyboard.c main.c hud.c view.c automap.c BFont.c \
+ defs.h map.h vars.h takeover.h global.h \
+ proto.h struct.h system.h BFont.h \
+- SDL_rotozoom.c SDL_rotozoom.h open_gl.c open_gl_atlas.c mission.c chat.c light.c \
++ open_gl.c open_gl_atlas.c mission.c chat.c light.c \
+ getopt.c getopt1.c getopt.h scandir.c scandir.h sound.h sound_effects.c \
+ lang.h lists.c lists.h gen_savestruct.py savestruct.c savestruct.h string.c pathfinder.c \
+ benchmark.c \
+@@ -45,12 +43,3 @@
+
+ savestruct.c savestruct.h: struct.h gen_savestruct.py
+ python gen_savestruct.py struct.h savestruct
+-
+-clean-local:
+- cd ../lua; make clean
+-
+-../lua/liblua.a:
+- cd ../lua; make CC=${CC} AR="${AR} rcu" liblua.a
+-if WIN32
+- i686-pc-mingw32-ranlib ../lua/liblua.a
+-endif
+diff -ru freedroidrpg-0.13.orig/src/lua.c freedroidrpg-0.13/src/lua.c
+--- freedroidrpg-0.13.orig/src/lua.c 2010-01-21 07:31:29.000000000 -0500
++++ freedroidrpg-0.13/src/lua.c 2010-01-25 11:33:27.344703642 -0500
+@@ -37,9 +37,9 @@
+ #include "lvledit/lvledit_actions.h"
+ #include "lvledit/lvledit_map.h"
+
+-#include "../lua/lua.h"
+-#include "../lua/lauxlib.h"
+-#include "../lua/lualib.h"
++#include <lua.h>
++#include <lauxlib.h>
++#include <lualib.h>
+
+ /* Our Lua state for event execution */
+ lua_State *global_lua_state;
+diff -ru freedroidrpg-0.13.orig/src/struct.h freedroidrpg-0.13/src/struct.h
+--- freedroidrpg-0.13.orig/src/struct.h 2010-01-21 07:31:29.000000000 -0500
++++ freedroidrpg-0.13/src/struct.h 2010-01-25 11:35:34.764604580 -0500
+@@ -30,16 +30,7 @@
+ #include "system.h"
+ #include "defs.h"
+
+-typedef struct tColorRGBA {
+- Uint8 r;
+- Uint8 g;
+- Uint8 b;
+- Uint8 a;
+-} tColorRGBA, myColor;
+-
+-typedef struct tColorY {
+- Uint8 y;
+-} tColorY;
++typedef tColorRGBA myColor;
+
+ /**
+ * Simple doubly linked list implementation.
+diff -ru freedroidrpg-0.13.orig/src/system.h freedroidrpg-0.13/src/system.h
+--- freedroidrpg-0.13.orig/src/system.h 2010-01-21 07:31:29.000000000 -0500
++++ freedroidrpg-0.13/src/system.h 2010-01-25 11:35:53.944486530 -0500
+@@ -111,6 +111,7 @@
+
+ #include "SDL.h"
+ #include "SDL_image.h"
++#include "SDL_rotozoom.h"
+
+ #ifdef HAVE_LIBSDL_MIXER
+ #include "SDL_mixer.h"
diff --git a/games-rpg/freedroidrpg/freedroidrpg-0.13.ebuild b/games-rpg/freedroidrpg/freedroidrpg-0.13.ebuild
new file mode 100644
index 000000000000..9b7406b94186
--- /dev/null
+++ b/games-rpg/freedroidrpg/freedroidrpg-0.13.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/freedroidrpg/freedroidrpg-0.13.ebuild,v 1.1 2010/01/25 17:48:35 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="A modification of the classical Freedroid engine into an RPG"
+HOMEPAGE="http://freedroid.sourceforge.net/"
+SRC_URI="mirror://sourceforge/freedroid/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="opengl"
+
+RDEPEND="media-libs/libsdl[video]
+ dev-lang/lua
+ media-libs/jpeg
+ media-libs/libpng
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-net
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-gfx
+ media-libs/libogg
+ media-libs/libvorbis
+ x11-libs/libX11
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ x11-libs/libXt
+ dev-lang/python"
+
+src_prepare() {
+ rm -rf lua src/SDL_rotozoom*
+ epatch "${FILESDIR}"/${P}-syslibs.patch
+
+ # No need for executable game resources
+ find sound graphics -type f -exec chmod -c a-x '{}' +
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-fastmath \
+ $(use_enable opengl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}/${GAMES_BINDIR}/"{croppy,pngtoico,gluem}
+ newicon win32/w32icon2_64x64.png ${PN}.png
+ make_desktop_entry freedroidRPG "Freedroid RPG"
+ prepgamesdirs
+}