summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/freedroidrpg/files/freedroidrpg-0.13-syslibs.patch')
-rw-r--r--games-rpg/freedroidrpg/files/freedroidrpg-0.13-syslibs.patch102
1 files changed, 102 insertions, 0 deletions
diff --git a/games-rpg/freedroidrpg/files/freedroidrpg-0.13-syslibs.patch b/games-rpg/freedroidrpg/files/freedroidrpg-0.13-syslibs.patch
new file mode 100644
index 000000000000..0e0209d78d6e
--- /dev/null
+++ b/games-rpg/freedroidrpg/files/freedroidrpg-0.13-syslibs.patch
@@ -0,0 +1,102 @@
+diff -ru freedroidrpg-0.13.orig/configure.ac freedroidrpg-0.13/configure.ac
+--- freedroidrpg-0.13.orig/configure.ac 2010-01-21 07:56:26.000000000 -0500
++++ freedroidrpg-0.13/configure.ac 2010-01-25 11:32:51.795551904 -0500
+@@ -109,6 +109,14 @@
+ AC_MSG_ERROR([SDL_image library needed for FreedroidRPG!
+ see http://www.libsdl.org/]))
+
++AC_CHECK_LIB([SDL_gfx], [rotozoomSurface],,
++ AC_MSG_ERROR([SDL_gfx library needed to run FreedroidRPG
++see http://www.ferzkopp.net/Software/SDL_gfx-2.0/]))
++
++AC_CHECK_LIB([lua], [luaL_openlibs],,
++ AC_MSG_ERROR([lua library needed to run FreedroidRPG
++see http://www.lua.org/]))
++
+ AC_MSG_NOTICE([[Checking for optional SDL libraries:]])
+ AC_CHECK_LIB([SDL_mixer], [Mix_ChannelFinished],, AC_MSG_WARN([
+ --------------------------------------------------
+diff -ru freedroidrpg-0.13.orig/src/Makefile.am freedroidrpg-0.13/src/Makefile.am
+--- freedroidrpg-0.13.orig/src/Makefile.am 2010-01-21 07:31:29.000000000 -0500
++++ freedroidrpg-0.13/src/Makefile.am 2010-01-25 11:34:48.618487853 -0500
+@@ -1,9 +1,7 @@
+ ## Process this file with automake to produce Makefile.in
+
+-freedroidRPG_LDADD = ../lua/liblua.a
+-
+ if WIN32
+-freedroidRPG_LDADD += ../win32/freedroidRPG.coff
++freedroidRPG_LDADD = ../win32/freedroidRPG.coff
+ endif
+
+ bin_PROGRAMS = freedroidRPG
+@@ -18,7 +16,7 @@
+ enemy.c input.c keyboard.c main.c hud.c view.c automap.c BFont.c \
+ defs.h map.h vars.h takeover.h global.h \
+ proto.h struct.h system.h BFont.h \
+- SDL_rotozoom.c SDL_rotozoom.h open_gl.c open_gl_atlas.c mission.c chat.c light.c \
++ open_gl.c open_gl_atlas.c mission.c chat.c light.c \
+ getopt.c getopt1.c getopt.h scandir.c scandir.h sound.h sound_effects.c \
+ lang.h lists.c lists.h gen_savestruct.py savestruct.c savestruct.h string.c pathfinder.c \
+ benchmark.c \
+@@ -45,12 +43,3 @@
+
+ savestruct.c savestruct.h: struct.h gen_savestruct.py
+ python gen_savestruct.py struct.h savestruct
+-
+-clean-local:
+- cd ../lua; make clean
+-
+-../lua/liblua.a:
+- cd ../lua; make CC=${CC} AR="${AR} rcu" liblua.a
+-if WIN32
+- i686-pc-mingw32-ranlib ../lua/liblua.a
+-endif
+diff -ru freedroidrpg-0.13.orig/src/lua.c freedroidrpg-0.13/src/lua.c
+--- freedroidrpg-0.13.orig/src/lua.c 2010-01-21 07:31:29.000000000 -0500
++++ freedroidrpg-0.13/src/lua.c 2010-01-25 11:33:27.344703642 -0500
+@@ -37,9 +37,9 @@
+ #include "lvledit/lvledit_actions.h"
+ #include "lvledit/lvledit_map.h"
+
+-#include "../lua/lua.h"
+-#include "../lua/lauxlib.h"
+-#include "../lua/lualib.h"
++#include <lua.h>
++#include <lauxlib.h>
++#include <lualib.h>
+
+ /* Our Lua state for event execution */
+ lua_State *global_lua_state;
+diff -ru freedroidrpg-0.13.orig/src/struct.h freedroidrpg-0.13/src/struct.h
+--- freedroidrpg-0.13.orig/src/struct.h 2010-01-21 07:31:29.000000000 -0500
++++ freedroidrpg-0.13/src/struct.h 2010-01-25 11:35:34.764604580 -0500
+@@ -30,16 +30,7 @@
+ #include "system.h"
+ #include "defs.h"
+
+-typedef struct tColorRGBA {
+- Uint8 r;
+- Uint8 g;
+- Uint8 b;
+- Uint8 a;
+-} tColorRGBA, myColor;
+-
+-typedef struct tColorY {
+- Uint8 y;
+-} tColorY;
++typedef tColorRGBA myColor;
+
+ /**
+ * Simple doubly linked list implementation.
+diff -ru freedroidrpg-0.13.orig/src/system.h freedroidrpg-0.13/src/system.h
+--- freedroidrpg-0.13.orig/src/system.h 2010-01-21 07:31:29.000000000 -0500
++++ freedroidrpg-0.13/src/system.h 2010-01-25 11:35:53.944486530 -0500
+@@ -111,6 +111,7 @@
+
+ #include "SDL.h"
+ #include "SDL_image.h"
++#include "SDL_rotozoom.h"
+
+ #ifdef HAVE_LIBSDL_MIXER
+ #include "SDL_mixer.h"