summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-11-21 17:51:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-11-21 17:51:22 +0000
commit7db4008560dcd1d64db18ff4db1224a1f06c6e3f (patch)
tree83f7faa864f8928fafd0c167e053c5a63d9fe19c /games-kids/gcompris/gcompris-6.5.3-r1.ebuild
parentNew patchset, patchutils messed up the sip header fix. (diff)
downloadgentoo-2-7db4008560dcd1d64db18ff4db1224a1f06c6e3f.tar.gz
gentoo-2-7db4008560dcd1d64db18ff4db1224a1f06c6e3f.tar.bz2
gentoo-2-7db4008560dcd1d64db18ff4db1224a1f06c6e3f.zip
rev bump to run off python support until python 2.4 is supported by upstream
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'games-kids/gcompris/gcompris-6.5.3-r1.ebuild')
-rw-r--r--games-kids/gcompris/gcompris-6.5.3-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/games-kids/gcompris/gcompris-6.5.3-r1.ebuild b/games-kids/gcompris/gcompris-6.5.3-r1.ebuild
new file mode 100644
index 000000000000..631124beacf5
--- /dev/null
+++ b/games-kids/gcompris/gcompris-6.5.3-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/gcompris-6.5.3-r1.ebuild,v 1.1 2005/11/21 17:51:22 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="full featured educational application for children from 2 to 10"
+HOMEPAGE="http://gcompris.net"
+SRC_URI="mirror://sourceforge/gcompris/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+#IUSE="python editor" #editor didn't compile for me.; doesn't like python-2.4
+IUSE=""
+
+RDEPEND="virtual/x11
+ >=dev-libs/glib-2.0
+ =x11-libs/gtk+-2*
+ >=gnome-base/libgnomecanvas-2.0.2
+ media-libs/sdl-mixer
+ media-libs/libsdl
+ dev-libs/libxml2
+ dev-libs/popt
+ games-board/gnuchess
+ editor? (
+ >=gnome-base/libgnome-1.96.0
+ >=gnome-base/libgnomeui-1.96.0
+ )"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ app-text/texi2html"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^install-data-am/s/install-libgcomprisincludeHEADERS//' \
+ src/gcompris/Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ export GNUCHESS="${GAMES_BINDIR}/gnuchess"
+ # $(use_with editor) - editor didn't compile for me.
+ # $(use_with python python /usr/bin/python) - doesn't seem to work with 2.4
+ econf \
+ --disable-dependency-tracking \
+ --without-python \
+ --without-editor \
+ || die
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ # Crashed for me
+ rm -rf "${D}/usr/share/gcompris/boards/watercycle"*
+ rm -f "${D}/usr/share/gcompris/boards/followline.xml"
+ # mailing list reports crash
+ rm -f "${D}/usr/share/gcompris/boards/click_on_letter.xml"
+ use editor || rm -f "${D}/usr/share/applications/gcompris-edit.desktop"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ prepgamesdirs
+}