summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-11-21 17:51:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-11-21 17:51:22 +0000
commit7db4008560dcd1d64db18ff4db1224a1f06c6e3f (patch)
tree83f7faa864f8928fafd0c167e053c5a63d9fe19c /games-kids
parentNew patchset, patchutils messed up the sip header fix. (diff)
downloadgentoo-2-7db4008560dcd1d64db18ff4db1224a1f06c6e3f.tar.gz
gentoo-2-7db4008560dcd1d64db18ff4db1224a1f06c6e3f.tar.bz2
gentoo-2-7db4008560dcd1d64db18ff4db1224a1f06c6e3f.zip
rev bump to run off python support until python 2.4 is supported by upstream
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/gcompris/ChangeLog8
-rw-r--r--games-kids/gcompris/Manifest2
-rw-r--r--games-kids/gcompris/files/digest-gcompris-6.5.3-r11
-rw-r--r--games-kids/gcompris/gcompris-6.5.3-r1.ebuild65
4 files changed, 75 insertions, 1 deletions
diff --git a/games-kids/gcompris/ChangeLog b/games-kids/gcompris/ChangeLog
index 2617cd12b584..d2c0303a46c5 100644
--- a/games-kids/gcompris/ChangeLog
+++ b/games-kids/gcompris/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-kids/gcompris
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/ChangeLog,v 1.17 2005/09/16 22:14:21 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/ChangeLog,v 1.18 2005/11/21 17:51:22 mr_bones_ Exp $
+
+*gcompris-6.5.3-r1 (21 Nov 2005)
+
+ 21 Nov 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +gcompris-6.5.3-r1.ebuild:
+ rev bump to run off python support until python 2.4 is supported by upstream
16 Sep 2005; Ciaran McCreesh <ciaranm@gentoo.org> ChangeLog:
Converted to UTF-8, fixed encoding screwups
diff --git a/games-kids/gcompris/Manifest b/games-kids/gcompris/Manifest
index 04f1df7521b3..2a7c33370e57 100644
--- a/games-kids/gcompris/Manifest
+++ b/games-kids/gcompris/Manifest
@@ -1,4 +1,6 @@
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 a2e8c22744806ba76f448162d88feaca gcompris-6.5.3-r1.ebuild 1794
MD5 8cdf0116edbb15a870577e2cf40e91e0 ChangeLog 2667
MD5 0f3e1b204624641e356707b88dce2171 gcompris-6.5.3.ebuild 1784
MD5 557b7f4481b6c30ca79251c8a19af714 files/digest-gcompris-6.5.3 68
+MD5 557b7f4481b6c30ca79251c8a19af714 files/digest-gcompris-6.5.3-r1 68
diff --git a/games-kids/gcompris/files/digest-gcompris-6.5.3-r1 b/games-kids/gcompris/files/digest-gcompris-6.5.3-r1
new file mode 100644
index 000000000000..3e0d15c3f1e1
--- /dev/null
+++ b/games-kids/gcompris/files/digest-gcompris-6.5.3-r1
@@ -0,0 +1 @@
+MD5 11cc5c1fe2ebb583767884e18307534e gcompris-6.5.3.tar.gz 43519786
diff --git a/games-kids/gcompris/gcompris-6.5.3-r1.ebuild b/games-kids/gcompris/gcompris-6.5.3-r1.ebuild
new file mode 100644
index 000000000000..631124beacf5
--- /dev/null
+++ b/games-kids/gcompris/gcompris-6.5.3-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/gcompris-6.5.3-r1.ebuild,v 1.1 2005/11/21 17:51:22 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="full featured educational application for children from 2 to 10"
+HOMEPAGE="http://gcompris.net"
+SRC_URI="mirror://sourceforge/gcompris/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+#IUSE="python editor" #editor didn't compile for me.; doesn't like python-2.4
+IUSE=""
+
+RDEPEND="virtual/x11
+ >=dev-libs/glib-2.0
+ =x11-libs/gtk+-2*
+ >=gnome-base/libgnomecanvas-2.0.2
+ media-libs/sdl-mixer
+ media-libs/libsdl
+ dev-libs/libxml2
+ dev-libs/popt
+ games-board/gnuchess
+ editor? (
+ >=gnome-base/libgnome-1.96.0
+ >=gnome-base/libgnomeui-1.96.0
+ )"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ app-text/texi2html"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^install-data-am/s/install-libgcomprisincludeHEADERS//' \
+ src/gcompris/Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ export GNUCHESS="${GAMES_BINDIR}/gnuchess"
+ # $(use_with editor) - editor didn't compile for me.
+ # $(use_with python python /usr/bin/python) - doesn't seem to work with 2.4
+ econf \
+ --disable-dependency-tracking \
+ --without-python \
+ --without-editor \
+ || die
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ # Crashed for me
+ rm -rf "${D}/usr/share/gcompris/boards/watercycle"*
+ rm -f "${D}/usr/share/gcompris/boards/followline.xml"
+ # mailing list reports crash
+ rm -f "${D}/usr/share/gcompris/boards/click_on_letter.xml"
+ use editor || rm -f "${D}/usr/share/applications/gcompris-edit.desktop"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ prepgamesdirs
+}