summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-11-21 21:16:53 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-11-21 21:16:53 +0000
commit479128f6c6b32eec3492e96e780e96b550dd50a5 (patch)
tree8013da9c0cce731cb1f2abea5030549fd5f83196 /games-fps/quakeforge
parentStable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt b... (diff)
downloadgentoo-2-479128f6c6b32eec3492e96e780e96b550dd50a5.tar.gz
gentoo-2-479128f6c6b32eec3492e96e780e96b550dd50a5.tar.bz2
gentoo-2-479128f6c6b32eec3492e96e780e96b550dd50a5.zip
Version bump to 0.7.0 Bug #405287
(Portage version: 2.1.11.31/cvs/Linux i686, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-fps/quakeforge')
-rw-r--r--games-fps/quakeforge/ChangeLog8
-rw-r--r--games-fps/quakeforge/files/quakeforge-0.7.0-gentoo.patch33
-rw-r--r--games-fps/quakeforge/quakeforge-0.7.0.ebuild126
3 files changed, 166 insertions, 1 deletions
diff --git a/games-fps/quakeforge/ChangeLog b/games-fps/quakeforge/ChangeLog
index 317a0b32b134..2d8bc8b549d8 100644
--- a/games-fps/quakeforge/ChangeLog
+++ b/games-fps/quakeforge/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/quakeforge
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/ChangeLog,v 1.32 2012/06/23 14:17:57 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/ChangeLog,v 1.33 2012/11/21 21:16:52 tupone Exp $
+
+*quakeforge-0.7.0 (21 Nov 2012)
+
+ 21 Nov 2012; Tupone Alfredo <tupone@gentoo.org> +quakeforge-0.7.0.ebuild,
+ +files/quakeforge-0.7.0-gentoo.patch:
+ Version bump to 0.7.0 Bug #405287 by Tim
23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -quakeforge-0.5.5.ebuild:
old
diff --git a/games-fps/quakeforge/files/quakeforge-0.7.0-gentoo.patch b/games-fps/quakeforge/files/quakeforge-0.7.0-gentoo.patch
new file mode 100644
index 000000000000..be0679c9640e
--- /dev/null
+++ b/games-fps/quakeforge/files/quakeforge-0.7.0-gentoo.patch
@@ -0,0 +1,33 @@
+--- nq/source/Makefile.am.old 2012-11-18 16:57:56.658388682 +0100
++++ nq/source/Makefile.am 2012-11-18 16:58:11.470268607 +0100
+@@ -138,7 +138,7 @@
+ nq_x11_SOURCES= sys_unix.c
+ nq_x11_LDADD= $(nq_x11_libs) \
+ $(VIDMODE_LIBS) $(DGA_LIBS) $(X_LIBS) -lX11 \
+- $(X_EXTRA_LIBS) $(X_SHM_LIB) $(NET_LIBS)
++ $(X_EXTRA_LIBS) $(X_SHM_LIB) $(NET_LIBS) -ldl
+ nq_x11_LDFLAGS= $(common_ldflags)
+ nq_x11_DEPENDENCIES= $(nq_x11_libs)
+
+--- qw/source/Makefile.am.old 2012-11-18 17:10:59.148172332 +0100
++++ qw/source/Makefile.am 2012-11-18 17:11:55.866876762 +0100
+@@ -169,7 +169,7 @@
+ qw_client_x11_SOURCES= cl_sys_unix.c
+ qw_client_x11_LDADD= $(qw_client_x11_libs) \
+ $(VIDMODE_LIBS) $(DGA_LIBS) $(X_LIBS) -lX11 \
+- $(X_EXTRA_LIBS) $(X_SHM_LIB) $(NET_LIBS) $(LIBCURL_LIBS)
++ $(X_EXTRA_LIBS) $(X_SHM_LIB) $(NET_LIBS) $(LIBCURL_LIBS) -ldl
+ qw_client_x11_LDFLAGS= $(common_ldflags)
+ qw_client_x11_DEPENDENCIES= $(qw_client_x11_libs)
+
+--- tools/qwaq/Makefile.am.old 2012-11-18 17:15:16.024714317 +0100
++++ tools/qwaq/Makefile.am 2012-11-18 17:15:41.955749660 +0100
+@@ -38,7 +38,7 @@
+ qwaq_x11_SOURCES=qwaq.c qwaq-bi.c
+ qwaq_x11_LDADD= $(qwaq_x11_libs) $(QWAQ_LIBS) \
+ $(VIDMODE_LIBS) $(DGA_LIBS) $(X_LIBS) -lX11 \
+- $(X_EXTRA_LIBS) $(X_SHM_LIB)
++ $(X_EXTRA_LIBS) $(X_SHM_LIB) -ldl
+ qwaq_x11_LDFLAGS=
+ qwaq_x11_DEPENDENCIES= $(qwaq_x11_libs) $(QWAQ_DEPS)
+
diff --git a/games-fps/quakeforge/quakeforge-0.7.0.ebuild b/games-fps/quakeforge/quakeforge-0.7.0.ebuild
new file mode 100644
index 000000000000..a47a1df5e690
--- /dev/null
+++ b/games-fps/quakeforge/quakeforge-0.7.0.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/quakeforge-0.7.0.ebuild,v 1.1 2012/11/21 21:16:52 tupone Exp $
+
+EAPI=4
+inherit base eutils autotools games
+
+DESCRIPTION="A new 3d engine based off of id Softwares's legendary Quake and QuakeWorld game engine"
+HOMEPAGE="http://www.quakeforge.net/"
+SRC_URI="mirror://sourceforge/quake/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="cdinstall debug fbcon flac opengl sdl svga X ncurses png vorbis zlib ipv6 xv dga alsa oss"
+RESTRICT="userpriv"
+
+RDEPEND="
+ media-libs/libsamplerate
+ net-misc/curl
+ png? ( media-libs/libpng )
+ flac? ( media-libs/flac )
+ opengl? ( virtual/opengl )
+ sdl? ( media-libs/libsdl )
+ svga? ( media-libs/svgalib )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ )
+ ncurses? ( sys-libs/ncurses )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ zlib? ( sys-libs/zlib )
+ xv? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86vm
+ )
+ dga? ( x11-libs/libXxf86dga )
+ alsa? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}
+ cdinstall? ( games-fps/quake1-data )
+ sys-devel/bison
+ sys-devel/flex"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ eautoreconf
+}
+
+src_configure() {
+ local debugopts
+ use debug \
+ && debugopts="--enable-debug --disable-optimize --enable-profile" \
+ || debugopts="--disable-debug --disable-profile"
+
+ local clients=${QF_CLIENTS}
+ use fbcon && clients="${clients},fbdev"
+ use opengl && clients="${clients},glx"
+ use sdl && clients="${clients},sdl,sdl32"
+ use sdl && use opengl && clients="${clients},sgl"
+ use svga && clients="${clients},svga"
+ use X && clients="${clients},x11"
+ use X && use opengl && clients="${clients},wgl"
+ [ "${clients:0:1}" == "," ] && clients=${clients:1}
+
+ local servers=${QF_SERVERS:-master,nq,qw,qtv}
+
+ local tools=${QF_TOOLS:-all}
+
+ local svgaconf # use old school way for broken conf opts
+ use svga \
+ && svgaconf="--with-svga=/usr" \
+ || svgaconf="--without-svga"
+
+ addpredict "$(games_get_libdir)"
+ egamesconf \
+ $(use_enable ncurses curses) \
+ $(use_enable vorbis) \
+ $(use_enable png) \
+ $(use_enable zlib) \
+ $(use_with ipv6) \
+ $(use_with fbcon fbdev) \
+ ${svgaconf} \
+ $(use_with X x) \
+ $(use_enable xv vidmode) \
+ $(use_enable dga) \
+ $(use_enable sdl) \
+ --disable-xmms \
+ $(use_enable alsa) \
+ $(use_enable flac) \
+ $(use_enable oss) \
+ --enable-sound \
+ --disable-optimize \
+ ${debugopts} \
+ --with-global-cfg="${GAMES_SYSCONFDIR}"/quakeforge.conf \
+ --with-sharepath="${GAMES_DATADIR}"/quake1 \
+ --with-clients=${clients} \
+ --with-servers=${servers} \
+ --with-tools=${tools}
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ mv "${D}/${GAMES_PREFIX}"/include "${D}"/usr/
+ dodoc ChangeLog NEWS TODO
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ # same warning used in quake1 / quakeforge / nprquake-sdl
+ games_pkg_postinst
+ echo
+ elog "Before you can play, you must make sure"
+ elog "${PN} can find your Quake .pak files"
+ elog
+ elog "You have 2 choices to do this"
+ elog "1 Copy pak*.pak files to ${GAMES_DATADIR}/quake1/id1"
+ elog "2 Symlink pak*.pak files in ${GAMES_DATADIR}/quake1/id1"
+ elog
+ elog "Example:"
+ elog "my pak*.pak files are in /mnt/secondary/Games/Quake/Id1/"
+ elog "ln -s /mnt/secondary/Games/Quake/Id1/pak0.pak ${GAMES_DATADIR}/quake1/id1/pak0.pak"
+ elog
+ elog "You only need pak0.pak to play the demo version,"
+ elog "the others are needed for registered version"
+}