summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-12-16 16:41:59 +0000
committerMichał Górny <mgorny@gentoo.org>2013-12-16 16:41:59 +0000
commit28e3f501ffd1db5b632234348783e46e83a5d317 (patch)
treed86dacc7c6ec9b5a3207f107f821a122e8ca1ea4 /games-emulation
parentRemove implicit CPU flags from the Makefiles. Support epatch_user. (diff)
downloadgentoo-2-28e3f501ffd1db5b632234348783e46e83a5d317.tar.gz
gentoo-2-28e3f501ffd1db5b632234348783e46e83a5d317.tar.bz2
gentoo-2-28e3f501ffd1db5b632234348783e46e83a5d317.zip
Remove implicit CPU flags from the Makefiles. Support epatch_user.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64plus-input-sdl/ChangeLog6
-rw-r--r--games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.0.ebuild9
2 files changed, 13 insertions, 2 deletions
diff --git a/games-emulation/mupen64plus-input-sdl/ChangeLog b/games-emulation/mupen64plus-input-sdl/ChangeLog
index 2c8b4e5a482f..9c508d166048 100644
--- a/games-emulation/mupen64plus-input-sdl/ChangeLog
+++ b/games-emulation/mupen64plus-input-sdl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/mupen64plus-input-sdl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-input-sdl/ChangeLog,v 1.1 2013/12/15 12:09:42 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-input-sdl/ChangeLog,v 1.2 2013/12/16 16:41:59 mgorny Exp $
+
+ 16 Dec 2013; Michał Górny <mgorny@gentoo.org>
+ mupen64plus-input-sdl-2.0.ebuild:
+ Remove implicit CPU flags from the Makefiles. Support epatch_user.
*mupen64plus-input-sdl-2.0 (15 Dec 2013)
diff --git a/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.0.ebuild b/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.0.ebuild
index 99cd3973b5da..391cff417476 100644
--- a/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.0.ebuild
+++ b/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.0.ebuild,v 1.1 2013/12/15 12:09:41 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.0.ebuild,v 1.2 2013/12/16 16:41:59 mgorny Exp $
EAPI=5
@@ -23,6 +23,13 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ epatch_user
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
src_compile() {
MAKEARGS=(
# Note: please keep this in sync in all of mupen64plus-* packages