summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-12-16 16:41:58 +0000
committerMichał Górny <mgorny@gentoo.org>2013-12-16 16:41:58 +0000
commitf70e12cf99e7d8de41471e7b3343f18699e36935 (patch)
treec656e3eeb096ea1aac8bfad402970b81371cda93 /games-emulation
parentRemove implicit CPU flags from the Makefiles. Support epatch_user. (diff)
downloadgentoo-2-f70e12cf99e7d8de41471e7b3343f18699e36935.tar.gz
gentoo-2-f70e12cf99e7d8de41471e7b3343f18699e36935.tar.bz2
gentoo-2-f70e12cf99e7d8de41471e7b3343f18699e36935.zip
Remove implicit CPU flags from the Makefiles. Support epatch_user.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64plus-rsp-hle/ChangeLog5
-rw-r--r--games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.0.ebuild9
2 files changed, 12 insertions, 2 deletions
diff --git a/games-emulation/mupen64plus-rsp-hle/ChangeLog b/games-emulation/mupen64plus-rsp-hle/ChangeLog
index ebd5682c5f01..852277db9e19 100644
--- a/games-emulation/mupen64plus-rsp-hle/ChangeLog
+++ b/games-emulation/mupen64plus-rsp-hle/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/mupen64plus-rsp-hle
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-rsp-hle/ChangeLog,v 1.1 2013/12/15 12:10:36 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-rsp-hle/ChangeLog,v 1.2 2013/12/16 16:41:58 mgorny Exp $
+
+ 16 Dec 2013; Michał Górny <mgorny@gentoo.org> mupen64plus-rsp-hle-2.0.ebuild:
+ Remove implicit CPU flags from the Makefiles. Support epatch_user.
*mupen64plus-rsp-hle-2.0 (15 Dec 2013)
diff --git a/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.0.ebuild b/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.0.ebuild
index 3e37ee4cb76a..69456c0a4d6f 100644
--- a/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.0.ebuild
+++ b/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.0.ebuild,v 1.1 2013/12/15 12:10:36 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.0.ebuild,v 1.2 2013/12/16 16:41:58 mgorny Exp $
EAPI=5
@@ -21,6 +21,13 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ epatch_user
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
src_compile() {
MAKEARGS=(
# Note: please keep this in sync in all of mupen64plus-* packages