summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-04-29 08:11:31 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-04-29 08:11:31 +0000
commitd552541004e06345e72098665ff8604335943910 (patch)
treeb1f6184961a448780c6ad5f2736e17ceff3fcc07 /games-board/pychess
parentMigrate to qt4-r2 eclass wrt bug #311481 (diff)
downloadgentoo-2-d552541004e06345e72098665ff8604335943910.tar.gz
gentoo-2-d552541004e06345e72098665ff8604335943910.tar.bz2
gentoo-2-d552541004e06345e72098665ff8604335943910.zip
Force python2 fixing bug #312241
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-board/pychess')
-rw-r--r--games-board/pychess/ChangeLog7
-rw-r--r--games-board/pychess/pychess-0.8.4.ebuild16
2 files changed, 18 insertions, 5 deletions
diff --git a/games-board/pychess/ChangeLog b/games-board/pychess/ChangeLog
index dfee18fb4fbd..d489803e8217 100644
--- a/games-board/pychess/ChangeLog
+++ b/games-board/pychess/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-board/pychess
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pychess/ChangeLog,v 1.6 2009/11/16 22:12:24 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pychess/ChangeLog,v 1.7 2010/04/29 08:11:31 tupone Exp $
+
+ 29 Apr 2010; Tupone Alfredo <tupone@gentoo.org> pychess-0.8.4.ebuild:
+ Force python2 fixing bug #312241 by arfrever@gentoo.org
16 Nov 2009; Markus Meier <maekke@gentoo.org> pychess-0.8.4.ebuild:
amd64/x86 stable, bug #292687
diff --git a/games-board/pychess/pychess-0.8.4.ebuild b/games-board/pychess/pychess-0.8.4.ebuild
index 356fa6d10347..0cdb8ff4e82c 100644
--- a/games-board/pychess/pychess-0.8.4.ebuild
+++ b/games-board/pychess/pychess-0.8.4.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pychess/pychess-0.8.4.ebuild,v 1.2 2009/11/16 22:12:24 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pychess/pychess-0.8.4.ebuild,v 1.3 2010/04/29 08:11:31 tupone Exp $
+PYTHON_DEPEND="2"
+EAPI="2"
inherit python games distutils
@@ -21,8 +23,16 @@ DEPEND="dev-python/pygtk
dev-python/gnome-python-desktop
x11-themes/gnome-icon-theme"
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+pkg_setup() {
+ python_set_active_version 2
+ games_pkg_setup
+}
+
src_install() {
- python_version
distutils_src_install --install-scripts="${GAMES_BINDIR}"
dodoc AUTHORS README
prepgamesdirs