summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/pychess/pychess-0.8.4.ebuild')
-rw-r--r--games-board/pychess/pychess-0.8.4.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/games-board/pychess/pychess-0.8.4.ebuild b/games-board/pychess/pychess-0.8.4.ebuild
index 356fa6d10347..0cdb8ff4e82c 100644
--- a/games-board/pychess/pychess-0.8.4.ebuild
+++ b/games-board/pychess/pychess-0.8.4.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pychess/pychess-0.8.4.ebuild,v 1.2 2009/11/16 22:12:24 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pychess/pychess-0.8.4.ebuild,v 1.3 2010/04/29 08:11:31 tupone Exp $
+PYTHON_DEPEND="2"
+EAPI="2"
inherit python games distutils
@@ -21,8 +23,16 @@ DEPEND="dev-python/pygtk
dev-python/gnome-python-desktop
x11-themes/gnome-icon-theme"
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+pkg_setup() {
+ python_set_active_version 2
+ games_pkg_setup
+}
+
src_install() {
- python_version
distutils_src_install --install-scripts="${GAMES_BINDIR}"
dodoc AUTHORS README
prepgamesdirs