summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2013-05-21 21:38:15 +0000
committerSebastian Pipping <sping@gentoo.org>2013-05-21 21:38:15 +0000
commitc515043a625cb7a7de97714283bacfe15fa142df (patch)
tree27577aa6bff62384249189bbb0201ebef58d49ad /dev-vcs/svn2git/svn2git-1.0.10.ebuild
parentDev channel bump. Remove old. (diff)
downloadgentoo-2-c515043a625cb7a7de97714283bacfe15fa142df.tar.gz
gentoo-2-c515043a625cb7a7de97714283bacfe15fa142df.tar.bz2
gentoo-2-c515043a625cb7a7de97714283bacfe15fa142df.zip
dev-vcs/svn2git: 1.0.10
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x401A1600)
Diffstat (limited to 'dev-vcs/svn2git/svn2git-1.0.10.ebuild')
-rw-r--r--dev-vcs/svn2git/svn2git-1.0.10.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-vcs/svn2git/svn2git-1.0.10.ebuild b/dev-vcs/svn2git/svn2git-1.0.10.ebuild
new file mode 100644
index 000000000000..287a042cba6d
--- /dev/null
+++ b/dev-vcs/svn2git/svn2git-1.0.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/svn2git-1.0.10.ebuild,v 1.1 2013/05/21 21:38:15 sping Exp $
+
+EAPI="2"
+
+inherit eutils qt4-r2
+[ "$PV" == "9999" ] && inherit git
+
+DESCRIPTION="Tool for one-time conversion from svn to git."
+HOMEPAGE="http://gitorious.org/svn2git/svn2git"
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="git://gitorious.org/svn2git/svn2git.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://gitorious.org/${PN}/${PN}/archive-tarball/${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+# KEYWORDS way up
+
+DEPEND="dev-vcs/subversion
+ dev-qt/qtcore:4"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+S=${WORKDIR}/${PN}-${PN}
+
+src_prepare() {
+ # Note: patching order matters
+ epatch "${FILESDIR}"/${PN}-1.0.2.1-include-path.patch
+ if [[ "$PV" != "9999" ]]; then
+ epatch "${FILESDIR}"/${PN}-1.0.10-version.patch
+ export SVN_ALL_FAST_EXPORT_VERSION=${PVR} # for src_compile
+ fi
+
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ insinto /usr/share/${PN}/samples
+ doins samples/*.rules || die 'doins failed'
+ dobin svn-all-fast-export || die 'dobin failed'
+ dosym svn-all-fast-export /usr/bin/svn2git || die 'dosym failed'
+}