summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2013-05-21 21:38:15 +0000
committerSebastian Pipping <sping@gentoo.org>2013-05-21 21:38:15 +0000
commitc515043a625cb7a7de97714283bacfe15fa142df (patch)
tree27577aa6bff62384249189bbb0201ebef58d49ad /dev-vcs
parentDev channel bump. Remove old. (diff)
downloadgentoo-2-c515043a625cb7a7de97714283bacfe15fa142df.tar.gz
gentoo-2-c515043a625cb7a7de97714283bacfe15fa142df.tar.bz2
gentoo-2-c515043a625cb7a7de97714283bacfe15fa142df.zip
dev-vcs/svn2git: 1.0.10
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x401A1600)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/svn2git/ChangeLog8
-rw-r--r--dev-vcs/svn2git/files/svn2git-1.0.10-version.patch23
-rw-r--r--dev-vcs/svn2git/svn2git-1.0.10.ebuild48
3 files changed, 78 insertions, 1 deletions
diff --git a/dev-vcs/svn2git/ChangeLog b/dev-vcs/svn2git/ChangeLog
index f7ab369b893d..d6fc8ee291a3 100644
--- a/dev-vcs/svn2git/ChangeLog
+++ b/dev-vcs/svn2git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/svn2git
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/ChangeLog,v 1.20 2013/05/09 18:41:39 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/ChangeLog,v 1.21 2013/05/21 21:38:15 sping Exp $
+
+*svn2git-1.0.10 (21 May 2013)
+
+ 21 May 2013; Sebastian Pipping <sping@gentoo.org> +svn2git-1.0.10.ebuild,
+ +files/svn2git-1.0.10-version.patch:
+ Bump to 1.0.10, stop the version patch madness
09 May 2013; Sebastian Pipping <sping@gentoo.org> -svn2git-1.0.8.ebuild:
Remove 1.0.8 due to the UTF-8 bug fixed in 1.0.8-r1
diff --git a/dev-vcs/svn2git/files/svn2git-1.0.10-version.patch b/dev-vcs/svn2git/files/svn2git-1.0.10-version.patch
new file mode 100644
index 000000000000..894cf2c2a10e
--- /dev/null
+++ b/dev-vcs/svn2git/files/svn2git-1.0.10-version.patch
@@ -0,0 +1,23 @@
+From d8b1c8c774a61666e7c62bf5beb8f0f1b4a3e01a Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Tue, 21 May 2013 23:11:25 +0200
+Subject: [PATCH] Stop using Git SHA1 version string
+
+diff --git a/src/src.pro b/src/src.pro
+index da6d40d..2626a6f 100644
+--- a/src/src.pro
++++ b/src/src.pro
+@@ -6,10 +6,7 @@ SVN_INCLUDE = /usr/include/subversion-1 /usr/local/include/subversion-1
+ APR_INCLUDE = /usr/include/apr-1.0 /usr/include/apr-1 /usr/local/include/apr-1
+ exists(local-config.pri):include(local-config.pri)
+
+-VERSION = $$system(git --no-pager show --pretty=oneline --no-notes | head -1 | cut -b-40)
+- !isEmpty(VERSION){
+- VERSION = $${VERSION}
+- }
++VERSION = $$(SVN_ALL_FAST_EXPORT_VERSION)
+
+ VERSTR = '\\"$${VERSION}\\"' # place quotes around the version string
+ DEFINES += VER=\"$${VERSTR}\" # create a VER macro containing the version string
+--
+1.8.2.1
diff --git a/dev-vcs/svn2git/svn2git-1.0.10.ebuild b/dev-vcs/svn2git/svn2git-1.0.10.ebuild
new file mode 100644
index 000000000000..287a042cba6d
--- /dev/null
+++ b/dev-vcs/svn2git/svn2git-1.0.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/svn2git-1.0.10.ebuild,v 1.1 2013/05/21 21:38:15 sping Exp $
+
+EAPI="2"
+
+inherit eutils qt4-r2
+[ "$PV" == "9999" ] && inherit git
+
+DESCRIPTION="Tool for one-time conversion from svn to git."
+HOMEPAGE="http://gitorious.org/svn2git/svn2git"
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="git://gitorious.org/svn2git/svn2git.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://gitorious.org/${PN}/${PN}/archive-tarball/${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+# KEYWORDS way up
+
+DEPEND="dev-vcs/subversion
+ dev-qt/qtcore:4"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+S=${WORKDIR}/${PN}-${PN}
+
+src_prepare() {
+ # Note: patching order matters
+ epatch "${FILESDIR}"/${PN}-1.0.2.1-include-path.patch
+ if [[ "$PV" != "9999" ]]; then
+ epatch "${FILESDIR}"/${PN}-1.0.10-version.patch
+ export SVN_ALL_FAST_EXPORT_VERSION=${PVR} # for src_compile
+ fi
+
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ insinto /usr/share/${PN}/samples
+ doins samples/*.rules || die 'doins failed'
+ dobin svn-all-fast-export || die 'dobin failed'
+ dosym svn-all-fast-export /usr/bin/svn2git || die 'dosym failed'
+}