summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-02-14 18:56:12 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-02-14 18:56:12 +0000
commit20185b543e1c29b3400feb7b7c5c5771c2c2438a (patch)
tree3d726f95638c3954bda3dc9a9282386ee9d793af /dev-util/geany
parentDepend on >=app-admin/eselect-python-20091230, which allows to use --ABI opti... (diff)
downloadgentoo-2-20185b543e1c29b3400feb7b7c5c5771c2c2438a.tar.gz
gentoo-2-20185b543e1c29b3400feb7b7c5c5771c2c2438a.tar.bz2
gentoo-2-20185b543e1c29b3400feb7b7c5c5771c2c2438a.zip
Version bump.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/geany')
-rw-r--r--dev-util/geany/ChangeLog9
-rw-r--r--dev-util/geany/geany-0.16.ebuild51
-rw-r--r--dev-util/geany/geany-0.18.1.ebuild45
3 files changed, 52 insertions, 53 deletions
diff --git a/dev-util/geany/ChangeLog b/dev-util/geany/ChangeLog
index 9b7b16925c70..2523b1cb5f46 100644
--- a/dev-util/geany/ChangeLog
+++ b/dev-util/geany/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/geany
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/geany/ChangeLog,v 1.31 2009/11/21 19:27:29 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/geany/ChangeLog,v 1.32 2010/02/14 18:56:12 ssuominen Exp $
+
+*geany-0.18.1 (14 Feb 2010)
+
+ 14 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> +geany-0.18.1.ebuild:
+ Version bump.
21 Nov 2009; Markus Meier <maekke@gentoo.org> geany-0.18.ebuild:
x86 stable, bug #289084
diff --git a/dev-util/geany/geany-0.16.ebuild b/dev-util/geany/geany-0.16.ebuild
deleted file mode 100644
index 55525aaa9233..000000000000
--- a/dev-util/geany/geany-0.16.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/geany/geany-0.16.ebuild,v 1.4 2009/05/05 10:19:57 ssuominen Exp $
-
-EAPI=2
-inherit gnome2-utils
-
-DESCRIPTION="GTK+ based fast and lightweight IDE"
-HOMEPAGE="http://geany.uvena.de"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
- http://files.uvena.de/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2 Scintilla"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-IUSE="+vte"
-
-RDEPEND=">=x11-libs/gtk+-2.10:2
- vte? ( x11-libs/vte )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_prepare() {
- # Syntax highlighting for Portage
- sed -i -e "s:*.sh;:*.sh;*.ebuild;*.eclass;:" \
- data/filetype_extensions.conf || die "sed failed"
-}
-
-src_configure() {
- econf --disable-dependency-tracking --enable-the-force \
- $(use_enable vte)
-}
-
-src_install() {
- emake DESTDIR="${D}" DOCDIR="${D}/usr/share/doc/${PF}" \
- install || die "emake install failed"
- rm -f "${D}"/usr/share/doc/${PF}/{COPYING,GPL-2,ScintillaLicense.txt}
- prepalldocs
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/dev-util/geany/geany-0.18.1.ebuild b/dev-util/geany/geany-0.18.1.ebuild
new file mode 100644
index 000000000000..9e1b10e41c37
--- /dev/null
+++ b/dev-util/geany/geany-0.18.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/geany/geany-0.18.1.ebuild,v 1.1 2010/02/14 18:56:12 ssuominen Exp $
+
+EAPI=2
+inherit gnome2-utils
+
+DESCRIPTION="GTK+ based fast and lightweight IDE"
+HOMEPAGE="http://geany.uvena.de"
+SRC_URI="http://files.uvena.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 Scintilla"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="+vte"
+
+RDEPEND=">=x11-libs/gtk+-2.12:2
+ >=dev-libs/glib-2.16:2
+ vte? ( x11-libs/vte )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+src_prepare() {
+ # Syntax highlighting for Portage
+ sed -i -e "s:*.sh;:*.sh;*.ebuild;*.eclass;:" \
+ data/filetype_extensions.conf || die
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable vte)
+}
+
+src_install() {
+ emake DESTDIR="${D}" DOCDIR="${D}/usr/share/doc/${PF}" install || die
+ rm -f "${D}"/usr/share/doc/${PF}/{COPYING,GPL-2,ScintillaLicense.txt}
+ prepalldocs
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }