summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-02-22 20:32:35 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-02-22 20:32:35 +0000
commitf903a86bc86e46dcab44a782cad9284a372d2bc1 (patch)
tree6db782778d519070c8ffb29fd34c1e9cb3cdfff9 /dev-util/checkstyle/checkstyle-3.3.ebuild
parentRemove arm keywords (Manifest recommit) (diff)
downloadgentoo-2-f903a86bc86e46dcab44a782cad9284a372d2bc1.tar.gz
gentoo-2-f903a86bc86e46dcab44a782cad9284a372d2bc1.tar.bz2
gentoo-2-f903a86bc86e46dcab44a782cad9284a372d2bc1.zip
Initial import, closes #27982
Diffstat (limited to 'dev-util/checkstyle/checkstyle-3.3.ebuild')
-rw-r--r--dev-util/checkstyle/checkstyle-3.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/checkstyle/checkstyle-3.3.ebuild b/dev-util/checkstyle/checkstyle-3.3.ebuild
new file mode 100644
index 000000000000..4f5094df323d
--- /dev/null
+++ b/dev-util/checkstyle/checkstyle-3.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/checkstyle/checkstyle-3.3.ebuild,v 1.1 2004/02/22 20:32:35 zx Exp $
+
+inherit java-pkg
+
+DESCRIPTION="A development tool to help programmers write Java code that adheres to a coding standard."
+HOMEPAGE="http://checkstyle.sourceforge.net"
+SRC_URI="mirror://sourceforge/checkstyle/${PN}-src-${PV}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE="doc"
+
+S=${WORKDIR}/${PN}-src-${PV}
+
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-1.5
+ jikes? ( dev-java/jikes )"
+
+RDEPEND=">=virtual/jre-1.3
+ dev-java/antlr
+ dev-java/commons-beanutils
+ dev-java/commons-cli
+ dev-java/commons-collections
+ dev-java/commons-logging
+ dev-java/regexp"
+
+src_compile() {
+ local antflags="compile.checkstyle"
+ use doc && antflags="${antflags} javadoc"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "ant :("
+}
+
+src_install() {
+ insinto /usr/share/checkstyle
+ jar cfm ${P}.jar config/manifest.mf -C target/checkstyle .
+ java-pkg_dojar ${P}.jar
+ use doc && dohtml -r docs/*
+ dodoc README RIGHTS.antlr TODO
+ mv docs/checkstyle_checks.xml ${D}/usr/share/checkstyle/checkstyle_checks.xml
+ mv docs/sun_checks.xml ${D}/usr/share/checkstyle/sun_checks.xml
+ mv contrib ${D}/usr/share/checkstyle
+}