summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-02-22 20:32:35 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-02-22 20:32:35 +0000
commitf903a86bc86e46dcab44a782cad9284a372d2bc1 (patch)
tree6db782778d519070c8ffb29fd34c1e9cb3cdfff9 /dev-util/checkstyle
parentRemove arm keywords (Manifest recommit) (diff)
downloadgentoo-2-f903a86bc86e46dcab44a782cad9284a372d2bc1.tar.gz
gentoo-2-f903a86bc86e46dcab44a782cad9284a372d2bc1.tar.bz2
gentoo-2-f903a86bc86e46dcab44a782cad9284a372d2bc1.zip
Initial import, closes #27982
Diffstat (limited to 'dev-util/checkstyle')
-rw-r--r--dev-util/checkstyle/ChangeLog11
-rw-r--r--dev-util/checkstyle/Manifest2
-rw-r--r--dev-util/checkstyle/checkstyle-3.3.ebuild45
-rw-r--r--dev-util/checkstyle/files/digest-checkstyle-3.31
-rw-r--r--dev-util/checkstyle/metadata.xml5
5 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/checkstyle/ChangeLog b/dev-util/checkstyle/ChangeLog
new file mode 100644
index 000000000000..05dce4e69368
--- /dev/null
+++ b/dev-util/checkstyle/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-util/checkstyle
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/checkstyle/ChangeLog,v 1.1 2004/02/22 20:32:35 zx Exp $
+
+*checkstyle-3.3 (24 Feb 2004)
+
+ 24 Feb 2004; Chris Aniszczyk <zx@gentoo.org> checkstyle-3.3.ebuild,
+ metadata.xml:
+ Initial Import. Thanks to Andrew Sayman <lorien420@myrealbox.com> for the
+ initial ebuild. Bug #27982
+
diff --git a/dev-util/checkstyle/Manifest b/dev-util/checkstyle/Manifest
new file mode 100644
index 000000000000..dd4b6de2df86
--- /dev/null
+++ b/dev-util/checkstyle/Manifest
@@ -0,0 +1,2 @@
+MD5 c24dd52848c2ff6e68585bd35f226150 checkstyle-3.3.ebuild 1231
+MD5 3bfc61fcf1ab108f7cf96aef2c3acd0e files/digest-checkstyle-3.3 71
diff --git a/dev-util/checkstyle/checkstyle-3.3.ebuild b/dev-util/checkstyle/checkstyle-3.3.ebuild
new file mode 100644
index 000000000000..4f5094df323d
--- /dev/null
+++ b/dev-util/checkstyle/checkstyle-3.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/checkstyle/checkstyle-3.3.ebuild,v 1.1 2004/02/22 20:32:35 zx Exp $
+
+inherit java-pkg
+
+DESCRIPTION="A development tool to help programmers write Java code that adheres to a coding standard."
+HOMEPAGE="http://checkstyle.sourceforge.net"
+SRC_URI="mirror://sourceforge/checkstyle/${PN}-src-${PV}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE="doc"
+
+S=${WORKDIR}/${PN}-src-${PV}
+
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-1.5
+ jikes? ( dev-java/jikes )"
+
+RDEPEND=">=virtual/jre-1.3
+ dev-java/antlr
+ dev-java/commons-beanutils
+ dev-java/commons-cli
+ dev-java/commons-collections
+ dev-java/commons-logging
+ dev-java/regexp"
+
+src_compile() {
+ local antflags="compile.checkstyle"
+ use doc && antflags="${antflags} javadoc"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "ant :("
+}
+
+src_install() {
+ insinto /usr/share/checkstyle
+ jar cfm ${P}.jar config/manifest.mf -C target/checkstyle .
+ java-pkg_dojar ${P}.jar
+ use doc && dohtml -r docs/*
+ dodoc README RIGHTS.antlr TODO
+ mv docs/checkstyle_checks.xml ${D}/usr/share/checkstyle/checkstyle_checks.xml
+ mv docs/sun_checks.xml ${D}/usr/share/checkstyle/sun_checks.xml
+ mv contrib ${D}/usr/share/checkstyle
+}
diff --git a/dev-util/checkstyle/files/digest-checkstyle-3.3 b/dev-util/checkstyle/files/digest-checkstyle-3.3
new file mode 100644
index 000000000000..e8c6fd42cc1e
--- /dev/null
+++ b/dev-util/checkstyle/files/digest-checkstyle-3.3
@@ -0,0 +1 @@
+MD5 034f31ce020fa35b48882b762b4999b2 checkstyle-src-3.3.tar.gz 1277240
diff --git a/dev-util/checkstyle/metadata.xml b/dev-util/checkstyle/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-util/checkstyle/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>