summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-08-28 19:08:10 +0000
committerUlrich Müller <ulm@gentoo.org>2008-08-28 19:08:10 +0000
commit53f2cc5239a470fe491cac29a7e5bd7d9edacc1c (patch)
tree4877086e946ada803e9561c8b2d2c2d476f9d2e3 /dev-scheme
parentFixing incorrect manifest (diff)
downloadgentoo-2-53f2cc5239a470fe491cac29a7e5bd7d9edacc1c.tar.gz
gentoo-2-53f2cc5239a470fe491cac29a7e5bd7d9edacc1c.tar.bz2
gentoo-2-53f2cc5239a470fe491cac29a7e5bd7d9edacc1c.zip
Fix byte-compilation of Emacs lisp files, bug 236046.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/guile/ChangeLog5
-rw-r--r--dev-scheme/guile/guile-1.8.5-r1.ebuild9
2 files changed, 9 insertions, 5 deletions
diff --git a/dev-scheme/guile/ChangeLog b/dev-scheme/guile/ChangeLog
index 7774d5845aea..2bfbee998248 100644
--- a/dev-scheme/guile/ChangeLog
+++ b/dev-scheme/guile/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-scheme/guile
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/ChangeLog,v 1.62 2008/08/22 10:58:04 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/ChangeLog,v 1.63 2008/08/28 19:08:10 ulm Exp $
+
+ 28 Aug 2008; Ulrich Mueller <ulm@gentoo.org> guile-1.8.5-r1.ebuild:
+ Fix byte-compilation of Emacs lisp files, bug 236046.
*guile-1.8.5-r1 (22 Aug 2008)
diff --git a/dev-scheme/guile/guile-1.8.5-r1.ebuild b/dev-scheme/guile/guile-1.8.5-r1.ebuild
index 13578e19f12f..35b4734afc6c 100644
--- a/dev-scheme/guile/guile-1.8.5-r1.ebuild
+++ b/dev-scheme/guile/guile-1.8.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.5-r1.ebuild,v 1.1 2008/08/22 10:58:04 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.5-r1.ebuild,v 1.2 2008/08/28 19:08:10 ulm Exp $
inherit eutils autotools flag-o-matic elisp-common
@@ -65,10 +65,11 @@ src_compile() {
emake || die "make failed"
- # above we disable the build system's Emacs support;
- # do it manually for USE=emacs
+ # Above we have disabled the build system's Emacs support;
+ # for USE=emacs we compile (and install) the files manually
if use emacs; then
- elisp-compile emacs/*.el || die "elisp-compile failed"
+ cd emacs
+ elisp-compile *.el || die "elisp-compile failed"
fi
}