summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/guile/guile-1.8.5-r1.ebuild')
-rw-r--r--dev-scheme/guile/guile-1.8.5-r1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-scheme/guile/guile-1.8.5-r1.ebuild b/dev-scheme/guile/guile-1.8.5-r1.ebuild
index 13578e19f12f..35b4734afc6c 100644
--- a/dev-scheme/guile/guile-1.8.5-r1.ebuild
+++ b/dev-scheme/guile/guile-1.8.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.5-r1.ebuild,v 1.1 2008/08/22 10:58:04 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.5-r1.ebuild,v 1.2 2008/08/28 19:08:10 ulm Exp $
inherit eutils autotools flag-o-matic elisp-common
@@ -65,10 +65,11 @@ src_compile() {
emake || die "make failed"
- # above we disable the build system's Emacs support;
- # do it manually for USE=emacs
+ # Above we have disabled the build system's Emacs support;
+ # for USE=emacs we compile (and install) the files manually
if use emacs; then
- elisp-compile emacs/*.el || die "elisp-compile failed"
+ cd emacs
+ elisp-compile *.el || die "elisp-compile failed"
fi
}