summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-08-28 17:41:16 +0000
committerUlrich Müller <ulm@gentoo.org>2008-08-28 17:41:16 +0000
commit7f16edcfd9d6b11ff5e6becfc1c70e10e26b1c84 (patch)
treeaa0d69add7229c708c82bcb465a9d73b0bab6f51 /dev-scheme/gambit
parentfix parallel make, by Diego Pettenò <flameeyes@gentoo.org>, bug #236030. (diff)
downloadgentoo-2-7f16edcfd9d6b11ff5e6becfc1c70e10e26b1c84.tar.gz
gentoo-2-7f16edcfd9d6b11ff5e6becfc1c70e10e26b1c84.tar.bz2
gentoo-2-7f16edcfd9d6b11ff5e6becfc1c70e10e26b1c84.zip
Use elisp-compile instead of elisp-comp, bug 235883.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'dev-scheme/gambit')
-rw-r--r--dev-scheme/gambit/ChangeLog8
-rw-r--r--dev-scheme/gambit/files/50gambit-gentoo.el3
-rw-r--r--dev-scheme/gambit/gambit-4.0.0.ebuild6
-rw-r--r--dev-scheme/gambit/gambit-4.0.1.ebuild6
-rw-r--r--dev-scheme/gambit/gambit-4.0_beta22.ebuild6
-rw-r--r--dev-scheme/gambit/gambit-4.1.0.ebuild6
-rw-r--r--dev-scheme/gambit/gambit-4.1.1.ebuild6
-rw-r--r--dev-scheme/gambit/gambit-4.1.2.ebuild6
8 files changed, 27 insertions, 20 deletions
diff --git a/dev-scheme/gambit/ChangeLog b/dev-scheme/gambit/ChangeLog
index 3fca67dc7065..064e84bebddb 100644
--- a/dev-scheme/gambit/ChangeLog
+++ b/dev-scheme/gambit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-scheme/gambit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.17 2008/07/28 18:05:04 pchrist Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.18 2008/08/28 17:41:15 ulm Exp $
+
+ 28 Aug 2008; Ulrich Mueller <ulm@gentoo.org> files/50gambit-gentoo.el,
+ gambit-4.0_beta22.ebuild, gambit-4.0.0.ebuild, gambit-4.0.1.ebuild,
+ gambit-4.1.0.ebuild, gambit-4.1.1.ebuild, gambit-4.1.2.ebuild:
+ Use elisp-compile instead of elisp-comp, bug 235883. Set load-path for
+ Emacs correctly.
28 Jul 2008; Panagiotis Christopoulos <pchrist@gentoo.org> metadata.xml:
Update metadata.xml to include USE flag descriptions. Entries taken from
diff --git a/dev-scheme/gambit/files/50gambit-gentoo.el b/dev-scheme/gambit/files/50gambit-gentoo.el
index 131682207e78..2e8e196ba04d 100644
--- a/dev-scheme/gambit/files/50gambit-gentoo.el
+++ b/dev-scheme/gambit/files/50gambit-gentoo.el
@@ -1,6 +1,7 @@
-;; site-lisp configuration for gambit
+;;; gambit site-lisp configuration
+(add-to-list 'load-path "@SITELISP@")
(autoload 'gambit-inferior-mode "gambit" "Hook Gambit mode into cmuscheme.")
(autoload 'gambit-mode "gambit" "Hook Gambit mode into scheme.")
diff --git a/dev-scheme/gambit/gambit-4.0.0.ebuild b/dev-scheme/gambit/gambit-4.0.0.ebuild
index c092665021fc..2ca1c35238e2 100644
--- a/dev-scheme/gambit/gambit-4.0.0.ebuild
+++ b/dev-scheme/gambit/gambit-4.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.0.0.ebuild,v 1.3 2007/09/02 11:52:29 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.0.0.ebuild,v 1.4 2008/08/28 17:41:15 ulm Exp $
inherit eutils elisp-common check-reqs autotools multilib
@@ -63,7 +63,7 @@ src_compile() {
emake || die "emake failed"
if use emacs; then
- ( cd misc; elisp-comp *.el )
+ elisp-compile misc/*.el || die "elisp-compile failed"
fi
# compile syntax-case
diff --git a/dev-scheme/gambit/gambit-4.0.1.ebuild b/dev-scheme/gambit/gambit-4.0.1.ebuild
index 4086d00d6595..5c00ae8e6d19 100644
--- a/dev-scheme/gambit/gambit-4.0.1.ebuild
+++ b/dev-scheme/gambit/gambit-4.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.0.1.ebuild,v 1.1 2007/09/12 12:06:53 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.0.1.ebuild,v 1.2 2008/08/28 17:41:15 ulm Exp $
inherit eutils elisp-common check-reqs autotools multilib
@@ -63,7 +63,7 @@ src_compile() {
emake || die "emake failed"
if use emacs; then
- ( cd misc; elisp-comp *.el )
+ elisp-compile misc/*.el || die "elisp-compile failed"
fi
# compile syntax-case
diff --git a/dev-scheme/gambit/gambit-4.0_beta22.ebuild b/dev-scheme/gambit/gambit-4.0_beta22.ebuild
index b0af7743ad12..a91cadc0ed7b 100644
--- a/dev-scheme/gambit/gambit-4.0_beta22.ebuild
+++ b/dev-scheme/gambit/gambit-4.0_beta22.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.0_beta22.ebuild,v 1.8 2007/09/02 11:43:22 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.0_beta22.ebuild,v 1.9 2008/08/28 17:41:15 ulm Exp $
inherit eutils elisp-common check-reqs autotools multilib
@@ -51,7 +51,7 @@ src_compile() {
emake || die "emake failed"
if use emacs; then
- ( cd misc; elisp-comp *.el )
+ elisp-compile misc/*.el || die "elisp-compile failed"
fi
# compile syntax-case
diff --git a/dev-scheme/gambit/gambit-4.1.0.ebuild b/dev-scheme/gambit/gambit-4.1.0.ebuild
index 390641ca4b79..ee47ce38d271 100644
--- a/dev-scheme/gambit/gambit-4.1.0.ebuild
+++ b/dev-scheme/gambit/gambit-4.1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.1.0.ebuild,v 1.1 2007/11/18 18:29:34 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.1.0.ebuild,v 1.2 2008/08/28 17:41:15 ulm Exp $
inherit eutils elisp-common check-reqs autotools multilib
@@ -64,7 +64,7 @@ src_compile() {
emake || die "emake failed"
if use emacs; then
- ( cd misc; elisp-comp *.el )
+ elisp-compile misc/*.el || die "elisp-compile failed"
fi
# compile syntax-case
diff --git a/dev-scheme/gambit/gambit-4.1.1.ebuild b/dev-scheme/gambit/gambit-4.1.1.ebuild
index 19701ae9ce0d..c889b95dd1cb 100644
--- a/dev-scheme/gambit/gambit-4.1.1.ebuild
+++ b/dev-scheme/gambit/gambit-4.1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.1.1.ebuild,v 1.1 2007/12/16 13:01:23 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.1.1.ebuild,v 1.2 2008/08/28 17:41:15 ulm Exp $
inherit eutils elisp-common check-reqs autotools multilib
@@ -63,7 +63,7 @@ src_compile() {
emake || die "emake failed"
if use emacs; then
- ( cd misc; elisp-comp *.el )
+ elisp-compile misc/*.el || die "elisp-compile failed"
fi
#workaround
diff --git a/dev-scheme/gambit/gambit-4.1.2.ebuild b/dev-scheme/gambit/gambit-4.1.2.ebuild
index 4a1bf18f21fa..857b257f6416 100644
--- a/dev-scheme/gambit/gambit-4.1.2.ebuild
+++ b/dev-scheme/gambit/gambit-4.1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.1.2.ebuild,v 1.1 2007/12/17 21:32:54 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.1.2.ebuild,v 1.2 2008/08/28 17:41:15 ulm Exp $
inherit eutils elisp-common check-reqs autotools multilib
@@ -61,7 +61,7 @@ src_compile() {
emake || die "emake failed"
if use emacs; then
- ( cd misc; elisp-comp *.el )
+ elisp-compile misc/*.el || die "elisp-compile failed"
fi
}