summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-21 11:18:55 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-21 11:18:55 +0000
commite84c7b1541e4280512c97fdd26f9fcdb235f9c06 (patch)
tree2415f9d45a9374d5d1d6a9f9c42b7f866f3a3fc3 /dev-ruby/polyglot
parentVersion bump, remove Ruby 1.9 support as it's not testable right now (actionp... (diff)
downloadgentoo-2-e84c7b1541e4280512c97fdd26f9fcdb235f9c06.tar.gz
gentoo-2-e84c7b1541e4280512c97fdd26f9fcdb235f9c06.tar.bz2
gentoo-2-e84c7b1541e4280512c97fdd26f9fcdb235f9c06.zip
Add ruby19/jruby as they pass tests, also make sure to let the ebuild die if tests fail.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/polyglot')
-rw-r--r--dev-ruby/polyglot/ChangeLog7
-rw-r--r--dev-ruby/polyglot/polyglot-0.2.9-r1.ebuild6
2 files changed, 9 insertions, 4 deletions
diff --git a/dev-ruby/polyglot/ChangeLog b/dev-ruby/polyglot/ChangeLog
index 933b4e87243e..d4c9e0053693 100644
--- a/dev-ruby/polyglot/ChangeLog
+++ b/dev-ruby/polyglot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/polyglot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/polyglot/ChangeLog,v 1.8 2010/01/14 16:06:13 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/polyglot/ChangeLog,v 1.9 2010/01/21 11:18:55 flameeyes Exp $
+
+ 21 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ polyglot-0.2.9-r1.ebuild:
+ Add ruby19/jruby as they pass tests, also make sure to let the ebuild die
+ if tests fail.
14 Jan 2010; Brent Baude <ranger@gentoo.org> polyglot-0.2.9-r1.ebuild:
Marking polyglot-0.2.9-r1 ~ppc for bug 300739
diff --git a/dev-ruby/polyglot/polyglot-0.2.9-r1.ebuild b/dev-ruby/polyglot/polyglot-0.2.9-r1.ebuild
index 1ba4176bc166..5836b5f5175b 100644
--- a/dev-ruby/polyglot/polyglot-0.2.9-r1.ebuild
+++ b/dev-ruby/polyglot/polyglot-0.2.9-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/polyglot/polyglot-0.2.9-r1.ebuild,v 1.4 2010/01/14 16:06:13 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/polyglot/polyglot-0.2.9-r1.ebuild,v 1.5 2010/01/21 11:18:55 flameeyes Exp $
EAPI=2
-USE_RUBY="ruby18"
+USE_RUBY="ruby18 ruby19 jruby"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_TASK_TEST=""
@@ -23,5 +23,5 @@ IUSE=""
ruby_add_bdepend test virtual/ruby-test-unit
each_ruby_test() {
- ${RUBY} test/test_polyglot.rb
+ ${RUBY} test/test_polyglot.rb || die "tests failed"
}