summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-05 07:29:40 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-05 07:29:40 +0000
commit779884556fbe6257ab97331162f82b414cd03427 (patch)
tree36c31d096fa993f46b6288b965c35dba4dc178e0 /dev-python/python-fastcgi
parentfix typo (diff)
downloadgentoo-2-779884556fbe6257ab97331162f82b414cd03427.tar.gz
gentoo-2-779884556fbe6257ab97331162f82b414cd03427.tar.bz2
gentoo-2-779884556fbe6257ab97331162f82b414cd03427.zip
revbump; conversion -> distutils-r1, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/python-fastcgi')
-rw-r--r--dev-python/python-fastcgi/ChangeLog10
-rw-r--r--dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild (renamed from dev-python/python-fastcgi/python-fastcgi-1.1.ebuild)26
2 files changed, 20 insertions, 16 deletions
diff --git a/dev-python/python-fastcgi/ChangeLog b/dev-python/python-fastcgi/ChangeLog
index 062d06ea82e7..8b47cd69cc07 100644
--- a/dev-python/python-fastcgi/ChangeLog
+++ b/dev-python/python-fastcgi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-fastcgi
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-fastcgi/ChangeLog,v 1.5 2014/08/10 21:18:58 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-fastcgi/ChangeLog,v 1.6 2015/01/05 07:29:40 idella4 Exp $
+
+*python-fastcgi-1.1-r1 (05 Jan 2015)
+
+ 05 Jan 2015; Ian Delaney <idella4@gentoo.org> +python-fastcgi-1.1-r1.ebuild,
+ -python-fastcgi-1.1.ebuild:
+ revbump; conversion -> distutils-r1, rm old
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> python-fastcgi-1.1.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/dev-python/python-fastcgi/python-fastcgi-1.1.ebuild b/dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild
index 586860c994bd..5ece2b2e392f 100644
--- a/dev-python/python-fastcgi/python-fastcgi-1.1.ebuild
+++ b/dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-fastcgi/python-fastcgi-1.1.ebuild,v 1.5 2014/08/10 21:18:58 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild,v 1.1 2015/01/05 07:29:40 idella4 Exp $
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
-inherit distutils eutils
+inherit distutils-r1
DESCRIPTION="Interface to OpenMarket's FastCGI C Library/SDK"
HOMEPAGE="http://pypi.python.org/pypi/python-fastcgi"
@@ -16,17 +14,17 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="examples"
RDEPEND=">=dev-libs/fcgi-2.4.0-r2"
DEPEND="${RDEPEND}
- dev-python/setuptools"
+ dev-python/setuptools[${PYTHON_USEDEP}]"
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+CFLAGS="${CFLAGS} -fno-strict-aliasing"
-PYTHON_MODNAME="fastcgi"
+PATCHES=( "${FILESDIR}/${P}-setup.patch" )
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${P}-setup.patch"
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
}