summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild')
-rw-r--r--dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild b/dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild
new file mode 100644
index 000000000000..5ece2b2e392f
--- /dev/null
+++ b/dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild,v 1.1 2015/01/05 07:29:40 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Interface to OpenMarket's FastCGI C Library/SDK"
+HOMEPAGE="http://pypi.python.org/pypi/python-fastcgi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-libs/fcgi-2.4.0-r2"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+PATCHES=( "${FILESDIR}/${P}-setup.patch" )
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}