summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando Serboncini <fserb@gentoo.org>2005-05-26 18:03:42 +0000
committerFernando Serboncini <fserb@gentoo.org>2005-05-26 18:03:42 +0000
commitd87ac806a3681699cd20a0edab82a66b3c6e90b0 (patch)
treef9b4a7b2404a2fd335a722382ec98e7f6a4745e5 /dev-python/matplotlib/matplotlib-0.80-r1.ebuild
parentAdd no-tmpdir patch (diff)
downloadgentoo-2-d87ac806a3681699cd20a0edab82a66b3c6e90b0.tar.gz
gentoo-2-d87ac806a3681699cd20a0edab82a66b3c6e90b0.tar.bz2
gentoo-2-d87ac806a3681699cd20a0edab82a66b3c6e90b0.zip
Removed need for virtualx. Fixes #91553
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-python/matplotlib/matplotlib-0.80-r1.ebuild')
-rw-r--r--dev-python/matplotlib/matplotlib-0.80-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/matplotlib/matplotlib-0.80-r1.ebuild b/dev-python/matplotlib/matplotlib-0.80-r1.ebuild
new file mode 100644
index 000000000000..dfdd95e30c4b
--- /dev/null
+++ b/dev-python/matplotlib/matplotlib-0.80-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.80-r1.ebuild,v 1.1 2005/05/26 18:03:42 fserb Exp $
+
+inherit distutils
+
+DESCRIPTION="matplotlib is a pure python plotting library designed to bring publication quality plotting to python with a syntax familiar to matlab users."
+HOMEPAGE="http://matplotlib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+IUSE="doc gtk"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+LICENSE="as-is"
+
+DEPEND="virtual/python
+ >=dev-python/numeric-22
+ gtk? ( >=dev-python/pygtk-1.99.16 )"
+
+src_install() {
+ distutils_src_install
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.py examples/README
+ insinfo /usr/share/doc/${PF}/examples/data
+ doins examples/data/*.dat
+ fi
+}
+