summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando Serboncini <fserb@gentoo.org>2005-05-26 18:03:42 +0000
committerFernando Serboncini <fserb@gentoo.org>2005-05-26 18:03:42 +0000
commitd87ac806a3681699cd20a0edab82a66b3c6e90b0 (patch)
treef9b4a7b2404a2fd335a722382ec98e7f6a4745e5 /dev-python/matplotlib
parentAdd no-tmpdir patch (diff)
downloadgentoo-2-d87ac806a3681699cd20a0edab82a66b3c6e90b0.tar.gz
gentoo-2-d87ac806a3681699cd20a0edab82a66b3c6e90b0.tar.bz2
gentoo-2-d87ac806a3681699cd20a0edab82a66b3c6e90b0.zip
Removed need for virtualx. Fixes #91553
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/ChangeLog8
-rw-r--r--dev-python/matplotlib/Manifest12
-rw-r--r--dev-python/matplotlib/files/digest-matplotlib-0.80-r11
-rw-r--r--dev-python/matplotlib/matplotlib-0.80-r1.ebuild30
4 files changed, 40 insertions, 11 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index d0a912712965..ad76008e2ca7 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.9 2005/05/26 14:14:08 fserb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.10 2005/05/26 18:03:42 fserb Exp $
+
+*matplotlib-0.80-r1 (26 May 2005)
+
+ 26 May 2005; Fernando Serboncini <fserb@gentoo.org>
+ +matplotlib-0.80-r1.ebuild:
+ Removed need for virtualx on new matplotlib. Fixes #91553.
26 May 2005; Fernando Serboncini <fserb@gentoo.org>
-matplotlib-0.64.ebuild, -matplotlib-0.65.ebuild, matplotlib-0.71.ebuild:
diff --git a/dev-python/matplotlib/Manifest b/dev-python/matplotlib/Manifest
index 9700b8af8616..433eb910702b 100644
--- a/dev-python/matplotlib/Manifest
+++ b/dev-python/matplotlib/Manifest
@@ -1,18 +1,10 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 f69d996d233a5305188c75d037b52225 ChangeLog 1615
+MD5 21a52d03a159303bd810baabf894cb84 matplotlib-0.80-r1.ebuild 762
MD5 491c0eab778ca3c4081a32465ac56383 matplotlib-0.71.ebuild 1008
MD5 83c6067a034ad2bafe918740733bdd7b matplotlib-0.73.1.ebuild 1022
MD5 d876f23e265d0f6c4c89a345367ddd36 matplotlib-0.80.ebuild 1017
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
+MD5 c0167eaa6285560f9d7be0cefac5b7c3 files/digest-matplotlib-0.80-r1 68
MD5 c114d2c51202eda7d4a722513e7dbaa4 files/digest-matplotlib-0.71 68
MD5 29e58690d4283dec939607bc0cc32e44 files/digest-matplotlib-0.73.1 70
MD5 c0167eaa6285560f9d7be0cefac5b7c3 files/digest-matplotlib-0.80 68
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCldnVxtZcznfol0URAhGRAJ4zicVshJgJ2xew3dlIefUeENaDzgCg8qQi
-jFsudH9q3wyiov+JFSk0UpE=
-=sBxd
------END PGP SIGNATURE-----
diff --git a/dev-python/matplotlib/files/digest-matplotlib-0.80-r1 b/dev-python/matplotlib/files/digest-matplotlib-0.80-r1
new file mode 100644
index 000000000000..7a9c9bca874e
--- /dev/null
+++ b/dev-python/matplotlib/files/digest-matplotlib-0.80-r1
@@ -0,0 +1 @@
+MD5 0374c439d3fcbca193c1333b84713674 matplotlib-0.80.tar.gz 2332845
diff --git a/dev-python/matplotlib/matplotlib-0.80-r1.ebuild b/dev-python/matplotlib/matplotlib-0.80-r1.ebuild
new file mode 100644
index 000000000000..dfdd95e30c4b
--- /dev/null
+++ b/dev-python/matplotlib/matplotlib-0.80-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.80-r1.ebuild,v 1.1 2005/05/26 18:03:42 fserb Exp $
+
+inherit distutils
+
+DESCRIPTION="matplotlib is a pure python plotting library designed to bring publication quality plotting to python with a syntax familiar to matlab users."
+HOMEPAGE="http://matplotlib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+IUSE="doc gtk"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+LICENSE="as-is"
+
+DEPEND="virtual/python
+ >=dev-python/numeric-22
+ gtk? ( >=dev-python/pygtk-1.99.16 )"
+
+src_install() {
+ distutils_src_install
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.py examples/README
+ insinfo /usr/share/doc/${PF}/examples/data
+ doins examples/data/*.dat
+ fi
+}
+