summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-10-16 14:13:40 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-10-16 14:13:40 +0000
commit2c99b5f888c3d1ce7e1171841d326198519bc207 (patch)
tree1de402ee077464aa9c3772554588a0d800fb4c8b /dev-python/IcePy/IcePy-3.1.1.ebuild
parentAdd me as maintainer and commit kernel/userland ABI patch from bug 133382 tha... (diff)
downloadgentoo-2-2c99b5f888c3d1ce7e1171841d326198519bc207.tar.gz
gentoo-2-2c99b5f888c3d1ce7e1171841d326198519bc207.tar.bz2
gentoo-2-2c99b5f888c3d1ce7e1171841d326198519bc207.zip
version bump
(Portage version: 2.1.2_pre2-r9)
Diffstat (limited to 'dev-python/IcePy/IcePy-3.1.1.ebuild')
-rw-r--r--dev-python/IcePy/IcePy-3.1.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/IcePy/IcePy-3.1.1.ebuild b/dev-python/IcePy/IcePy-3.1.1.ebuild
new file mode 100644
index 000000000000..54f759549492
--- /dev/null
+++ b/dev-python/IcePy/IcePy-3.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/IcePy/IcePy-3.1.1.ebuild,v 1.1 2006/10/16 14:13:40 caleb Exp $
+
+inherit eutils python
+
+DESCRIPTION="ICE middleware C++ bindings"
+HOMEPAGE="http://www.zeroc.com/index.html"
+SRC_URI="http://www.zeroc.com/download/Ice/3.1/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="test debug"
+
+DEPEND="=dev-cpp/ice-3.1*"
+
+ICE_HOME=/usr
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch ${FILESDIR}/icepy-${PV}-makefile.patch
+
+ if use amd64; then
+ sed -i -e "s:^#LP64:LP64:g" ${S}/config/Make.rules \
+ || die "Failed to set lib64 directory"
+ fi
+
+ if ! use debug; then
+ sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
+ ${S}/config/Make.rules || die "Failed to remove debug"
+ fi
+
+ sed -i -e \
+ "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
+ ${S}/config/Make.rules.Linux || die "CXXFLAGS patching failed!"
+}
+
+src_compile() {
+ cd ${S}
+ export ICE_HOME=/usr
+ make || die "Died during make"
+}
+
+src_install() {
+ export ICE_HOME=/usr
+ make DESTDIR="${D}" install || die "Install Failed!"
+}
+
+src_test() {
+ export ICE_HOME=/usr
+ make test || die "Test failed"
+}