summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-10-16 14:13:40 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-10-16 14:13:40 +0000
commit2c99b5f888c3d1ce7e1171841d326198519bc207 (patch)
tree1de402ee077464aa9c3772554588a0d800fb4c8b /dev-python/IcePy
parentAdd me as maintainer and commit kernel/userland ABI patch from bug 133382 tha... (diff)
downloadgentoo-2-2c99b5f888c3d1ce7e1171841d326198519bc207.tar.gz
gentoo-2-2c99b5f888c3d1ce7e1171841d326198519bc207.tar.bz2
gentoo-2-2c99b5f888c3d1ce7e1171841d326198519bc207.zip
version bump
(Portage version: 2.1.2_pre2-r9)
Diffstat (limited to 'dev-python/IcePy')
-rw-r--r--dev-python/IcePy/ChangeLog8
-rw-r--r--dev-python/IcePy/IcePy-3.1.1.ebuild55
-rw-r--r--dev-python/IcePy/files/digest-IcePy-3.1.13
-rw-r--r--dev-python/IcePy/files/icepy-3.1.1-makefile.patch74
4 files changed, 139 insertions, 1 deletions
diff --git a/dev-python/IcePy/ChangeLog b/dev-python/IcePy/ChangeLog
index 9d916d90e676..ebad99d26f87 100644
--- a/dev-python/IcePy/ChangeLog
+++ b/dev-python/IcePy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/IcePy
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/IcePy/ChangeLog,v 1.1 2006/09/11 12:35:12 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/IcePy/ChangeLog,v 1.2 2006/10/16 14:13:40 caleb Exp $
+
+*IcePy-3.1.1 (16 Oct 2006)
+
+ 16 Oct 2006; Caleb Tennis <caleb@gentoo.org>
+ +files/icepy-3.1.1-makefile.patch, +IcePy-3.1.1.ebuild:
+ version bump
*IcePy-3.1.0 (11 Sep 2006)
diff --git a/dev-python/IcePy/IcePy-3.1.1.ebuild b/dev-python/IcePy/IcePy-3.1.1.ebuild
new file mode 100644
index 000000000000..54f759549492
--- /dev/null
+++ b/dev-python/IcePy/IcePy-3.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/IcePy/IcePy-3.1.1.ebuild,v 1.1 2006/10/16 14:13:40 caleb Exp $
+
+inherit eutils python
+
+DESCRIPTION="ICE middleware C++ bindings"
+HOMEPAGE="http://www.zeroc.com/index.html"
+SRC_URI="http://www.zeroc.com/download/Ice/3.1/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="test debug"
+
+DEPEND="=dev-cpp/ice-3.1*"
+
+ICE_HOME=/usr
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch ${FILESDIR}/icepy-${PV}-makefile.patch
+
+ if use amd64; then
+ sed -i -e "s:^#LP64:LP64:g" ${S}/config/Make.rules \
+ || die "Failed to set lib64 directory"
+ fi
+
+ if ! use debug; then
+ sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
+ ${S}/config/Make.rules || die "Failed to remove debug"
+ fi
+
+ sed -i -e \
+ "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
+ ${S}/config/Make.rules.Linux || die "CXXFLAGS patching failed!"
+}
+
+src_compile() {
+ cd ${S}
+ export ICE_HOME=/usr
+ make || die "Died during make"
+}
+
+src_install() {
+ export ICE_HOME=/usr
+ make DESTDIR="${D}" install || die "Install Failed!"
+}
+
+src_test() {
+ export ICE_HOME=/usr
+ make test || die "Test failed"
+}
diff --git a/dev-python/IcePy/files/digest-IcePy-3.1.1 b/dev-python/IcePy/files/digest-IcePy-3.1.1
new file mode 100644
index 000000000000..7a14bdeb7b3a
--- /dev/null
+++ b/dev-python/IcePy/files/digest-IcePy-3.1.1
@@ -0,0 +1,3 @@
+MD5 96023adfb1449fd633d57e4dc1d5a876 IcePy-3.1.1.tar.gz 399743
+RMD160 d0bf996b20bacc563e60766047224e2f55c42b05 IcePy-3.1.1.tar.gz 399743
+SHA256 e0e104f4bfc19d97ed9ab11e34a7365055a6cb9a7f8aa0d95b60bd469285c20b IcePy-3.1.1.tar.gz 399743
diff --git a/dev-python/IcePy/files/icepy-3.1.1-makefile.patch b/dev-python/IcePy/files/icepy-3.1.1-makefile.patch
new file mode 100644
index 000000000000..350470860f8e
--- /dev/null
+++ b/dev-python/IcePy/files/icepy-3.1.1-makefile.patch
@@ -0,0 +1,74 @@
+--- config/Make.rules.orig 2006-10-16 09:46:19.000000000 -0400
++++ config/Make.rules 2006-10-16 09:49:52.000000000 -0400
+@@ -16,13 +16,13 @@
+ # if it does not exist.
+ #
+
+-prefix = /opt/IcePy-$(VERSION)
++prefix = $(DESTDIR)/usr
+
+ #
+ # The "root directory" for runpath embedded in executables. Can be unset
+ # to avoid adding a runpath to Ice executables.
+ #
+-embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
++#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
+
+ #
+ # Define OPTIMIZE as yes if you want to build with optimization.
+@@ -127,7 +127,7 @@
+ ifeq ($(shell test -d $(top_srcdir)/slice && echo 0),0)
+ slicedir = $(top_srcdir)/slice
+ else
+- slicedir = $(ICE_HOME)/slice
++ slicedir = $(prefix)/share/icepy-$(VERSION)/slice
+ endif
+
+ ifeq ($(LP64),yes)
+@@ -135,9 +135,9 @@
+ # TODO: Where should the shared library be installed if it is a 64 bit
+ # build.
+ #
+- install_libdir = $(prefix)/python
++ install_libdir = $(prefix)/lib$(lp64suffix)
+ else
+- install_libdir = $(prefix)/python
++ install_libdir = $(prefix)/lib
+ endif
+
+ ifeq ($(LP64),yes)
+@@ -203,7 +203,7 @@
+ endif
+
+ ifeq ($(mkdir),)
+- mkdir = mkdir $(1) ; \
++ mkdir = mkdir -p $(1) ; \
+ chmod a+rx $(1)
+ endif
+
+--- Makefile.orig 2006-10-16 09:50:17.000000000 -0400
++++ Makefile 2006-10-16 09:50:49.000000000 -0400
+@@ -69,8 +69,8 @@
+ fi
+
+ install::
+- $(call installdata,ICE_LICENSE,$(prefix))
+- $(call installdata,LICENSE,$(prefix))
++ $(call installdata,ICE_LICENSE,$(install_slicedir))
++ $(call installdata,LICENSE,$(install_slicedir))
+
+ test::
+ @python $(top_srcdir)/allTests.py
+--- config/Make.rules.orig 2006-10-16 10:02:00.000000000 -0400
++++ config/Make.rules 2006-10-16 10:04:04.000000000 -0400
+@@ -96,8 +96,8 @@
+ SOVERSION = $(VERSION_MAJOR)$(VERSION_MINOR)
+ libdir = $(top_srcdir)/python
+
+-install_slicedir = $(prefix)/slice
+-install_pythondir = $(prefix)/python
++install_slicedir = $(prefix)/share/icepy-$(VERSION)/slice
++install_pythondir = $(prefix)/lib/$(PYTHON_VERSION)/site-packages
+
+ INSTALL = cp -fp
+ INSTALL_PROGRAM = ${INSTALL}