summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2012-01-18 19:37:42 +0000
committerMatti Bickel <mabi@gentoo.org>2012-01-18 19:37:42 +0000
commit6e97fdaabf56eebc3162e011d2502dfd6f3f2d7b (patch)
tree8d2d3c26357b29b073b27106f1cbf2f88aed94ff /dev-php/PEAR-Crypt_HMAC2
parentfix has_version call (diff)
downloadgentoo-2-6e97fdaabf56eebc3162e011d2502dfd6f3f2d7b.tar.gz
gentoo-2-6e97fdaabf56eebc3162e011d2502dfd6f3f2d7b.tar.bz2
gentoo-2-6e97fdaabf56eebc3162e011d2502dfd6f3f2d7b.zip
fix has_version call
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/PEAR-Crypt_HMAC2')
-rw-r--r--dev-php/PEAR-Crypt_HMAC2/ChangeLog5
-rw-r--r--dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/dev-php/PEAR-Crypt_HMAC2/ChangeLog b/dev-php/PEAR-Crypt_HMAC2/ChangeLog
index d2aab3bd6dd9..dd38355c10a0 100644
--- a/dev-php/PEAR-Crypt_HMAC2/ChangeLog
+++ b/dev-php/PEAR-Crypt_HMAC2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-php/PEAR-Crypt_HMAC2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Crypt_HMAC2/ChangeLog,v 1.3 2012/01/18 18:33:39 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Crypt_HMAC2/ChangeLog,v 1.4 2012/01/18 19:37:42 mabi Exp $
+
+ 18 Jan 2012; Matti Bickel <mabi@gentoo.org> PEAR-Crypt_HMAC2-1.0.0.ebuild:
+ fix has_version call
*PEAR-Crypt_HMAC2-1.0.0 (18 Jan 2012)
diff --git a/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0.ebuild b/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0.ebuild
index a2cb1ba6ad18..ff097b42aec4 100644
--- a/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0.ebuild
+++ b/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0.ebuild,v 1.1 2012/01/18 18:33:39 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0.ebuild,v 1.2 2012/01/18 19:37:42 mabi Exp $
EAPI="4"
@@ -13,9 +13,9 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
pkg_postinst() {
- if ! has_version "=dev-lang/php[hash,mhash]" ; then
- elog "${PN} can use the hash or mhash extensions when enabled to extend the range"
+ if ! has_version "dev-lang/php[hash]" ; then
+ elog "${PN} can use the hash extension when enabled to extend the range"
elog "of cryptographic hash functions beyond the natively implemented MD5 and SHA1."
- elog "Recompile dev-lang/php with these USE flags enabled if you want these features."
+ elog "Recompile dev-lang/php with USE=\"hash\" if you want these features."
fi
}