summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-14 15:45:31 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-14 15:45:31 +0000
commit5f893b286352cac0f005e3adaa20f2396fd56bba (patch)
tree83b1a8ba84f4852560865752a5ecc0bf5b2524de /dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild
parentPass --force to eautopoint and few other pre-autoreconf funcs. (diff)
downloadgentoo-2-5f893b286352cac0f005e3adaa20f2396fd56bba.tar.gz
gentoo-2-5f893b286352cac0f005e3adaa20f2396fd56bba.tar.bz2
gentoo-2-5f893b286352cac0f005e3adaa20f2396fd56bba.zip
Initial commit wrt #398699 by "khorio"
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild')
-rw-r--r--dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild b/dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild
new file mode 100644
index 000000000000..51481c2485dc
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild,v 1.1 2012/01/14 15:45:31 ssuominen Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=FLORA
+
+inherit perl-module
+
+DESCRIPTION="A perl interface to the notification library"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/glib-perl
+ dev-perl/gtk2-perl
+ >=x11-libs/libnotify-0.7"
+DEPEND="${RDEPEND}
+ dev-perl/extutils-depends
+ dev-perl/extutils-pkgconfig
+ test? ( dev-perl/Test-Exception )"
+
+SRC_TEST="do"
+
+PATCHES=( "${FILESDIR}"/${P}-libnotify.patch )