summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-14 15:45:31 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-14 15:45:31 +0000
commit5f893b286352cac0f005e3adaa20f2396fd56bba (patch)
tree83b1a8ba84f4852560865752a5ecc0bf5b2524de /dev-perl/Gtk2-Notify
parentPass --force to eautopoint and few other pre-autoreconf funcs. (diff)
downloadgentoo-2-5f893b286352cac0f005e3adaa20f2396fd56bba.tar.gz
gentoo-2-5f893b286352cac0f005e3adaa20f2396fd56bba.tar.bz2
gentoo-2-5f893b286352cac0f005e3adaa20f2396fd56bba.zip
Initial commit wrt #398699 by "khorio"
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/Gtk2-Notify')
-rw-r--r--dev-perl/Gtk2-Notify/ChangeLog10
-rw-r--r--dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild28
-rw-r--r--dev-perl/Gtk2-Notify/Manifest5
-rw-r--r--dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch114
-rw-r--r--dev-perl/Gtk2-Notify/metadata.xml9
5 files changed, 166 insertions, 0 deletions
diff --git a/dev-perl/Gtk2-Notify/ChangeLog b/dev-perl/Gtk2-Notify/ChangeLog
new file mode 100644
index 000000000000..bffd84b4ba6a
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-perl/Gtk2-Notify
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Gtk2-Notify/ChangeLog,v 1.1 2012/01/14 15:45:31 ssuominen Exp $
+
+*Gtk2-Notify-0.05 (14 Jan 2012)
+
+ 14 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +Gtk2-Notify-0.05.ebuild,
+ +files/Gtk2-Notify-0.05-libnotify.patch:
+ Initial commit wrt #398699 by "khorio"
+
diff --git a/dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild b/dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild
new file mode 100644
index 000000000000..51481c2485dc
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Gtk2-Notify/Gtk2-Notify-0.05.ebuild,v 1.1 2012/01/14 15:45:31 ssuominen Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=FLORA
+
+inherit perl-module
+
+DESCRIPTION="A perl interface to the notification library"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/glib-perl
+ dev-perl/gtk2-perl
+ >=x11-libs/libnotify-0.7"
+DEPEND="${RDEPEND}
+ dev-perl/extutils-depends
+ dev-perl/extutils-pkgconfig
+ test? ( dev-perl/Test-Exception )"
+
+SRC_TEST="do"
+
+PATCHES=( "${FILESDIR}"/${P}-libnotify.patch )
diff --git a/dev-perl/Gtk2-Notify/Manifest b/dev-perl/Gtk2-Notify/Manifest
new file mode 100644
index 000000000000..c1335074c497
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/Manifest
@@ -0,0 +1,5 @@
+AUX Gtk2-Notify-0.05-libnotify.patch 2805 RMD160 cd2c7c7d59544af07a23cda83a337d23ddacbae0 SHA1 72e8b998260d7a1a529952c5b1ad5e7692fd0d15 SHA256 4be481603b7f59db7a46e459b13789a615c954054382412c573249bc21ba163f
+DIST Gtk2-Notify-0.05.tar.gz 60883 RMD160 10aea571e4d975880bb29d36afb9ef55f0717f20 SHA1 b0223dd5a85358c9b92ebc99040201e640612348 SHA256 88189ae68dfbd54615ad133df07e2ec8048d06d8b9586add1227d74eb2ebb047
+EBUILD Gtk2-Notify-0.05.ebuild 542 RMD160 92b675f50e25863cd3b3ad52169a28d9f1556ea4 SHA1 203f4aec43ef06bbb2bfaa5c00d7d8424f8c0bd7 SHA256 29ab270ab58649cf2c7e8ba3a1ca4a79a9070e6ac86162974c96be72d49c1cbd
+MISC ChangeLog 319 RMD160 551e4d7d874bf89a18cb2ba5cf40aaf57397d3c2 SHA1 867cd9d971ba735eb4d89555d9bbb9eea24e53d3 SHA256 aae6f10fa34df77ab44dc35d1f8ddd8272350ba7ae9abd5af6f27baf3a449f73
+MISC metadata.xml 263 RMD160 8231617d462f53192a522bdd01bb69ea11380b50 SHA1 55824ea63639ac63fa41bb13283def5f45bd95f7 SHA256 80af2a627918a5098ea78ef9855bf7b702a83fcbbe222a964d4dece8cab8ee2a
diff --git a/dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch b/dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch
new file mode 100644
index 000000000000..1e1ce9c094d3
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch
@@ -0,0 +1,114 @@
+http://bugs.gentoo.org/398699
+http://rt.cpan.org/Public/Bug/Display.html?id=67297
+http://pkgs.fedoraproject.org/gitweb/?p=perl-Gtk2-Notify.git;a=blob_plain;f=libnotify.patch;hb=HEAD
+
+--- t/notification.t
++++ t/notification.t
+@@ -2,20 +2,18 @@
+
+ use strict;
+ use warnings;
+-use Gtk2::TestHelper tests => 35;
++use Gtk2::TestHelper tests => 32;
+ use Test::Exception;
+ use Gtk2::Notify -init, $0;
+
+ ginterfaces_ok('Gtk2::Notify');
+
+-my $w = Gtk2::Window->new;
+-my $n = Gtk2::Notify->new('foo', 'bar', '', $w);
++my $n = Gtk2::Notify->new('foo', 'bar', '');
+
+ isa_ok($n, 'Gtk2::Notify');
+
+ my @methods = qw(
+ add_action
+- attach_to_widget
+ clear_actions
+ clear_hints
+ close
+@@ -46,16 +44,6 @@ lives_ok(sub {
+ }, 42);
+ }, 'add_action');
+
+-{
+- my $nw = Gtk2::Window->new;
+- lives_ok(sub {
+- $n->attach_to_widget($nw);
+- }, 'attach_to_widget');
+- lives_ok(sub {
+- $n->attach_to_widget($w);
+- }, 'attach_to_widget');
+-}
+-
+ lives_ok(sub {
+ $n->clear_actions;
+ }, 'clear_actions with existing actions');
+@@ -99,8 +87,6 @@ lives_ok(sub {
+ $n->close;
+ }, 'close before show');
+
+-$w->show_all;
+-
+ lives_ok(sub {
+ $n->show;
+ }, 'show');
+--- xs/Notify.xs
++++ xs/Notify.xs
+@@ -86,26 +86,12 @@ notify_get_server_info (class, OUTLIST c
+ MODULE = Gtk2::Notify PACKAGE = Gtk2::Notify PREFIX = notify_notification_
+
+ NotifyNotification *
+-notify_notification_new (class, summary, body=NULL, icon=NULL, attach=NULL)
++notify_notification_new (class, summary, body=NULL, icon=NULL)
+ const gchar *summary
+ const gchar *body
+ const gchar *icon
+- GtkWidget_ornull *attach
+ C_ARGS:
+- summary, body, icon, attach
+-
+-#if GTK_CHECK_VERSION (2, 9, 2)
+-
+-NotifyNotification *
+-notify_notification_new_with_status_icon (class, summary, body=NULL, icon=NULL, status_icon=NULL)
+- const gchar *summary
+- const gchar *body
+- const gchar *icon
+- GtkStatusIcon *status_icon
+- C_ARGS:
+- summary, body, icon, status_icon
+-
+-#endif
++ summary, body, icon
+
+ gboolean
+ notify_notification_update (notification, summary, message=NULL, icon=NULL)
+@@ -114,27 +100,6 @@ notify_notification_update (notification
+ const gchar *message
+ const gchar *icon
+
+-void
+-notify_notification_attach_to_widget (notification, attach)
+- NotifyNotification *notification
+- GtkWidget *attach
+-
+-#if GTK_CHECK_VERSION (2, 9, 2)
+-
+-void
+-notify_notification_attach_to_status_icon (notification, status_icon)
+- NotifyNotification *notification
+- GtkStatusIcon *status_icon
+-
+-#endif
+-
+-void
+-notify_notification_set_geometry_hints (notification, screen, x, y)
+- NotifyNotification *notification
+- GdkScreen *screen
+- gint x
+- gint y
+-
+ NO_OUTPUT gboolean
+ notify_notification_show (notification)
+ NotifyNotification *notification
diff --git a/dev-perl/Gtk2-Notify/metadata.xml b/dev-perl/Gtk2-Notify/metadata.xml
new file mode 100644
index 000000000000..0ff259de6f9b
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+</pkgmetadata>