summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-10-06 20:45:15 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-10-06 20:45:15 +0000
commit54c789dc79a971ab18f25c249c0d333629a4c2b5 (patch)
tree6ec6d0f15c5c718e51ab65f3d5f0517cbb7d36e8 /dev-ml/core/core-107.01.ebuild
parentStable on amd64 wrt bug #385893 (diff)
downloadgentoo-2-54c789dc79a971ab18f25c249c0d333629a4c2b5.tar.gz
gentoo-2-54c789dc79a971ab18f25c249c0d333629a4c2b5.tar.bz2
gentoo-2-54c789dc79a971ab18f25c249c0d333629a4c2b5.zip
version bump
(Portage version: 2.2.0_alpha62/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/core/core-107.01.ebuild')
-rw-r--r--dev-ml/core/core-107.01.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/core/core-107.01.ebuild b/dev-ml/core/core-107.01.ebuild
new file mode 100644
index 000000000000..71f279f4ff2f
--- /dev/null
+++ b/dev-ml/core/core-107.01.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/core-107.01.ebuild,v 1.1 2011/10/06 20:45:15 aballier Exp $
+
+EAPI="2"
+inherit findlib eutils multilib
+
+MY_P=${P/_/\~}
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://www.janestreet.com/ocaml/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug +ocamlopt test"
+
+RDEPEND=">=dev-lang/ocaml-3.12[ocamlopt?]
+ dev-ml/res
+ >=dev-ml/sexplib-5.2.1
+ >=dev-ml/bin-prot-1.3.1
+ >=dev-ml/fieldslib-0.1.2"
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 )"
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --docdir /usr/share/doc/${PF}/html \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}/_build/lib" emake test || die
+}
+
+src_install() {
+ findlib_src_install
+}