summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/core/ChangeLog7
-rw-r--r--dev-ml/core/core-107.01.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ml/core/ChangeLog b/dev-ml/core/ChangeLog
index d7fcdbf1e92d..108c4e7d7dc1 100644
--- a/dev-ml/core/ChangeLog
+++ b/dev-ml/core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/core
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.5 2011/07/06 18:26:59 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.6 2011/10/06 20:45:15 aballier Exp $
+
+*core-107.01 (06 Oct 2011)
+
+ 06 Oct 2011; Alexis Ballier <aballier@gentoo.org> +core-107.01.ebuild:
+ version bump
06 Jul 2011; Alexis Ballier <aballier@gentoo.org> -core-0.6.0.ebuild,
-files/core-0.6.0-ocaml312.patch, -core-0.7.0_beta1.ebuild,
diff --git a/dev-ml/core/core-107.01.ebuild b/dev-ml/core/core-107.01.ebuild
new file mode 100644
index 000000000000..71f279f4ff2f
--- /dev/null
+++ b/dev-ml/core/core-107.01.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/core-107.01.ebuild,v 1.1 2011/10/06 20:45:15 aballier Exp $
+
+EAPI="2"
+inherit findlib eutils multilib
+
+MY_P=${P/_/\~}
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://www.janestreet.com/ocaml/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug +ocamlopt test"
+
+RDEPEND=">=dev-lang/ocaml-3.12[ocamlopt?]
+ dev-ml/res
+ >=dev-ml/sexplib-5.2.1
+ >=dev-ml/bin-prot-1.3.1
+ >=dev-ml/fieldslib-0.1.2"
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 )"
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --docdir /usr/share/doc/${PF}/html \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}/_build/lib" emake test || die
+}
+
+src_install() {
+ findlib_src_install
+}