summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2003-03-27 18:45:49 +0000
committerDaniel Robbins <drobbins@gentoo.org>2003-03-27 18:45:49 +0000
commit3d6dcb02b950a9e55198bfcb79c60c21101af0e1 (patch)
tree16d4c60b34e2e3931af6c8e262b142d7a961f8fb /dev-libs
parentbump (diff)
downloadgentoo-2-3d6dcb02b950a9e55198bfcb79c60c21101af0e1.tar.gz
gentoo-2-3d6dcb02b950a9e55198bfcb79c60c21101af0e1.tar.bz2
gentoo-2-3d6dcb02b950a9e55198bfcb79c60c21101af0e1.zip
new libxml2 for unstable x86
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libxml2/ChangeLog7
-rw-r--r--dev-libs/libxml2/files/digest-libxml2-2.5.51
-rw-r--r--dev-libs/libxml2/libxml2-2.5.5.ebuild52
3 files changed, 59 insertions, 1 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index 161388c04822..a436d1e5a817 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libxml2
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.34 2003/03/19 19:26:52 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.35 2003/03/27 18:45:49 drobbins Exp $
+
+*libxml2-2.5.5 (27 Mar 2003)
+
+ 27 Mar 2003; Daniel Robbins <drobbins@gentoo.org> libxml2-2.5.5.ebuild:
+ bumping into unstable x86.
13 Mar 2003; Olivier Reisch <doctomoe@gentoo.org> libxml2-2.5.4.ebuild:
Mark stable on ppc
diff --git a/dev-libs/libxml2/files/digest-libxml2-2.5.5 b/dev-libs/libxml2/files/digest-libxml2-2.5.5
new file mode 100644
index 000000000000..30ed49e411a7
--- /dev/null
+++ b/dev-libs/libxml2/files/digest-libxml2-2.5.5
@@ -0,0 +1 @@
+MD5 43313ab09655d9e6c46ec49941879697 libxml2-2.5.5.tar.bz2 2357630
diff --git a/dev-libs/libxml2/libxml2-2.5.5.ebuild b/dev-libs/libxml2/libxml2-2.5.5.ebuild
new file mode 100644
index 000000000000..48363b2328c1
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.5.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.5.5.ebuild,v 1.1 2003/03/27 18:45:49 drobbins Exp $
+
+inherit eutils libtool gnome.org
+
+IUSE="python readline"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="sys-libs/zlib
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )"
+
+SLOT="2"
+LICENSE="MIT"
+KEYWORDS="~x86"
+
+src_compile() {
+ # Fix .la files of python site packages
+ elibtoolize
+
+ local myconf=""
+
+ # This breaks gnome2 (libgnomeprint for instance fails to compile with
+ # fresh install, and existing) - <azarah@gentoo.org> (22 Dec 2002).
+ #use zlib && myconf="--with-zlib" || myconf="--without-zlib"
+
+ use python && myconf="${myconf} --with-python" \
+ || myconf="${myconf} --without-python"
+ use readline && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ econf --with-zlib ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/python/example \
+ BASE_DIR=/usr/share/doc \
+ DOC_MODULE=${PF} \
+ EXAMPLES_DIR=/usr/share/doc/${PF}/example \
+ TARGET_DIR=/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}