summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libxml2/libxml2-2.5.5.ebuild')
-rw-r--r--dev-libs/libxml2/libxml2-2.5.5.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/libxml2/libxml2-2.5.5.ebuild b/dev-libs/libxml2/libxml2-2.5.5.ebuild
new file mode 100644
index 000000000000..48363b2328c1
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.5.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.5.5.ebuild,v 1.1 2003/03/27 18:45:49 drobbins Exp $
+
+inherit eutils libtool gnome.org
+
+IUSE="python readline"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="sys-libs/zlib
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )"
+
+SLOT="2"
+LICENSE="MIT"
+KEYWORDS="~x86"
+
+src_compile() {
+ # Fix .la files of python site packages
+ elibtoolize
+
+ local myconf=""
+
+ # This breaks gnome2 (libgnomeprint for instance fails to compile with
+ # fresh install, and existing) - <azarah@gentoo.org> (22 Dec 2002).
+ #use zlib && myconf="--with-zlib" || myconf="--without-zlib"
+
+ use python && myconf="${myconf} --with-python" \
+ || myconf="${myconf} --without-python"
+ use readline && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ econf --with-zlib ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/python/example \
+ BASE_DIR=/usr/share/doc \
+ DOC_MODULE=${PF} \
+ EXAMPLES_DIR=/usr/share/doc/${PF}/example \
+ TARGET_DIR=/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}