summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-12-02 18:27:23 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-12-02 18:27:23 +0000
commit9427cf3671629cd4be790601f4ccfcda3c272ed4 (patch)
tree5e0eb70aa7f6be4558647b46030191178e390490 /dev-libs/libowfat
parentKEYWORD fix (diff)
downloadgentoo-2-9427cf3671629cd4be790601f4ccfcda3c272ed4.tar.gz
gentoo-2-9427cf3671629cd4be790601f4ccfcda3c272ed4.tar.bz2
gentoo-2-9427cf3671629cd4be790601f4ccfcda3c272ed4.zip
new release
Diffstat (limited to 'dev-libs/libowfat')
-rw-r--r--dev-libs/libowfat/ChangeLog11
-rw-r--r--dev-libs/libowfat/libowfat-0.14.ebuild37
2 files changed, 44 insertions, 4 deletions
diff --git a/dev-libs/libowfat/ChangeLog b/dev-libs/libowfat/ChangeLog
index c50065d891d9..0fa4ee35a452 100644
--- a/dev-libs/libowfat/ChangeLog
+++ b/dev-libs/libowfat/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for dev-libs/libowfat
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libowfat/ChangeLog,v 1.2 2002/04/27 21:46:44 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libowfat/ChangeLog,v 1.3 2002/12/02 18:27:23 drobbins Exp $
-*libowfat-0.10-<PACKAGE_RELEASE> (29 Mar 2002)
+*libowfat-0.14 (02 Dec 2002)
- 29 Mar 2002; Thilo Bangert <thilo.bangert@gmx.net> ChangeLog :
+ 02 Dec 2002; Daniel Robbins <drobbins@gentoo.org>: New libowfat release.
- initial release ;-)
+*libowfat-0.10 (29 Mar 2002)
+
+ 29 Mar 2002; Thilo Bangert <thilo.bangert@gmx.net> ChangeLog : initial
+ release ;-)
diff --git a/dev-libs/libowfat/libowfat-0.14.ebuild b/dev-libs/libowfat/libowfat-0.14.ebuild
new file mode 100644
index 000000000000..d5ad7f400319
--- /dev/null
+++ b/dev-libs/libowfat/libowfat-0.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libowfat/libowfat-0.14.ebuild,v 1.1 2002/12/02 18:27:23 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="reimplement libdjb - excellent libraries from Dan Bernstein."
+SRC_URI="http://www.fefe.de/libowfat/${P}.tar.bz2"
+HOMEPAGE="http://www.fefe.de/libowfat/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND=">=dev-libs/dietlibc-0.16"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ mv Makefile Makefile.orig
+ sed -e "s:^CFLAGS.*:CFLAGS=-I. ${CFLAGS}:" \
+ -e "s:^DIET.*:DIET=/usr/bin/diet -Os:" \
+ -e "s:^prefix.*:prefix=/usr:" \
+ -e "s:^INCLUDEDIR.*:INCLUDEDIR=\${prefix}/include/libowfat:" \
+ Makefile.orig > Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+
+ make \
+ LIBDIR=${D}/usr/lib \
+ MAN3DIR=${D}/usr/share/man/man3 \
+ INCLUDEDIR=${D}/usr/include/libowfat \
+ install || die
+}