summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libowfat/libowfat-0.14.ebuild')
-rw-r--r--dev-libs/libowfat/libowfat-0.14.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/libowfat/libowfat-0.14.ebuild b/dev-libs/libowfat/libowfat-0.14.ebuild
new file mode 100644
index 000000000000..d5ad7f400319
--- /dev/null
+++ b/dev-libs/libowfat/libowfat-0.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libowfat/libowfat-0.14.ebuild,v 1.1 2002/12/02 18:27:23 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="reimplement libdjb - excellent libraries from Dan Bernstein."
+SRC_URI="http://www.fefe.de/libowfat/${P}.tar.bz2"
+HOMEPAGE="http://www.fefe.de/libowfat/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND=">=dev-libs/dietlibc-0.16"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ mv Makefile Makefile.orig
+ sed -e "s:^CFLAGS.*:CFLAGS=-I. ${CFLAGS}:" \
+ -e "s:^DIET.*:DIET=/usr/bin/diet -Os:" \
+ -e "s:^prefix.*:prefix=/usr:" \
+ -e "s:^INCLUDEDIR.*:INCLUDEDIR=\${prefix}/include/libowfat:" \
+ Makefile.orig > Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+
+ make \
+ LIBDIR=${D}/usr/lib \
+ MAN3DIR=${D}/usr/share/man/man3 \
+ INCLUDEDIR=${D}/usr/include/libowfat \
+ install || die
+}