summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2010-06-05 15:37:14 +0000
committerSteve Dibb <beandog@gentoo.org>2010-06-05 15:37:14 +0000
commit10ec39f06b3f4ef381e47b9f2078e8a13bf4c7f8 (patch)
tree96e3edc2f19df51461e83a054e870b5c7799e30a /dev-libs/libebml
parentalpha/arm/ia64/s390/sh stable wrt #310015 (diff)
downloadgentoo-2-10ec39f06b3f4ef381e47b9f2078e8a13bf4c7f8.tar.gz
gentoo-2-10ec39f06b3f4ef381e47b9f2078e8a13bf4c7f8.tar.bz2
gentoo-2-10ec39f06b3f4ef381e47b9f2078e8a13bf4c7f8.zip
Version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libebml')
-rw-r--r--dev-libs/libebml/ChangeLog10
-rw-r--r--dev-libs/libebml/files/libebml-1.0.0-makefile-fixup.patch107
-rw-r--r--dev-libs/libebml/libebml-1.0.0.ebuild42
3 files changed, 157 insertions, 2 deletions
diff --git a/dev-libs/libebml/ChangeLog b/dev-libs/libebml/ChangeLog
index 7e751f5115cb..58a693429846 100644
--- a/dev-libs/libebml/ChangeLog
+++ b/dev-libs/libebml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libebml
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/ChangeLog,v 1.94 2009/11/13 18:55:08 grobian Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/ChangeLog,v 1.95 2010/06/05 15:37:14 beandog Exp $
+
+*libebml-1.0.0 (05 Jun 2010)
+
+ 05 Jun 2010; Steve Dibb <beandog@gentoo.org> +libebml-1.0.0.ebuild,
+ +files/libebml-1.0.0-makefile-fixup.patch:
+ Version bump
*libebml-0.7.8-r2 (13 Nov 2009)
diff --git a/dev-libs/libebml/files/libebml-1.0.0-makefile-fixup.patch b/dev-libs/libebml/files/libebml-1.0.0-makefile-fixup.patch
new file mode 100644
index 000000000000..18508e6b3278
--- /dev/null
+++ b/dev-libs/libebml/files/libebml-1.0.0-makefile-fixup.patch
@@ -0,0 +1,107 @@
+--- make/linux/Makefile.orig 2010-06-05 09:00:43.000000000 -0600
++++ make/linux/Makefile 2010-06-05 09:34:40.000000000 -0600
+@@ -50,6 +50,8 @@
+ LIBRARY=libebml.a
+ LIBRARY_SO=libebml.so
+ LIBRARY_SO_VER=libebml.so.2
++LIBRARY_DYLIB=libebml.dylib
++LIBRARY_DYLIB_VER=libebml.2.dylib
+
+ # source-files
+ sources:=$(wildcard ${SRC_DIR}*$(EXTENSION))
+@@ -62,11 +64,11 @@
+ objects_so:=$(patsubst %$(EXTENSION),%.lo,$(sources))
+
+ WARNINGFLAGS=-Wall -Wno-unknown-pragmas -ansi -fno-gnu-keywords -Wshadow
+-COMPILEFLAGS=$(WARNINGFLAGS) $(CXXFLAGS) $(CPPFLAGS) $(DEBUGFLAGS) $(INCLUDE)
++COMPILEFLAGS=$(CXXFLAGS) $(CPPFLAGS) $(DEBUGFLAGS) $(INCLUDE)
+ DEPENDFLAGS = $(CXXFLAGS) $(INCLUDE)
+
+ ifeq (Darwin,$(shell uname -s))
+-all: staticlib
++all: staticlib macholib
+ else
+ all: staticlib sharedlib
+ endif
+@@ -75,8 +77,10 @@
+
+ sharedlib: $(LIBRARY_SO)
+
++macholib: $(LIBRARY_DYLIB)
++
+ lib:
+- @echo "Use the 'staticlib', 'sharedlib' or 'all' targets."
++ @echo "Use the 'staticlib', 'sharedlib', 'macholib' or 'all' targets."
+ @false
+
+ # Build rules
+@@ -91,15 +95,22 @@
+ $(RANLIB) $@
+
+ $(LIBRARY_SO): $(objects_so)
+- $(CXX) -shared -Wl,-soname,$(LIBRARY_SO_VER) -o $(LIBRARY_SO_VER) $(objects_so)
++ $(CXX) $(LDFLAGS) -shared -Wl,-soname,$(LIBRARY_SO_VER) -o $(LIBRARY_SO_VER) $(objects_so) $(LIBS)
+ rm -f $(LIBRARY_SO)
+ ln -s $(LIBRARY_SO_VER) $(LIBRARY_SO)
+
++$(LIBRARY_DYLIB): $(objects_so)
++ $(CXX) $(LDFLAGS) -dynamiclib -install_name $(libdir)/$(LIBRARY_DYLIB_VER) -o $(LIBRARY_DYLIB_VER) $(objects_so) $(LIBS)
++ rm -f $(LIBRARY_DYLIB)
++ ln -s $(LIBRARY_DYLIB_VER) $(LIBRARY_DYLIB)
++
+ clean:
+ rm -f $(objects) $(objects_so)
+ rm -f $(LIBRARY)
+ rm -f $(LIBRARY_SO)
+ rm -f $(LIBRARY_SO_VER)
++ rm -f $(LIBRARY_DYLIB)
++ rm -f $(LIBRARY_DYLIB_VER)
+ rm -f CORE
+
+ distclean dist-clean: clean
+@@ -116,30 +127,34 @@
+ done
+
+ ifeq (Darwin,$(shell uname -s))
+-install: install_staticlib install_headers
++install: install_staticlib install_macholib install_headers
+ else
+ install: install_staticlib install_sharedlib install_headers
+ endif
+
+ install_headers:
+- $(INSTALL) $(INSTALL_DIR_OPTS) -d $(includedir)
++ $(INSTALL) $(INSTALL_DIR_OPTS) -d $(DESTDIR)$(includedir)
+ for i in $(INCLUDE_DIR)/*.h; do \
+- $(INSTALL) $(INSTALL_OPTS) $$i $(includedir) ; \
++ $(INSTALL) $(INSTALL_OPTS) $$i $(DESTDIR)$(includedir) ; \
+ done
+- $(INSTALL) $(INSTALL_DIR_OPTS) -d $(includedir)/c
++ $(INSTALL) $(INSTALL_DIR_OPTS) -d $(DESTDIR)$(includedir)/c
+ for i in $(INCLUDE_DIR)/c/*.h; do \
+- $(INSTALL) $(INSTALL_OPTS) $$i $(includedir)/c ; \
++ $(INSTALL) $(INSTALL_OPTS) $$i $(DESTDIR)$(includedir)/c ; \
+ done
+
+ install_staticlib: $(LIBRARY)
+- $(INSTALL) $(INSTALL_DIR_OPTS) -d $(libdir)
+- $(INSTALL) $(INSTALL_OPTS_LIB) $(LIBRARY) $(libdir)
++ $(INSTALL) $(INSTALL_DIR_OPTS) -d $(DESTDIR)$(libdir)
++ $(INSTALL) $(INSTALL_OPTS_LIB) $(LIBRARY) $(DESTDIR)$(libdir)
+
+ install_sharedlib: $(LIBRARY_SO)
+- $(INSTALL) $(INSTALL_DIR_OPTS) -d $(libdir)
+- $(INSTALL) $(INSTALL_OPTS_LIB) $(LIBRARY_SO_VER) $(libdir)
+- ln -fs $(LIBRARY_SO_VER) $(libdir)/$(LIBRARY_SO)
+-
++ $(INSTALL) $(INSTALL_DIR_OPTS) -d $(DESTDIR)$(libdir)
++ $(INSTALL) $(INSTALL_OPTS_LIB) $(LIBRARY_SO_VER) $(DESTDIR)$(libdir)
++ ln -fs $(LIBRARY_SO_VER) $(DESTDIR)$(libdir)/$(LIBRARY_SO)
++
++install_macholib: $(LIBRARY_DYLIB)
++ $(INSTALL) $(INSTALL_DIR_OPTS) -d $(DESTDIR)$(libdir)
++ $(INSTALL) $(INSTALL_OPTS_LIB) $(LIBRARY_DYLIB_VER) $(DESTDIR)$(libdir)
++ ln -fs $(LIBRARY_DYLIB_VER) $(DESTDIR)$(libdir)/$(LIBRARY_DYLIB)
+
+ ifneq ($(wildcard .depend),)
+ include .depend
diff --git a/dev-libs/libebml/libebml-1.0.0.ebuild b/dev-libs/libebml/libebml-1.0.0.ebuild
new file mode 100644
index 000000000000..c62d5a436e4b
--- /dev/null
+++ b/dev-libs/libebml/libebml-1.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/libebml-1.0.0.ebuild,v 1.1 2010/06/05 15:37:14 beandog Exp $
+
+EAPI=2
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Extensible binary format library (kinda like XML)"
+HOMEPAGE="http://www.matroska.org/"
+SRC_URI="http://www.bunkus.org/videotools/mkvtoolnix/sources/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+S="${S}/make/linux"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile-fixup.patch
+}
+
+src_compile() {
+ # keep the prefix in here to make sure the binary is built with a correct
+ # install_name on Darwin
+ emake \
+ prefix="${EPREFIX}/usr" \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ prefix="${EPREFIX}/usr" \
+ libdir="${EPREFIX}/usr/$(get_libdir)" \
+ install || die "emake install failed"
+
+ dodoc "${WORKDIR}/${P}/ChangeLog"
+}