summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2009-02-10 16:03:34 +0000
committerJesus Rivero <neurogeek@gentoo.org>2009-02-10 16:03:34 +0000
commitb583dc0109d7a42caf349eecfd837944610f8292 (patch)
tree874ea493f8853bab5d7e88d863670844a184766b /dev-lang
parentVersion bump, bug #229275, Raúl Porcel for report. Quite rewrote ebuild: ins... (diff)
downloadgentoo-2-b583dc0109d7a42caf349eecfd837944610f8292.tar.gz
gentoo-2-b583dc0109d7a42caf349eecfd837944610f8292.tar.bz2
gentoo-2-b583dc0109d7a42caf349eecfd837944610f8292.zip
Python 2.4.4 series. Added +xml use flag to standarize.
(Portage version: 2.2_rc20/cvs/Linux 2.6.27-gentoo-r7 i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog6
-rw-r--r--dev-lang/python/python-2.4.4-r14.ebuild19
-rw-r--r--dev-lang/python/python-2.4.4-r15.ebuild20
-rw-r--r--dev-lang/python/python-2.4.4-r5.ebuild21
-rw-r--r--dev-lang/python/python-2.4.4-r6.ebuild21
5 files changed, 66 insertions, 21 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 921fc5c784b5..eb4386b677dd 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.362 2009/01/24 01:58:57 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.363 2009/02/10 16:03:34 neurogeek Exp $
+
+ 10 Feb 2009; <neurogeek@gentoo.org> python-2.4.4-r5.ebuild,
+ python-2.4.4-r6.ebuild, python-2.4.4-r14.ebuild, python-2.4.4-r15.ebuild:
+ Python 2.4.4 series. Added +xml use flag to standarize.
*python-2.5.4-r2 (24 Jan 2009)
diff --git a/dev-lang/python/python-2.4.4-r14.ebuild b/dev-lang/python/python-2.4.4-r14.ebuild
index 5ed41a422b69..cd7255828dae 100644
--- a/dev-lang/python/python-2.4.4-r14.ebuild
+++ b/dev-lang/python/python-2.4.4-r14.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.4-r14.ebuild,v 1.3 2008/11/04 03:27:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.4-r14.ebuild,v 1.4 2009/02/10 16:03:34 neurogeek Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -26,7 +26,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.4"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="ncurses gdbm ssl readline tk berkdb bootstrap ipv6 build ucs2 doc +cxx +threads examples elibc_uclibc wininst"
+IUSE="ncurses gdbm ssl readline tk berkdb bootstrap ipv6 build ucs2 doc +cxx +threads examples elibc_uclibc wininst +xml"
# Can't be compiled against db-4.5 Bug #179377
DEPEND=">=sys-libs/zlib-1.1.3
@@ -38,7 +38,7 @@ DEPEND=">=sys-libs/zlib-1.1.3
gdbm? ( sys-libs/gdbm )
ssl? ( dev-libs/openssl )
doc? ( dev-python/python-docs:2.4 )
- dev-libs/expat
+ xml? ( dev-libs/expat )
)"
# NOTE: changed RDEPEND to PDEPEND to resolve bug 88777. - kloeri
@@ -106,8 +106,17 @@ src_configure() {
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _curses _curses_panel"
use ssl \
|| export PYTHON_DISABLE_SSL=1
+ use xml \
+ || PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} pyexpat"
export PYTHON_DISABLE_MODULES
- echo $PYTHON_DISABLE_MODULES
+
+ if use !xml; then
+ ewarn "You have configured Python without XML support."
+ ewarn "This is NOT a recommended configuration as you"
+ ewarn "may face problems parsing any XML documents."
+ fi
+
+ einfo "Disabled modules: $PYTHON_DISABLE_MODULES"
fi
}
diff --git a/dev-lang/python/python-2.4.4-r15.ebuild b/dev-lang/python/python-2.4.4-r15.ebuild
index 9305cac143f5..d8ca35c5da8c 100644
--- a/dev-lang/python/python-2.4.4-r15.ebuild
+++ b/dev-lang/python/python-2.4.4-r15.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.4-r15.ebuild,v 1.2 2008/10/26 21:40:28 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.4-r15.ebuild,v 1.3 2009/02/10 16:03:34 neurogeek Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -26,7 +26,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.4"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="ncurses gdbm ssl readline tk berkdb bootstrap ipv6 build ucs2 doc +cxx +threads examples elibc_uclibc wininst"
+IUSE="ncurses gdbm ssl readline tk berkdb bootstrap ipv6 build ucs2 doc +cxx +threads examples elibc_uclibc wininst +xml"
# Can't be compiled against db-4.5 Bug #179377
DEPEND=">=sys-libs/zlib-1.1.3
@@ -38,7 +38,7 @@ DEPEND=">=sys-libs/zlib-1.1.3
gdbm? ( sys-libs/gdbm )
ssl? ( dev-libs/openssl )
doc? ( dev-python/python-docs:2.4 )
- dev-libs/expat
+ xml? ( dev-libs/expat )
)"
# NOTE: changed RDEPEND to PDEPEND to resolve bug 88777. - kloeri
@@ -106,8 +106,18 @@ src_configure() {
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _curses _curses_panel"
use ssl \
|| export PYTHON_DISABLE_SSL=1
+ use xml \
+ || PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} pyexpat"
+
export PYTHON_DISABLE_MODULES
- echo $PYTHON_DISABLE_MODULES
+
+ if use !xml; then
+ ewarn "You have configured Python without XML support."
+ ewarn "This is NOT a recommended configuration as you"
+ ewarn "may face problems parsing any XML documents."
+ fi
+
+ einfo "Disabled modules: $PYTHON_DISABLE_MODULES"
fi
}
diff --git a/dev-lang/python/python-2.4.4-r5.ebuild b/dev-lang/python/python-2.4.4-r5.ebuild
index 7f7c5eb39a7a..d2935a961f8c 100644
--- a/dev-lang/python/python-2.4.4-r5.ebuild
+++ b/dev-lang/python/python-2.4.4-r5.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.4-r5.ebuild,v 1.21 2008/10/26 21:40:28 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.4-r5.ebuild,v 1.22 2009/02/10 16:03:34 neurogeek Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
# in dev-lang/python. It _WILL_ stop people installing from
# Gentoo 1.4 images.
+EAPI=1
+
inherit autotools eutils flag-o-matic python multilib versionator toolchain-funcs alternatives
# we need this so that we don't depends on python.eclass
@@ -24,7 +26,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.4"
KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="ncurses gdbm ssl readline tk berkdb bootstrap ipv6 build ucs2 doc nocxx nothreads examples elibc_uclibc"
+IUSE="ncurses gdbm ssl readline tk berkdb bootstrap ipv6 build ucs2 doc nocxx nothreads examples elibc_uclibc +xml"
DEPEND=">=sys-libs/zlib-1.1.3
!dev-python/cjkcodecs
@@ -35,7 +37,7 @@ DEPEND=">=sys-libs/zlib-1.1.3
gdbm? ( sys-libs/gdbm )
ssl? ( dev-libs/openssl )
doc? ( =dev-python/python-docs-${PV}* )
- dev-libs/expat
+ xml? ( dev-libs/expat )
)"
# NOTE: The dev-python/python-fchksum RDEPEND is needed so that this python
@@ -101,8 +103,17 @@ src_configure() {
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _curses _curses_panel"
use ssl \
|| export PYTHON_DISABLE_SSL=1
+ use xml \
+ || PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} pyexpat"
export PYTHON_DISABLE_MODULES
- echo $PYTHON_DISABLE_MODULES
+
+ if use !xml; then
+ ewarn "You have configured Python without XML support."
+ ewarn "This is NOT a recommended configuration as you"
+ ewarn "may face problems parsing any XML documents."
+ fi
+
+ einfo "Disabled modules: $PYTHON_DISABLE_MODULES"
fi
}
diff --git a/dev-lang/python/python-2.4.4-r6.ebuild b/dev-lang/python/python-2.4.4-r6.ebuild
index 882cc4406d97..f4a9ef89e245 100644
--- a/dev-lang/python/python-2.4.4-r6.ebuild
+++ b/dev-lang/python/python-2.4.4-r6.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.4-r6.ebuild,v 1.13 2008/10/26 21:40:28 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.4-r6.ebuild,v 1.14 2009/02/10 16:03:34 neurogeek Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
# in dev-lang/python. It _WILL_ stop people installing from
# Gentoo 1.4 images.
+EAPI=1
+
inherit autotools eutils flag-o-matic python multilib versionator toolchain-funcs alternatives
# we need this so that we don't depends on python.eclass
@@ -24,7 +26,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.4"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="ncurses gdbm ssl readline tk berkdb bootstrap ipv6 build ucs2 doc nocxx nothreads examples elibc_uclibc"
+IUSE="ncurses gdbm ssl readline tk berkdb bootstrap ipv6 build ucs2 doc nocxx nothreads examples elibc_uclibc +xml"
DEPEND=">=sys-libs/zlib-1.1.3
!dev-python/cjkcodecs
@@ -35,7 +37,7 @@ DEPEND=">=sys-libs/zlib-1.1.3
gdbm? ( sys-libs/gdbm )
ssl? ( dev-libs/openssl )
doc? ( =dev-python/python-docs-${PV}* )
- dev-libs/expat
+ xml? ( dev-libs/expat )
)"
# NOTE: The dev-python/python-fchksum RDEPEND is needed so that this python
@@ -101,8 +103,17 @@ src_configure() {
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _curses _curses_panel"
use ssl \
|| export PYTHON_DISABLE_SSL=1
+ use xml \
+ || PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} pyexpat"
export PYTHON_DISABLE_MODULES
- echo $PYTHON_DISABLE_MODULES
+
+ if use !xml; then
+ ewarn "You have configured Python without XML support."
+ ewarn "This is NOT a recommended configuration as you"
+ ewarn "may face problems parsing any XML documents."
+ fi
+
+ einfo "Disabled modules: $PYTHON_DISABLE_MODULES"
fi
}