summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-2.4.4-r5.ebuild')
-rw-r--r--dev-lang/python/python-2.4.4-r5.ebuild21
1 files changed, 16 insertions, 5 deletions
diff --git a/dev-lang/python/python-2.4.4-r5.ebuild b/dev-lang/python/python-2.4.4-r5.ebuild
index 7f7c5eb39a7a..d2935a961f8c 100644
--- a/dev-lang/python/python-2.4.4-r5.ebuild
+++ b/dev-lang/python/python-2.4.4-r5.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.4-r5.ebuild,v 1.21 2008/10/26 21:40:28 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.4-r5.ebuild,v 1.22 2009/02/10 16:03:34 neurogeek Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
# in dev-lang/python. It _WILL_ stop people installing from
# Gentoo 1.4 images.
+EAPI=1
+
inherit autotools eutils flag-o-matic python multilib versionator toolchain-funcs alternatives
# we need this so that we don't depends on python.eclass
@@ -24,7 +26,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.4"
KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="ncurses gdbm ssl readline tk berkdb bootstrap ipv6 build ucs2 doc nocxx nothreads examples elibc_uclibc"
+IUSE="ncurses gdbm ssl readline tk berkdb bootstrap ipv6 build ucs2 doc nocxx nothreads examples elibc_uclibc +xml"
DEPEND=">=sys-libs/zlib-1.1.3
!dev-python/cjkcodecs
@@ -35,7 +37,7 @@ DEPEND=">=sys-libs/zlib-1.1.3
gdbm? ( sys-libs/gdbm )
ssl? ( dev-libs/openssl )
doc? ( =dev-python/python-docs-${PV}* )
- dev-libs/expat
+ xml? ( dev-libs/expat )
)"
# NOTE: The dev-python/python-fchksum RDEPEND is needed so that this python
@@ -101,8 +103,17 @@ src_configure() {
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _curses _curses_panel"
use ssl \
|| export PYTHON_DISABLE_SSL=1
+ use xml \
+ || PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} pyexpat"
export PYTHON_DISABLE_MODULES
- echo $PYTHON_DISABLE_MODULES
+
+ if use !xml; then
+ ewarn "You have configured Python without XML support."
+ ewarn "This is NOT a recommended configuration as you"
+ ewarn "may face problems parsing any XML documents."
+ fi
+
+ einfo "Disabled modules: $PYTHON_DISABLE_MODULES"
fi
}