summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-21 13:51:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-21 13:51:13 +0000
commit91493b46010582bb7f3ea1485f7a74ac5dc0b7f9 (patch)
treec8f54900da686d515753bb84a3371ca13c7284f9 /dev-lang/python/python-3.1.1-r1.ebuild
parentDelete older ebuild. (diff)
downloadgentoo-2-91493b46010582bb7f3ea1485f7a74ac5dc0b7f9.tar.gz
gentoo-2-91493b46010582bb7f3ea1485f7a74ac5dc0b7f9.tar.bz2
gentoo-2-91493b46010582bb7f3ea1485f7a74ac5dc0b7f9.zip
Don't install idle${SLOT} and idlelib module with USE="-tk" (bug #237788).
Enable "ssl" USE flag by default via IUSE (bug #304891). (Portage version: 15417-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/python/python-3.1.1-r1.ebuild')
-rw-r--r--dev-lang/python/python-3.1.1-r1.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/dev-lang/python/python-3.1.1-r1.ebuild b/dev-lang/python/python-3.1.1-r1.ebuild
index 0dae4ef75d2a..913627aa785e 100644
--- a/dev-lang/python/python-3.1.1-r1.ebuild
+++ b/dev-lang/python/python-3.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.27 2010/01/16 14:34:44 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.28 2010/02/21 13:51:12 arfrever Exp $
EAPI="2"
@@ -20,7 +20,7 @@ LICENSE="PSF-2.2"
SLOT="3.1"
PYTHON_ABI="${SLOT}"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite ssl +threads tk +wide-unicode wininst +xml"
+IUSE="build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
RDEPEND=">=app-admin/eselect-python-20091230
>=sys-libs/zlib-1.1.3
@@ -154,11 +154,11 @@ src_configure() {
$(use_enable ipv6) \
$(use_with threads) \
$(use_with wide-unicode) \
- --infodir='${prefix}'/share/info \
- --mandir='${prefix}'/share/man \
+ --infodir='${prefix}/share/info' \
+ --mandir='${prefix}/share/man' \
--with-computed-gotos \
- --with-dbmliborder=${dbmliborder} \
- --with-libc='' \
+ --with-dbmliborder="${dbmliborder}" \
+ --with-libc="" \
--with-system-ffi
}
@@ -221,14 +221,14 @@ src_install() {
# Fix the OPT variable so that it doesn't have any flags listed in it.
# Prevents the problem with compiling things with conflicting flags later.
- sed -e "s:^OPT=.*:OPT=-DNDEBUG:" -i "${D}$(python_get_libdir)/config/Makefile"
+ sed -e "s:^OPT=.*:OPT=\t\t-DNDEBUG:" -i "${D}$(python_get_libdir)/config/Makefile"
if use build; then
- rm -fr "${D}$(python_get_libdir)/"{email,sqlite3,test,tkinter}
+ rm -fr "${D}usr/bin/idle${SLOT}" "${D}$(python_get_libdir)/"{email,idlelib,sqlite3,test,tkinter}
else
use elibc_uclibc && rm -fr "${D}$(python_get_libdir)/test"
use sqlite || rm -fr "${D}$(python_get_libdir)/"{sqlite3,test/test_sqlite*}
- use tk || rm -fr "${D}$(python_get_libdir)/"{tkinter,test/test_tk*}
+ use tk || rm -fr "${D}usr/bin/idle${SLOT}" "${D}$(python_get_libdir)/"{idlelib,tkinter,test/test_tk*}
fi
use threads || rm -fr "${D}$(python_get_libdir)/multiprocessing"
@@ -251,13 +251,13 @@ pkg_preinst() {
}
eselect_python_update() {
- local ignored_python_slots_options=
- [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots_options="--ignore 3.0 --ignore 3.1 --ignore 3.2"
+ local eselect_python_options=
+ [[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
# Create python3 symlink.
- eselect python update > /dev/null
+ eselect python update --python3 > /dev/null
- eselect python update ${ignored_python_slots_options}
+ eselect python update ${eselect_python_options}
}
pkg_postinst() {