summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-21 13:51:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-21 13:51:13 +0000
commit91493b46010582bb7f3ea1485f7a74ac5dc0b7f9 (patch)
treec8f54900da686d515753bb84a3371ca13c7284f9 /dev-lang
parentDelete older ebuild. (diff)
downloadgentoo-2-91493b46010582bb7f3ea1485f7a74ac5dc0b7f9.tar.gz
gentoo-2-91493b46010582bb7f3ea1485f7a74ac5dc0b7f9.tar.bz2
gentoo-2-91493b46010582bb7f3ea1485f7a74ac5dc0b7f9.zip
Don't install idle${SLOT} and idlelib module with USE="-tk" (bug #237788).
Enable "ssl" USE flag by default via IUSE (bug #304891). (Portage version: 15417-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog8
-rw-r--r--dev-lang/python/python-2.4.6.ebuild28
-rw-r--r--dev-lang/python/python-2.5.4-r4.ebuild26
-rw-r--r--dev-lang/python/python-2.6.4-r1.ebuild26
-rw-r--r--dev-lang/python/python-3.1.1-r1.ebuild26
5 files changed, 61 insertions, 53 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 0ef34d2a2cec..39b79fa19cb5 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.451 2010/02/13 16:34:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.452 2010/02/21 13:51:12 arfrever Exp $
+
+ 21 Feb 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ python-2.4.6.ebuild, python-2.5.4-r4.ebuild, python-2.6.4-r1.ebuild,
+ python-3.1.1-r1.ebuild:
+ Don't install idle${SLOT} and idlelib module with USE="-tk" (bug #237788).
+ Enable "ssl" USE flag by default via IUSE (bug #304891).
13 Feb 2010; Raúl Porcel <armin76@gentoo.org> python-2.5.4-r4.ebuild:
alpha/ia64/m68k/s390/sh/sparc stable wrt #303005
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index 9c53d77deeaf..13b3247fa92a 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.29 2010/01/16 14:34:44 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.30 2010/02/21 13:51:12 arfrever Exp $
EAPI="1"
@@ -20,9 +20,9 @@ LICENSE="PSF-2.2"
SLOT="2.4"
PYTHON_ABI="${SLOT}"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="-berkdb bootstrap build +cxx doc elibc_uclibc examples gdbm ipv6 +ncurses +readline ssl +threads tk +wide-unicode wininst +xml"
+IUSE="-berkdb bootstrap build +cxx doc elibc_uclibc examples gdbm ipv6 +ncurses +readline +ssl +threads tk +wide-unicode wininst +xml"
-RDEPEND=">=app-admin/eselect-python-20090606
+RDEPEND=">=app-admin/eselect-python-20091230
>=sys-libs/zlib-1.1.3
virtual/libintl
!build? (
@@ -163,9 +163,9 @@ src_configure() {
$(use_enable ipv6) \
$(use_with threads) \
$(use wide-unicode && echo "--enable-unicode=ucs4" || echo "--enable-unicode=ucs2") \
- --infodir='${prefix}'/share/info \
- --mandir='${prefix}'/share/man \
- --with-libc='' \
+ --infodir='${prefix}/share/info' \
+ --mandir='${prefix}/share/man' \
+ --with-libc="" \
${myconf}
}
@@ -208,6 +208,8 @@ src_test() {
elog "If you'd like to run them, you may:"
elog "cd $(python_get_libdir)/test"
elog "and run the tests separately."
+
+ python_disable_pyc
}
src_install() {
@@ -228,15 +230,15 @@ src_install() {
# Fix the OPT variable so that it doesn't have any flags listed in it.
# Prevents the problem with compiling things with conflicting flags later.
- sed -e "s:^OPT=.*:OPT=-DNDEBUG:" -i "${D}$(python_get_libdir)/config/Makefile"
+ sed -e "s:^OPT=.*:OPT=\t\t-DNDEBUG:" -i "${D}$(python_get_libdir)/config/Makefile"
# Python 2.4 partially doesn't respect $(get_libdir).
if use build; then
- rm -fr "${D}"usr/lib*/python${SLOT}/{bsddb,email,lib-tk,test}
+ rm -fr "${D}usr/bin/idle${SLOT}" "${D}"usr/lib*/python${SLOT}/{bsddb,email,idlelib,lib-tk,test}
else
use elibc_uclibc && rm -fr "${D}"usr/lib*/python${SLOT}/{bsddb/test,test}
use berkdb || rm -fr "${D}"usr/lib*/python${SLOT}/{bsddb,test/test_bsddb*}
- use tk || rm -fr "${D}"usr/lib*/python${SLOT}/lib-tk
+ use tk || rm -fr "${D}usr/bin/idle${SLOT}" "${D}"usr/lib*/python${SLOT}/{idlelib,lib-tk}
fi
prep_ml_includes $(python_get_includedir)
@@ -257,13 +259,13 @@ pkg_preinst() {
}
eselect_python_update() {
- local ignored_python_slots_options=
- [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots_options="--ignore 3.0 --ignore 3.1 --ignore 3.2"
+ local eselect_python_options=
+ [[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
# Create python2 symlink.
- eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 > /dev/null
+ eselect python update --python2 > /dev/null
- eselect python update ${ignored_python_slots_options}
+ eselect python update ${eselect_python_options}
}
pkg_postinst() {
diff --git a/dev-lang/python/python-2.5.4-r4.ebuild b/dev-lang/python/python-2.5.4-r4.ebuild
index ab1deedd468b..84153224e132 100644
--- a/dev-lang/python/python-2.5.4-r4.ebuild
+++ b/dev-lang/python/python-2.5.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.12 2010/02/13 16:34:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.13 2010/02/21 13:51:13 arfrever Exp $
EAPI="1"
@@ -20,12 +20,12 @@ LICENSE="PSF-2.2"
SLOT="2.5"
PYTHON_ABI="${SLOT}"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite ssl +threads tk +wide-unicode wininst +xml"
+IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
# NOTE: dev-python/{elementtree,celementtree,pysqlite,ctypes}
# do not conflict with the ones in python proper. - liquidx
-RDEPEND=">=app-admin/eselect-python-20090606
+RDEPEND=">=app-admin/eselect-python-20091230
>=sys-libs/zlib-1.1.3
virtual/libffi
virtual/libintl
@@ -177,9 +177,9 @@ src_configure() {
$(use_enable ipv6) \
$(use_with threads) \
$(use wide-unicode && echo "--enable-unicode=ucs4" || echo "--enable-unicode=ucs2") \
- --infodir='${prefix}'/share/info \
- --mandir='${prefix}'/share/man \
- --with-libc='' \
+ --infodir='${prefix}/share/info' \
+ --mandir='${prefix}/share/man' \
+ --with-libc="" \
--with-system-ffi
}
@@ -243,15 +243,15 @@ src_install() {
# Fix the OPT variable so that it doesn't have any flags listed in it.
# Prevents the problem with compiling things with conflicting flags later.
- sed -e "s:^OPT=.*:OPT=-DNDEBUG:" -i "${D}$(python_get_libdir)/config/Makefile"
+ sed -e "s:^OPT=.*:OPT=\t\t-DNDEBUG:" -i "${D}$(python_get_libdir)/config/Makefile"
if use build; then
- rm -fr "${D}$(python_get_libdir)/"{bsddb,email,lib-tk,sqlite3,test}
+ rm -fr "${D}usr/bin/idle${SLOT}" "${D}$(python_get_libdir)/"{bsddb,email,idlelib,lib-tk,sqlite3,test}
else
use elibc_uclibc && rm -fr "${D}$(python_get_libdir)/"{bsddb/test,test}
use berkdb || rm -fr "${D}$(python_get_libdir)/"{bsddb,test/test_bsddb*}
use sqlite || rm -fr "${D}$(python_get_libdir)/"{sqlite3,test/test_sqlite*}
- use tk || rm -fr "${D}$(python_get_libdir)/lib-tk"
+ use tk || rm -fr "${D}usr/bin/idle${SLOT}" "${D}$(python_get_libdir)/"{idlelib,lib-tk}
fi
prep_ml_includes $(python_get_includedir)
@@ -272,13 +272,13 @@ pkg_preinst() {
}
eselect_python_update() {
- local ignored_python_slots_options=
- [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots_options="--ignore 3.0 --ignore 3.1 --ignore 3.2"
+ local eselect_python_options=
+ [[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
# Create python2 symlink.
- eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 > /dev/null
+ eselect python update --python2 > /dev/null
- eselect python update ${ignored_python_slots_options}
+ eselect python update ${eselect_python_options}
}
pkg_postinst() {
diff --git a/dev-lang/python/python-2.6.4-r1.ebuild b/dev-lang/python/python-2.6.4-r1.ebuild
index b467265e9401..10a1f951cde8 100644
--- a/dev-lang/python/python-2.6.4-r1.ebuild
+++ b/dev-lang/python/python-2.6.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.4-r1.ebuild,v 1.1 2010/01/26 18:52:04 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.4-r1.ebuild,v 1.2 2010/02/21 13:51:13 arfrever Exp $
EAPI="2"
@@ -20,12 +20,12 @@ LICENSE="PSF-2.2"
SLOT="2.6"
PYTHON_ABI="${SLOT}"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite ssl +threads tk +wide-unicode wininst +xml"
+IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
# NOTE: dev-python/{elementtree,celementtree,pysqlite,ctypes}
# do not conflict with the ones in python proper. - liquidx
-RDEPEND=">=app-admin/eselect-python-20090606
+RDEPEND=">=app-admin/eselect-python-20091230
>=sys-libs/zlib-1.1.3
virtual/libffi
virtual/libintl
@@ -179,9 +179,9 @@ src_configure() {
$(use_enable ipv6) \
$(use_with threads) \
$(use wide-unicode && echo "--enable-unicode=ucs4" || echo "--enable-unicode=ucs2") \
- --infodir='${prefix}'/share/info \
- --mandir='${prefix}'/share/man \
- --with-libc='' \
+ --infodir='${prefix}/share/info' \
+ --mandir='${prefix}/share/man' \
+ --with-libc="" \
--with-system-ffi
}
@@ -240,15 +240,15 @@ src_install() {
# Fix the OPT variable so that it doesn't have any flags listed in it.
# Prevents the problem with compiling things with conflicting flags later.
- sed -e "s:^OPT=.*:OPT=-DNDEBUG:" -i "${D}$(python_get_libdir)/config/Makefile"
+ sed -e "s:^OPT=.*:OPT=\t\t-DNDEBUG:" -i "${D}$(python_get_libdir)/config/Makefile"
if use build; then
- rm -fr "${D}$(python_get_libdir)/"{bsddb,email,lib-tk,sqlite3,test}
+ rm -fr "${D}usr/bin/idle${SLOT}" "${D}$(python_get_libdir)/"{bsddb,email,idlelib,lib-tk,sqlite3,test}
else
use elibc_uclibc && rm -fr "${D}$(python_get_libdir)/"{bsddb/test,test}
use berkdb || rm -fr "${D}$(python_get_libdir)/"{bsddb,test/test_bsddb*}
use sqlite || rm -fr "${D}$(python_get_libdir)/"{sqlite3,test/test_sqlite*}
- use tk || rm -fr "${D}$(python_get_libdir)/lib-tk"
+ use tk || rm -fr "${D}usr/bin/idle${SLOT}" "${D}$(python_get_libdir)/"{idlelib,lib-tk}
fi
use threads || rm -fr "${D}$(python_get_libdir)/multiprocessing"
@@ -274,13 +274,13 @@ pkg_preinst() {
}
eselect_python_update() {
- local ignored_python_slots_options=
- [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots_options="--ignore 3.0 --ignore 3.1 --ignore 3.2"
+ local eselect_python_options=
+ [[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
# Create python2 symlink.
- eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 > /dev/null
+ eselect python update --python2 > /dev/null
- eselect python update ${ignored_python_slots_options}
+ eselect python update ${eselect_python_options}
}
pkg_postinst() {
diff --git a/dev-lang/python/python-3.1.1-r1.ebuild b/dev-lang/python/python-3.1.1-r1.ebuild
index 0dae4ef75d2a..913627aa785e 100644
--- a/dev-lang/python/python-3.1.1-r1.ebuild
+++ b/dev-lang/python/python-3.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.27 2010/01/16 14:34:44 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.28 2010/02/21 13:51:12 arfrever Exp $
EAPI="2"
@@ -20,7 +20,7 @@ LICENSE="PSF-2.2"
SLOT="3.1"
PYTHON_ABI="${SLOT}"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite ssl +threads tk +wide-unicode wininst +xml"
+IUSE="build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
RDEPEND=">=app-admin/eselect-python-20091230
>=sys-libs/zlib-1.1.3
@@ -154,11 +154,11 @@ src_configure() {
$(use_enable ipv6) \
$(use_with threads) \
$(use_with wide-unicode) \
- --infodir='${prefix}'/share/info \
- --mandir='${prefix}'/share/man \
+ --infodir='${prefix}/share/info' \
+ --mandir='${prefix}/share/man' \
--with-computed-gotos \
- --with-dbmliborder=${dbmliborder} \
- --with-libc='' \
+ --with-dbmliborder="${dbmliborder}" \
+ --with-libc="" \
--with-system-ffi
}
@@ -221,14 +221,14 @@ src_install() {
# Fix the OPT variable so that it doesn't have any flags listed in it.
# Prevents the problem with compiling things with conflicting flags later.
- sed -e "s:^OPT=.*:OPT=-DNDEBUG:" -i "${D}$(python_get_libdir)/config/Makefile"
+ sed -e "s:^OPT=.*:OPT=\t\t-DNDEBUG:" -i "${D}$(python_get_libdir)/config/Makefile"
if use build; then
- rm -fr "${D}$(python_get_libdir)/"{email,sqlite3,test,tkinter}
+ rm -fr "${D}usr/bin/idle${SLOT}" "${D}$(python_get_libdir)/"{email,idlelib,sqlite3,test,tkinter}
else
use elibc_uclibc && rm -fr "${D}$(python_get_libdir)/test"
use sqlite || rm -fr "${D}$(python_get_libdir)/"{sqlite3,test/test_sqlite*}
- use tk || rm -fr "${D}$(python_get_libdir)/"{tkinter,test/test_tk*}
+ use tk || rm -fr "${D}usr/bin/idle${SLOT}" "${D}$(python_get_libdir)/"{idlelib,tkinter,test/test_tk*}
fi
use threads || rm -fr "${D}$(python_get_libdir)/multiprocessing"
@@ -251,13 +251,13 @@ pkg_preinst() {
}
eselect_python_update() {
- local ignored_python_slots_options=
- [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots_options="--ignore 3.0 --ignore 3.1 --ignore 3.2"
+ local eselect_python_options=
+ [[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
# Create python3 symlink.
- eselect python update > /dev/null
+ eselect python update --python3 > /dev/null
- eselect python update ${ignored_python_slots_options}
+ eselect python update ${eselect_python_options}
}
pkg_postinst() {