summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-23 20:13:15 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-23 20:13:15 +0000
commited55b190b4d717b611729a9061afeb1bd17f85a8 (patch)
tree522a88044cc27c8b91afa0037db8c864d0b65284 /dev-lang/python/python-2.4.6.ebuild
parentstable amd64, bug 313149 (diff)
downloadgentoo-2-ed55b190b4d717b611729a9061afeb1bd17f85a8.tar.gz
gentoo-2-ed55b190b4d717b611729a9061afeb1bd17f85a8.tar.bz2
gentoo-2-ed55b190b4d717b611729a9061afeb1bd17f85a8.zip
Support FEATURES="test-fail-continue". Don't install byte-compiled Python modules (bug #301915).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/python/python-2.4.6.ebuild')
-rw-r--r--dev-lang/python/python-2.4.6.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index e25c91fe0657..709685c6e9b2 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.37 2010/05/20 21:14:08 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.38 2010/05/23 20:13:15 arfrever Exp $
EAPI="1"
@@ -196,7 +196,8 @@ src_test() {
done
# Rerun failed tests in verbose mode (regrtest -w).
- EXTRATESTOPTS="-w" make test || die "make test failed"
+ EXTRATESTOPTS="-w" emake test
+ local result="$?"
for test in ${skip_tests}; do
mv "${T}/test_${test}.py" "${S}/Lib/test/test_${test}.py"
@@ -207,17 +208,22 @@ src_test() {
elog "test_${test}.py"
done
- elog "If you'd like to run them, you may:"
+ elog "If you would like to run them, you may:"
elog "cd '${EPREFIX}$(python_get_libdir)/test'"
elog "and run the tests separately."
python_disable_pyc
+
+ if [[ "${result}" -ne 0 ]]; then
+ die "emake test failed"
+ fi
}
src_install() {
[[ -z "${ED}" ]] && ED="${D%/}${EPREFIX}/"
emake DESTDIR="${D}" altinstall maninstall || die "emake altinstall maninstall failed"
+ python_clean_installation_image -q
# Install our own custom python-config
exeinto /usr/bin
@@ -265,7 +271,7 @@ pkg_preinst() {
}
eselect_python_update() {
- local eselect_python_options=
+ local eselect_python_options
[[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
# Create python2 symlink.
@@ -278,7 +284,7 @@ pkg_postinst() {
eselect_python_update
# Python 2.4 partially doesn't respect $(get_libdir).
- python_mod_optimize -x "(site-packages|test)" /usr/lib/python${SLOT}
+ python_mod_optimize -x "/(site-packages|test|tests)/" /usr/lib/python${SLOT}
if [[ "${python_updater_warning}" == "1" ]]; then
ewarn