summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-23 20:13:15 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-23 20:13:15 +0000
commited55b190b4d717b611729a9061afeb1bd17f85a8 (patch)
tree522a88044cc27c8b91afa0037db8c864d0b65284 /dev-lang/python
parentstable amd64, bug 313149 (diff)
downloadgentoo-2-ed55b190b4d717b611729a9061afeb1bd17f85a8.tar.gz
gentoo-2-ed55b190b4d717b611729a9061afeb1bd17f85a8.tar.bz2
gentoo-2-ed55b190b4d717b611729a9061afeb1bd17f85a8.zip
Support FEATURES="test-fail-continue". Don't install byte-compiled Python modules (bug #301915).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog8
-rw-r--r--dev-lang/python/python-2.4.6.ebuild16
-rw-r--r--dev-lang/python/python-2.5.4-r4.ebuild16
-rw-r--r--dev-lang/python/python-2.6.5-r2.ebuild14
-rw-r--r--dev-lang/python/python-3.1.2-r3.ebuild14
5 files changed, 49 insertions, 19 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 79ba9501079e..f948e980f0b4 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.468 2010/05/21 19:22:17 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.469 2010/05/23 20:13:15 arfrever Exp $
+
+ 23 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ python-2.4.6.ebuild, python-2.5.4-r4.ebuild, python-2.6.5-r2.ebuild,
+ python-3.1.2-r3.ebuild:
+ Support FEATURES="test-fail-continue". Don't install byte-compiled Python
+ modules (bug #301915).
21 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
python-2.6.5-r2.ebuild:
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index e25c91fe0657..709685c6e9b2 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.37 2010/05/20 21:14:08 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.38 2010/05/23 20:13:15 arfrever Exp $
EAPI="1"
@@ -196,7 +196,8 @@ src_test() {
done
# Rerun failed tests in verbose mode (regrtest -w).
- EXTRATESTOPTS="-w" make test || die "make test failed"
+ EXTRATESTOPTS="-w" emake test
+ local result="$?"
for test in ${skip_tests}; do
mv "${T}/test_${test}.py" "${S}/Lib/test/test_${test}.py"
@@ -207,17 +208,22 @@ src_test() {
elog "test_${test}.py"
done
- elog "If you'd like to run them, you may:"
+ elog "If you would like to run them, you may:"
elog "cd '${EPREFIX}$(python_get_libdir)/test'"
elog "and run the tests separately."
python_disable_pyc
+
+ if [[ "${result}" -ne 0 ]]; then
+ die "emake test failed"
+ fi
}
src_install() {
[[ -z "${ED}" ]] && ED="${D%/}${EPREFIX}/"
emake DESTDIR="${D}" altinstall maninstall || die "emake altinstall maninstall failed"
+ python_clean_installation_image -q
# Install our own custom python-config
exeinto /usr/bin
@@ -265,7 +271,7 @@ pkg_preinst() {
}
eselect_python_update() {
- local eselect_python_options=
+ local eselect_python_options
[[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
# Create python2 symlink.
@@ -278,7 +284,7 @@ pkg_postinst() {
eselect_python_update
# Python 2.4 partially doesn't respect $(get_libdir).
- python_mod_optimize -x "(site-packages|test)" /usr/lib/python${SLOT}
+ python_mod_optimize -x "/(site-packages|test|tests)/" /usr/lib/python${SLOT}
if [[ "${python_updater_warning}" == "1" ]]; then
ewarn
diff --git a/dev-lang/python/python-2.5.4-r4.ebuild b/dev-lang/python/python-2.5.4-r4.ebuild
index aaefc537f8fe..d2f81d4b494d 100644
--- a/dev-lang/python/python-2.5.4-r4.ebuild
+++ b/dev-lang/python/python-2.5.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.19 2010/05/20 21:14:08 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.20 2010/05/23 20:13:15 arfrever Exp $
EAPI="1"
@@ -215,7 +215,8 @@ src_test() {
# Redirect stdin from /dev/tty as a workaround for bug #248081.
# Rerun failed tests in verbose mode (regrtest -w).
- EXTRATESTOPTS="-w" make test < /dev/tty || die "make test failed"
+ EXTRATESTOPTS="-w" emake test < /dev/tty
+ local result="$?"
for test in ${skip_tests}; do
mv "${T}/test_${test}.py" "${S}/Lib/test/test_${test}.py"
@@ -226,17 +227,22 @@ src_test() {
elog "test_${test}.py"
done
- elog "If you'd like to run them, you may:"
+ elog "If you would like to run them, you may:"
elog "cd '${EPREFIX}$(python_get_libdir)/test'"
elog "and run the tests separately."
python_disable_pyc
+
+ if [[ "${result}" -ne 0 ]]; then
+ die "emake test failed"
+ fi
}
src_install() {
[[ -z "${ED}" ]] && ED="${D%/}${EPREFIX}/"
emake DESTDIR="${D}" altinstall maninstall || die "emake altinstall maninstall failed"
+ python_clean_installation_image -q
mv "${ED}usr/bin/python${SLOT}-config" "${ED}usr/bin/python-config-${SLOT}"
@@ -279,7 +285,7 @@ pkg_preinst() {
}
eselect_python_update() {
- local eselect_python_options=
+ local eselect_python_options
[[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
# Create python2 symlink.
@@ -291,7 +297,7 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
- python_mod_optimize -x "(site-packages|test)" $(python_get_libdir)
+ python_mod_optimize -x "/(site-packages|test|tests)/" $(python_get_libdir)
if [[ "${python_updater_warning}" == "1" ]]; then
ewarn
diff --git a/dev-lang/python/python-2.6.5-r2.ebuild b/dev-lang/python/python-2.6.5-r2.ebuild
index cef70fe7052f..e92bc2fa465c 100644
--- a/dev-lang/python/python-2.6.5-r2.ebuild
+++ b/dev-lang/python/python-2.6.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.5-r2.ebuild,v 1.8 2010/05/21 19:22:17 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.5-r2.ebuild,v 1.9 2010/05/23 20:13:15 arfrever Exp $
EAPI="2"
@@ -205,7 +205,8 @@ src_test() {
done
# Rerun failed tests in verbose mode (regrtest -w).
- EXTRATESTOPTS="-w" make test || die "make test failed"
+ EXTRATESTOPTS="-w" emake test
+ local result="$?"
for test in ${skip_tests}; do
mv "${T}/test_${test}.py" "${S}/Lib/test/test_${test}.py"
@@ -221,12 +222,17 @@ src_test() {
elog "and run the tests separately."
python_disable_pyc
+
+ if [[ "${result}" -ne 0 ]]; then
+ die "emake test failed"
+ fi
}
src_install() {
[[ -z "${ED}" ]] && ED="${D%/}${EPREFIX}/"
emake DESTDIR="${D}" altinstall maninstall || die "emake altinstall maninstall failed"
+ python_clean_installation_image -q
mv "${ED}usr/bin/python${SLOT}-config" "${ED}usr/bin/python-config-${SLOT}"
@@ -271,7 +277,7 @@ pkg_preinst() {
}
eselect_python_update() {
- local eselect_python_options=
+ local eselect_python_options
[[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
# Create python2 symlink.
@@ -283,7 +289,7 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
- python_mod_optimize -x "(site-packages|test)" $(python_get_libdir)
+ python_mod_optimize -x "/(site-packages|test|tests)/" $(python_get_libdir)
if [[ "${python_updater_warning}" == "1" ]]; then
ewarn
diff --git a/dev-lang/python/python-3.1.2-r3.ebuild b/dev-lang/python/python-3.1.2-r3.ebuild
index 4db6ee79fb88..a19d2442afdd 100644
--- a/dev-lang/python/python-3.1.2-r3.ebuild
+++ b/dev-lang/python/python-3.1.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r3.ebuild,v 1.7 2010/05/22 21:08:23 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r3.ebuild,v 1.8 2010/05/23 20:13:15 arfrever Exp $
EAPI="3"
@@ -195,7 +195,8 @@ src_test() {
done
# Rerun failed tests in verbose mode (regrtest -w).
- EXTRATESTOPTS="-w" make test || die "make test failed"
+ EXTRATESTOPTS="-w" emake test
+ local result="$?"
for test in ${skip_tests}; do
mv "${T}/test_${test}.py" "${S}/Lib/test/test_${test}.py"
@@ -211,10 +212,15 @@ src_test() {
elog "and run the tests separately."
python_disable_pyc
+
+ if [[ "${result}" -ne 0 ]]; then
+ die "emake test failed"
+ fi
}
src_install() {
emake DESTDIR="${D}" altinstall || die "emake altinstall failed"
+ python_clean_installation_image -q
mv "${ED}usr/bin/python${SLOT}-config" "${ED}usr/bin/python-config-${SLOT}"
@@ -254,7 +260,7 @@ pkg_preinst() {
}
eselect_python_update() {
- local eselect_python_options=
+ local eselect_python_options
[[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
# Create python3 symlink.
@@ -266,7 +272,7 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
- python_mod_optimize -x "(site-packages|test)" $(python_get_libdir)
+ python_mod_optimize -x "/(site-packages|test|tests)/" $(python_get_libdir)
if [[ "$(eselect python show)" == "python2."* ]]; then
ewarn