summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-10-20 18:02:57 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-10-20 18:02:57 +0000
commit1e4a355933e97629517346d44c1209890ea312b4 (patch)
tree21d6d4b2ad4c393159597b950b96ea7bbb100400 /dev-lang/ocaml
parentmoved apache module installs into src_install. Bug 67000. (Manifest recommit) (diff)
downloadgentoo-2-1e4a355933e97629517346d44c1209890ea312b4.tar.gz
gentoo-2-1e4a355933e97629517346d44c1209890ea312b4.tar.bz2
gentoo-2-1e4a355933e97629517346d44c1209890ea312b4.zip
Changes strip-flags with replace-flags
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ChangeLog7
-rw-r--r--dev-lang/ocaml/ocaml-3.07-r1.ebuild4
-rw-r--r--dev-lang/ocaml/ocaml-3.08.1.ebuild4
-rw-r--r--dev-lang/ocaml/ocaml-3.08.ebuild4
4 files changed, 12 insertions, 7 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 6e9853b42ef0..9da8ca6c9ed4 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.48 2004/10/12 19:33:45 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.49 2004/10/20 18:02:57 mattam Exp $
+
+ 20 Oct 2004; Matthieu Sozeau <mattam@gentoo.org> ocaml-3.07-r1.ebuild,
+ ocaml-3.08.1.ebuild, ocaml-3.08.ebuild:
+ Changed strip-flags to replace-flags, as advised by Carsten Tschense in bug
+ #65327.
12 Oct 2004; Matthieu Sozeau <mattam@gentoo.org> ocaml-3.07-r1.ebuild,
ocaml-3.08.1.ebuild, ocaml-3.08.ebuild:
diff --git a/dev-lang/ocaml/ocaml-3.07-r1.ebuild b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
index 07f460df2c70..db1b2d3e59a3 100644
--- a/dev-lang/ocaml/ocaml-3.07-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.25 2004/10/12 19:33:45 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.26 2004/10/20 18:02:57 mattam Exp $
inherit flag-o-matic eutils
@@ -35,7 +35,7 @@ src_unpack() {
src_compile() {
filter-flags "-fstack-protector"
- strip-flags
+ replace-flags "-O?" -O2
local myconf
use tcltk || myconf="-no-tk"
diff --git a/dev-lang/ocaml/ocaml-3.08.1.ebuild b/dev-lang/ocaml/ocaml-3.08.1.ebuild
index c61dd2f4fc58..7419a77615a6 100644
--- a/dev-lang/ocaml/ocaml-3.08.1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.08.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.1.ebuild,v 1.3 2004/10/12 19:33:45 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.1.ebuild,v 1.4 2004/10/20 18:02:57 mattam Exp $
inherit flag-o-matic eutils
@@ -26,7 +26,7 @@ pkg_setup() {
src_compile() {
filter-flags "-fstack-protector"
- strip-flags
+ replace-flags "-O?" -O2
local myconf
use tcltk || myconf="-no-tk"
diff --git a/dev-lang/ocaml/ocaml-3.08.ebuild b/dev-lang/ocaml/ocaml-3.08.ebuild
index 33e48715cd05..59e26cd43cff 100644
--- a/dev-lang/ocaml/ocaml-3.08.ebuild
+++ b/dev-lang/ocaml/ocaml-3.08.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.ebuild,v 1.7 2004/10/12 19:33:45 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.ebuild,v 1.8 2004/10/20 18:02:57 mattam Exp $
inherit flag-o-matic eutils
@@ -28,7 +28,7 @@ pkg_setup() {
src_compile() {
filter-flags "-fstack-protector"
- strip-flags
+ replace-flags "-O?" -O2
local myconf
use tcltk || myconf="-no-tk"