summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-04-17 01:29:22 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-04-17 01:29:22 +0000
commitdab4442679bc427d99e735972f5635fff7afd582 (patch)
tree74b9733e203089ebc469ee3ece9384b8b48d111f /dev-lang/mono
parentVersion bump including security fixes, see bug #263070. Drop 3rd party pdftop... (diff)
downloadgentoo-2-dab4442679bc427d99e735972f5635fff7afd582.tar.gz
gentoo-2-dab4442679bc427d99e735972f5635fff7afd582.tar.bz2
gentoo-2-dab4442679bc427d99e735972f5635fff7afd582.zip
Check for CONFIG_SYSVIPC, see bug 261869. Thanks to Sergey Zolotorev <sergey.zolotorev@gmail.com> for finding the cause.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/ChangeLog7
-rw-r--r--dev-lang/mono/mono-2.0.1-r1.ebuild20
-rw-r--r--dev-lang/mono/mono-2.2-r5.ebuild20
-rw-r--r--dev-lang/mono/mono-2.4.ebuild20
4 files changed, 60 insertions, 7 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 505c413e80f3..59b4a9fc27c7 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.162 2009/04/10 23:11:08 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.163 2009/04/17 01:29:22 loki_val Exp $
+
+ 17 Apr 2009; Peter Alfredsen <loki_val@gentoo.org> mono-2.0.1-r1.ebuild,
+ mono-2.2-r5.ebuild, mono-2.4.ebuild:
+ Check for CONFIG_SYSVIPC, see bug 261869. Thanks to Sergey Zolotorev
+ <sergey.zolotorev@gmail.com> for finding the cause.
10 Apr 2009; Peter Alfredsen <loki_val@gentoo.org>
+files/mono-2.4-ppcbuild-fix.patch, mono-2.4.ebuild:
diff --git a/dev-lang/mono/mono-2.0.1-r1.ebuild b/dev-lang/mono/mono-2.0.1-r1.ebuild
index f26ee432f51e..f0b7367966cb 100644
--- a/dev-lang/mono/mono-2.0.1-r1.ebuild
+++ b/dev-lang/mono/mono-2.0.1-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.0.1-r1.ebuild,v 1.4 2009/04/04 14:05:21 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.0.1-r1.ebuild,v 1.5 2009/04/17 01:29:22 loki_val Exp $
EAPI=2
-inherit base eutils flag-o-matic multilib
+inherit linux-info base eutils flag-o-matic multilib
DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
HOMEPAGE="http://www.go-mono.com"
@@ -36,6 +36,22 @@ PATCHES=( "${FILESDIR}/${PN}-biginteger_overflow.diff"
"${FILESDIR}/${P}-fix_implicit_pointer_conversions.patch"
"${FILESDIR}/${PN}-2.0-fix-headless.patch" )
+pkg_setup() {
+ if use kernel_linux
+ then
+ get_version
+ require_configured_kernel
+ if linux_chkconfig_present SYSVIPC
+ then
+ einfo "CONFIG_SYSVIPC is set, looking good."
+ else
+ eerror "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
+ eerror "See http://bugs.gentoo.org/261869 for more info."
+ die "Please set CONFIG_SYSVIPC in your kernel .config"
+ fi
+ fi
+}
+
src_configure() {
# mono's build system is finiky, strip the flags
strip-flags
diff --git a/dev-lang/mono/mono-2.2-r5.ebuild b/dev-lang/mono/mono-2.2-r5.ebuild
index fb239382cb81..eddda7dedf72 100644
--- a/dev-lang/mono/mono-2.2-r5.ebuild
+++ b/dev-lang/mono/mono-2.2-r5.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.2-r5.ebuild,v 1.2 2009/04/06 15:12:26 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.2-r5.ebuild,v 1.3 2009/04/17 01:29:22 loki_val Exp $
EAPI=2
-inherit mono eutils flag-o-matic multilib go-mono
+inherit linux-info mono eutils flag-o-matic multilib go-mono
DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
HOMEPAGE="http://www.go-mono.com"
@@ -43,6 +43,22 @@ PATCHES=(
"${FILESDIR}/mono-2.2-freebsd-elf_common.patch"
)
+pkg_setup() {
+ if use kernel_linux
+ then
+ get_version
+ require_configured_kernel
+ if linux_chkconfig_present SYSVIPC
+ then
+ einfo "CONFIG_SYSVIPC is set, looking good."
+ else
+ eerror "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
+ eerror "See http://bugs.gentoo.org/261869 for more info."
+ die "Please set CONFIG_SYSVIPC in your kernel .config"
+ fi
+ fi
+}
+
src_prepare() {
sed -e "s:@MONOLIBDIR@:$(get_libdir):" \
< "${FILESDIR}"/mono-2.2-libdir126.patch \
diff --git a/dev-lang/mono/mono-2.4.ebuild b/dev-lang/mono/mono-2.4.ebuild
index c0ca10ab1f1d..9956968a8bfb 100644
--- a/dev-lang/mono/mono-2.4.ebuild
+++ b/dev-lang/mono/mono-2.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.4.ebuild,v 1.3 2009/04/10 23:11:08 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.4.ebuild,v 1.4 2009/04/17 01:29:22 loki_val Exp $
EAPI=2
-inherit mono eutils flag-o-matic multilib go-mono
+inherit linux-info mono eutils flag-o-matic multilib go-mono
DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
HOMEPAGE="http://www.go-mono.com"
@@ -41,6 +41,22 @@ PATCHES=(
"${FILESDIR}/mono-2.4-ppcbuild-fix.patch"
)
+pkg_setup() {
+ if use kernel_linux
+ then
+ get_version
+ require_configured_kernel
+ if linux_chkconfig_present SYSVIPC
+ then
+ einfo "CONFIG_SYSVIPC is set, looking good."
+ else
+ eerror "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
+ eerror "See http://bugs.gentoo.org/261869 for more info."
+ die "Please set CONFIG_SYSVIPC in your kernel .config"
+ fi
+ fi
+}
+
src_prepare() {
sed -e "s:@MONOLIBDIR@:$(get_libdir):" \
< "${FILESDIR}"/mono-2.2-libdir126.patch \