summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/mono/mono-2.4.ebuild')
-rw-r--r--dev-lang/mono/mono-2.4.ebuild20
1 files changed, 18 insertions, 2 deletions
diff --git a/dev-lang/mono/mono-2.4.ebuild b/dev-lang/mono/mono-2.4.ebuild
index c0ca10ab1f1d..9956968a8bfb 100644
--- a/dev-lang/mono/mono-2.4.ebuild
+++ b/dev-lang/mono/mono-2.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.4.ebuild,v 1.3 2009/04/10 23:11:08 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.4.ebuild,v 1.4 2009/04/17 01:29:22 loki_val Exp $
EAPI=2
-inherit mono eutils flag-o-matic multilib go-mono
+inherit linux-info mono eutils flag-o-matic multilib go-mono
DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
HOMEPAGE="http://www.go-mono.com"
@@ -41,6 +41,22 @@ PATCHES=(
"${FILESDIR}/mono-2.4-ppcbuild-fix.patch"
)
+pkg_setup() {
+ if use kernel_linux
+ then
+ get_version
+ require_configured_kernel
+ if linux_chkconfig_present SYSVIPC
+ then
+ einfo "CONFIG_SYSVIPC is set, looking good."
+ else
+ eerror "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
+ eerror "See http://bugs.gentoo.org/261869 for more info."
+ die "Please set CONFIG_SYSVIPC in your kernel .config"
+ fi
+ fi
+}
+
src_prepare() {
sed -e "s:@MONOLIBDIR@:$(get_libdir):" \
< "${FILESDIR}"/mono-2.2-libdir126.patch \