summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-16 02:27:08 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-16 02:27:08 +0000
commitd1f5bb5fc4fa044f0e51f54fd59f35bdef4fb5e5 (patch)
tree74c835906140e505bffefcabc9b5567a54d925a4 /dev-java/ant
parentadd inherit eutils (diff)
downloadgentoo-2-d1f5bb5fc4fa044f0e51f54fd59f35bdef4fb5e5.tar.gz
gentoo-2-d1f5bb5fc4fa044f0e51f54fd59f35bdef4fb5e5.tar.bz2
gentoo-2-d1f5bb5fc4fa044f0e51f54fd59f35bdef4fb5e5.zip
add inherit eutils
Diffstat (limited to 'dev-java/ant')
-rw-r--r--dev-java/ant/ant-1.5.3-r5.ebuild13
-rw-r--r--dev-java/ant/ant-1.5.4-r1.ebuild18
-rw-r--r--dev-java/ant/ant-1.6.0-r2.ebuild14
-rw-r--r--dev-java/ant/ant-1.6.0-r3.ebuild11
-rw-r--r--dev-java/ant/ant-1.6.1-r1.ebuild10
-rw-r--r--dev-java/ant/ant-1.6.1.ebuild10
6 files changed, 44 insertions, 32 deletions
diff --git a/dev-java/ant/ant-1.5.3-r5.ebuild b/dev-java/ant/ant-1.5.3-r5.ebuild
index 8126784afb60..69e48298b72a 100644
--- a/dev-java/ant/ant-1.5.3-r5.ebuild
+++ b/dev-java/ant/ant-1.5.3-r5.ebuild
@@ -1,21 +1,24 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.5.3-r5.ebuild,v 1.6 2004/02/10 06:15:09 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.5.3-r5.ebuild,v 1.7 2004/04/16 02:23:45 vapier Exp $
-inherit java-pkg
+inherit java-pkg eutils
-S="${WORKDIR}/apache-ant-${PV}-1"
DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
+HOMEPAGE="http://ant.apache.org/"
SRC_URI="http://archive.apache.org/dist/ant/source/apache-${PN}-${PV}-1-src.tar.bz2"
-HOMEPAGE="http://ant.apache.org"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="x86 ppc sparc"
+IUSE="doc"
+
DEPEND="virtual/glibc
>=virtual/jdk-1.3"
RDEPEND=">=virtual/jdk-1.3
app-shells/bash"
-IUSE="doc"
+
+S="${WORKDIR}/apache-ant-${PV}-1"
src_unpack() {
unpack ${A}
diff --git a/dev-java/ant/ant-1.5.4-r1.ebuild b/dev-java/ant/ant-1.5.4-r1.ebuild
index 5db2a1032892..df88f5d565c9 100644
--- a/dev-java/ant/ant-1.5.4-r1.ebuild
+++ b/dev-java/ant/ant-1.5.4-r1.ebuild
@@ -1,22 +1,25 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.5.4-r1.ebuild,v 1.10 2004/03/16 02:12:38 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.5.4-r1.ebuild,v 1.11 2004/04/16 02:24:08 vapier Exp $
inherit java-pkg
-S="${WORKDIR}/apache-ant-${PV}"
DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
+HOMEPAGE="http://ant.apache.org/"
SRC_URI="http://archive.apache.org/dist/ant/source/apache-${PN}-${PV}-src.zip"
-HOMEPAGE="http://ant.apache.org"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="x86 ppc sparc amd64"
+IUSE="doc"
+
DEPEND="virtual/glibc
- >=virtual/jdk-1.3
- >=app-arch/unzip-5.50-r1"
+ >=virtual/jdk-1.3
+ >=app-arch/unzip-5.50-r1"
RDEPEND=">=virtual/jdk-1.3
- app-shells/bash"
-IUSE="doc"
+ app-shells/bash"
+
+S="${WORKDIR}/apache-ant-${PV}"
src_unpack() {
unpack ${A}
@@ -30,7 +33,6 @@ src_unpack() {
}
src_compile() {
-
addwrite "/proc/self/maps"
[ -z ${JDK_HOME} ] && einfo "JDK_HOME not set, please check with java-config" && die
diff --git a/dev-java/ant/ant-1.6.0-r2.ebuild b/dev-java/ant/ant-1.6.0-r2.ebuild
index dc91847b134f..a70fa5c89907 100644
--- a/dev-java/ant/ant-1.6.0-r2.ebuild
+++ b/dev-java/ant/ant-1.6.0-r2.ebuild
@@ -1,16 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.0-r2.ebuild,v 1.5 2004/03/11 20:37:24 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.0-r2.ebuild,v 1.6 2004/04/16 02:25:02 vapier Exp $
-inherit java-pkg
+inherit java-pkg eutils
-S="${WORKDIR}/apache-ant-${PV}"
DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
+HOMEPAGE="http://ant.apache.org/"
SRC_URI="mirror://apache/ant/source/apache-${PN}-${PV}-src.tar.bz2"
-HOMEPAGE="http://ant.apache.org"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="-* ~x86"
+IUSE="doc optional-tasks"
+
DEPEND="virtual/glibc
>=virtual/jdk-1.4
>=dev-java/java-config-1.2"
@@ -18,7 +20,8 @@ RDEPEND=">=virtual/jdk-1.4
app-shells/bash
>=dev-java/java-config-1.2"
PDEPEND="optional-tasks? ( =dev-java/ant-optional-1.6.0-r2 )"
-IUSE="doc optional-tasks"
+
+S="${WORKDIR}/apache-ant-${PV}"
src_unpack() {
unpack ${A}
@@ -30,7 +33,6 @@ src_unpack() {
}
src_compile() {
-
addwrite "/proc/self/maps"
export JAVA_HOME=${JDK_HOME}
if [ `arch` == "ppc" ] ; then
diff --git a/dev-java/ant/ant-1.6.0-r3.ebuild b/dev-java/ant/ant-1.6.0-r3.ebuild
index 04bfa96eee81..f21bcafa3f7f 100644
--- a/dev-java/ant/ant-1.6.0-r3.ebuild
+++ b/dev-java/ant/ant-1.6.0-r3.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.0-r3.ebuild,v 1.6 2004/02/25 07:39:32 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.0-r3.ebuild,v 1.7 2004/04/16 02:25:22 vapier Exp $
-inherit java-pkg
+inherit java-pkg eutils
DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
+HOMEPAGE="http://ant.apache.org/"
SRC_URI="mirror://apache/ant/source/apache-${PN}-${PV}-src.tar.bz2"
-HOMEPAGE="http://ant.apache.org"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
DEPEND="virtual/glibc
>=virtual/jdk-1.4
>=dev-java/java-config-1.2
@@ -18,7 +21,6 @@ RDEPEND=">=virtual/jdk-1.4
app-shells/bash
>=dev-java/java-config-1.2"
PDEPEND="=dev-java/ant-optional-1.6.0-r3"
-IUSE="doc"
S="${WORKDIR}/apache-ant-${PV}"
@@ -32,7 +34,6 @@ src_unpack() {
}
src_compile() {
-
addwrite "/proc/self/maps"
export JAVA_HOME=${JDK_HOME}
if [ `arch` == "ppc" ] ; then
diff --git a/dev-java/ant/ant-1.6.1-r1.ebuild b/dev-java/ant/ant-1.6.1-r1.ebuild
index 89899f844a3c..9e8cb6361f31 100644
--- a/dev-java/ant/ant-1.6.1-r1.ebuild
+++ b/dev-java/ant/ant-1.6.1-r1.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.1-r1.ebuild,v 1.5 2004/03/23 20:23:16 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.1-r1.ebuild,v 1.6 2004/04/16 02:25:39 vapier Exp $
-inherit java-pkg
+inherit java-pkg eutils
DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
+HOMEPAGE="http://ant.apache.org/"
SRC_URI="mirror://apache/ant/source/apache-${PN}-${PV}-src.tar.bz2"
-HOMEPAGE="http://ant.apache.org"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
DEPEND="virtual/glibc
>=virtual/jdk-1.4
>=dev-java/java-config-1.2
@@ -18,7 +21,6 @@ RDEPEND=">=virtual/jdk-1.4
app-shells/bash
>=dev-java/java-config-1.2"
PDEPEND="=dev-java/ant-optional-${PV}-r1"
-IUSE="doc"
S="${WORKDIR}/apache-ant-${PV}"
diff --git a/dev-java/ant/ant-1.6.1.ebuild b/dev-java/ant/ant-1.6.1.ebuild
index 145d7d6d9850..843be7345a7d 100644
--- a/dev-java/ant/ant-1.6.1.ebuild
+++ b/dev-java/ant/ant-1.6.1.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.1.ebuild,v 1.5 2004/03/14 01:30:26 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.1.ebuild,v 1.6 2004/04/16 02:25:57 vapier Exp $
-inherit java-pkg
+inherit java-pkg eutils
DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
+HOMEPAGE="http://ant.apache.org/"
SRC_URI="mirror://apache/ant/source/apache-${PN}-${PV}-src.tar.bz2"
-HOMEPAGE="http://ant.apache.org"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
DEPEND="virtual/glibc
>=virtual/jdk-1.4
>=dev-java/java-config-1.2
@@ -18,7 +21,6 @@ RDEPEND=">=virtual/jdk-1.4
app-shells/bash
>=dev-java/java-config-1.2"
PDEPEND="=dev-java/ant-optional-${PV}"
-IUSE="doc"
S="${WORKDIR}/apache-ant-${PV}"