summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-16 02:27:08 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-16 02:27:08 +0000
commitd1f5bb5fc4fa044f0e51f54fd59f35bdef4fb5e5 (patch)
tree74c835906140e505bffefcabc9b5567a54d925a4
parentadd inherit eutils (diff)
downloadgentoo-2-d1f5bb5fc4fa044f0e51f54fd59f35bdef4fb5e5.tar.gz
gentoo-2-d1f5bb5fc4fa044f0e51f54fd59f35bdef4fb5e5.tar.bz2
gentoo-2-d1f5bb5fc4fa044f0e51f54fd59f35bdef4fb5e5.zip
add inherit eutils
-rw-r--r--dev-java/ant-optional/ant-optional-1.6.0-r3.ebuild23
-rw-r--r--dev-java/ant-optional/ant-optional-1.6.1-r1.ebuild22
-rw-r--r--dev-java/ant-optional/ant-optional-1.6.1.ebuild23
-rw-r--r--dev-java/ant/ant-1.5.3-r5.ebuild13
-rw-r--r--dev-java/ant/ant-1.5.4-r1.ebuild18
-rw-r--r--dev-java/ant/ant-1.6.0-r2.ebuild14
-rw-r--r--dev-java/ant/ant-1.6.0-r3.ebuild11
-rw-r--r--dev-java/ant/ant-1.6.1-r1.ebuild10
-rw-r--r--dev-java/ant/ant-1.6.1.ebuild10
-rw-r--r--dev-java/commons-httpclient/commons-httpclient-2.0-r1.ebuild16
-rw-r--r--dev-java/jsch/jsch-0.1.12.ebuild9
-rw-r--r--dev-java/jswat/jswat-2.21.ebuild19
12 files changed, 86 insertions, 102 deletions
diff --git a/dev-java/ant-optional/ant-optional-1.6.0-r3.ebuild b/dev-java/ant-optional/ant-optional-1.6.0-r3.ebuild
index 9db625a2385c..6696cc735339 100644
--- a/dev-java/ant-optional/ant-optional-1.6.0-r3.ebuild
+++ b/dev-java/ant-optional/ant-optional-1.6.0-r3.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-optional/ant-optional-1.6.0-r3.ebuild,v 1.5 2004/03/11 02:47:52 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-optional/ant-optional-1.6.0-r3.ebuild,v 1.6 2004/04/16 02:22:15 vapier Exp $
-inherit java-pkg
+inherit java-pkg eutils
-IUSE="doc javamail"
-
-S="${WORKDIR}/apache-ant-${PV}"
DESCRIPTION="Apache ANT Optional Tasks Jar Files"
-SRC_URI="mirror://apache/ant/source/apache-ant-${PV}-src.tar.bz2"
HOMEPAGE="http://ant.apache.org"
+SRC_URI="mirror://apache/ant/source/apache-ant-${PV}-src.tar.bz2"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="doc javamail"
+
DEPEND="=dev-java/ant-1.6.0-r3
>=dev-java/java-config-1.2
>=dev-java/log4j-1.2.8
@@ -32,19 +32,10 @@ DEPEND="=dev-java/ant-1.6.0-r3
>=dev-java/regexp-1.3
>=dev-java/jython-2.1
javamail? ( >=dev-java/javamail-1.3 )"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- # Patch build.sh to die with non-zero exit code in case of errors.
- # This patch may be useful for all ant versions.
-# epatch ${FILESDIR}/build.sh-exit-fix.patch.gz
-}
+S="${WORKDIR}/apache-ant-${PV}"
src_compile() {
-
addwrite "/proc/self/maps"
export JAVA_HOME=${JDK_HOME}
if [ `arch` == "ppc" ] ; then
diff --git a/dev-java/ant-optional/ant-optional-1.6.1-r1.ebuild b/dev-java/ant-optional/ant-optional-1.6.1-r1.ebuild
index 789a4ca368df..bb1ebd9a9f22 100644
--- a/dev-java/ant-optional/ant-optional-1.6.1-r1.ebuild
+++ b/dev-java/ant-optional/ant-optional-1.6.1-r1.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-optional/ant-optional-1.6.1-r1.ebuild,v 1.4 2004/03/23 20:25:11 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-optional/ant-optional-1.6.1-r1.ebuild,v 1.5 2004/04/16 02:22:41 vapier Exp $
-inherit java-pkg
+inherit java-pkg eutils
-IUSE="doc javamail"
-
-S="${WORKDIR}/apache-ant-${PV}"
DESCRIPTION="Apache ANT Optional Tasks Jar Files"
+HOMEPAGE="http://ant.apache.org/"
SRC_URI="mirror://apache/ant/source/apache-ant-${PV}-src.tar.bz2"
-HOMEPAGE="http://ant.apache.org"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="doc javamail"
+
DEPEND="=dev-java/ant-${PV}-r1
>=dev-java/java-config-1.2
>=dev-java/log4j-1.2.8
@@ -33,17 +33,9 @@ DEPEND="=dev-java/ant-${PV}-r1
javamail? ( >=dev-java/javamail-1.3 )"
RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # Patch build.sh to die with non-zero exit code in case of errors.
- # This patch may be useful for all ant versions.
-# epatch ${FILESDIR}/build.sh-exit-fix.patch.gz
-}
+S="${WORKDIR}/apache-ant-${PV}"
src_compile() {
-
addwrite "/proc/self/maps"
export JAVA_HOME=${JDK_HOME}
if [ `arch` == "ppc" ] ; then
diff --git a/dev-java/ant-optional/ant-optional-1.6.1.ebuild b/dev-java/ant-optional/ant-optional-1.6.1.ebuild
index 4b10874cf575..421458ce5928 100644
--- a/dev-java/ant-optional/ant-optional-1.6.1.ebuild
+++ b/dev-java/ant-optional/ant-optional-1.6.1.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-optional/ant-optional-1.6.1.ebuild,v 1.5 2004/03/17 04:05:37 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-optional/ant-optional-1.6.1.ebuild,v 1.6 2004/04/16 02:23:23 vapier Exp $
-inherit java-pkg
+inherit java-pkg eutils
-IUSE="doc javamail"
-
-S="${WORKDIR}/apache-ant-${PV}"
DESCRIPTION="Apache ANT Optional Tasks Jar Files"
+HOMEPAGE="http://ant.apache.org/"
SRC_URI="mirror://apache/ant/source/apache-ant-${PV}-src.tar.bz2"
-HOMEPAGE="http://ant.apache.org"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="doc javamail"
+
DEPEND="=dev-java/ant-${PV}
>=dev-java/java-config-1.2
>=dev-java/log4j-1.2.8
@@ -31,19 +31,10 @@ DEPEND="=dev-java/ant-${PV}
>=dev-java/regexp-1.3
>=dev-java/jython-2.1
javamail? ( >=dev-java/javamail-1.3 )"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- # Patch build.sh to die with non-zero exit code in case of errors.
- # This patch may be useful for all ant versions.
-# epatch ${FILESDIR}/build.sh-exit-fix.patch.gz
-}
+S="${WORKDIR}/apache-ant-${PV}"
src_compile() {
-
addwrite "/proc/self/maps"
export JAVA_HOME=${JDK_HOME}
if [ `arch` == "ppc" ] ; then
diff --git a/dev-java/ant/ant-1.5.3-r5.ebuild b/dev-java/ant/ant-1.5.3-r5.ebuild
index 8126784afb60..69e48298b72a 100644
--- a/dev-java/ant/ant-1.5.3-r5.ebuild
+++ b/dev-java/ant/ant-1.5.3-r5.ebuild
@@ -1,21 +1,24 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.5.3-r5.ebuild,v 1.6 2004/02/10 06:15:09 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.5.3-r5.ebuild,v 1.7 2004/04/16 02:23:45 vapier Exp $
-inherit java-pkg
+inherit java-pkg eutils
-S="${WORKDIR}/apache-ant-${PV}-1"
DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
+HOMEPAGE="http://ant.apache.org/"
SRC_URI="http://archive.apache.org/dist/ant/source/apache-${PN}-${PV}-1-src.tar.bz2"
-HOMEPAGE="http://ant.apache.org"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="x86 ppc sparc"
+IUSE="doc"
+
DEPEND="virtual/glibc
>=virtual/jdk-1.3"
RDEPEND=">=virtual/jdk-1.3
app-shells/bash"
-IUSE="doc"
+
+S="${WORKDIR}/apache-ant-${PV}-1"
src_unpack() {
unpack ${A}
diff --git a/dev-java/ant/ant-1.5.4-r1.ebuild b/dev-java/ant/ant-1.5.4-r1.ebuild
index 5db2a1032892..df88f5d565c9 100644
--- a/dev-java/ant/ant-1.5.4-r1.ebuild
+++ b/dev-java/ant/ant-1.5.4-r1.ebuild
@@ -1,22 +1,25 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.5.4-r1.ebuild,v 1.10 2004/03/16 02:12:38 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.5.4-r1.ebuild,v 1.11 2004/04/16 02:24:08 vapier Exp $
inherit java-pkg
-S="${WORKDIR}/apache-ant-${PV}"
DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
+HOMEPAGE="http://ant.apache.org/"
SRC_URI="http://archive.apache.org/dist/ant/source/apache-${PN}-${PV}-src.zip"
-HOMEPAGE="http://ant.apache.org"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="x86 ppc sparc amd64"
+IUSE="doc"
+
DEPEND="virtual/glibc
- >=virtual/jdk-1.3
- >=app-arch/unzip-5.50-r1"
+ >=virtual/jdk-1.3
+ >=app-arch/unzip-5.50-r1"
RDEPEND=">=virtual/jdk-1.3
- app-shells/bash"
-IUSE="doc"
+ app-shells/bash"
+
+S="${WORKDIR}/apache-ant-${PV}"
src_unpack() {
unpack ${A}
@@ -30,7 +33,6 @@ src_unpack() {
}
src_compile() {
-
addwrite "/proc/self/maps"
[ -z ${JDK_HOME} ] && einfo "JDK_HOME not set, please check with java-config" && die
diff --git a/dev-java/ant/ant-1.6.0-r2.ebuild b/dev-java/ant/ant-1.6.0-r2.ebuild
index dc91847b134f..a70fa5c89907 100644
--- a/dev-java/ant/ant-1.6.0-r2.ebuild
+++ b/dev-java/ant/ant-1.6.0-r2.ebuild
@@ -1,16 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.0-r2.ebuild,v 1.5 2004/03/11 20:37:24 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.0-r2.ebuild,v 1.6 2004/04/16 02:25:02 vapier Exp $
-inherit java-pkg
+inherit java-pkg eutils
-S="${WORKDIR}/apache-ant-${PV}"
DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
+HOMEPAGE="http://ant.apache.org/"
SRC_URI="mirror://apache/ant/source/apache-${PN}-${PV}-src.tar.bz2"
-HOMEPAGE="http://ant.apache.org"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="-* ~x86"
+IUSE="doc optional-tasks"
+
DEPEND="virtual/glibc
>=virtual/jdk-1.4
>=dev-java/java-config-1.2"
@@ -18,7 +20,8 @@ RDEPEND=">=virtual/jdk-1.4
app-shells/bash
>=dev-java/java-config-1.2"
PDEPEND="optional-tasks? ( =dev-java/ant-optional-1.6.0-r2 )"
-IUSE="doc optional-tasks"
+
+S="${WORKDIR}/apache-ant-${PV}"
src_unpack() {
unpack ${A}
@@ -30,7 +33,6 @@ src_unpack() {
}
src_compile() {
-
addwrite "/proc/self/maps"
export JAVA_HOME=${JDK_HOME}
if [ `arch` == "ppc" ] ; then
diff --git a/dev-java/ant/ant-1.6.0-r3.ebuild b/dev-java/ant/ant-1.6.0-r3.ebuild
index 04bfa96eee81..f21bcafa3f7f 100644
--- a/dev-java/ant/ant-1.6.0-r3.ebuild
+++ b/dev-java/ant/ant-1.6.0-r3.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.0-r3.ebuild,v 1.6 2004/02/25 07:39:32 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.0-r3.ebuild,v 1.7 2004/04/16 02:25:22 vapier Exp $
-inherit java-pkg
+inherit java-pkg eutils
DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
+HOMEPAGE="http://ant.apache.org/"
SRC_URI="mirror://apache/ant/source/apache-${PN}-${PV}-src.tar.bz2"
-HOMEPAGE="http://ant.apache.org"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
DEPEND="virtual/glibc
>=virtual/jdk-1.4
>=dev-java/java-config-1.2
@@ -18,7 +21,6 @@ RDEPEND=">=virtual/jdk-1.4
app-shells/bash
>=dev-java/java-config-1.2"
PDEPEND="=dev-java/ant-optional-1.6.0-r3"
-IUSE="doc"
S="${WORKDIR}/apache-ant-${PV}"
@@ -32,7 +34,6 @@ src_unpack() {
}
src_compile() {
-
addwrite "/proc/self/maps"
export JAVA_HOME=${JDK_HOME}
if [ `arch` == "ppc" ] ; then
diff --git a/dev-java/ant/ant-1.6.1-r1.ebuild b/dev-java/ant/ant-1.6.1-r1.ebuild
index 89899f844a3c..9e8cb6361f31 100644
--- a/dev-java/ant/ant-1.6.1-r1.ebuild
+++ b/dev-java/ant/ant-1.6.1-r1.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.1-r1.ebuild,v 1.5 2004/03/23 20:23:16 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.1-r1.ebuild,v 1.6 2004/04/16 02:25:39 vapier Exp $
-inherit java-pkg
+inherit java-pkg eutils
DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
+HOMEPAGE="http://ant.apache.org/"
SRC_URI="mirror://apache/ant/source/apache-${PN}-${PV}-src.tar.bz2"
-HOMEPAGE="http://ant.apache.org"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
DEPEND="virtual/glibc
>=virtual/jdk-1.4
>=dev-java/java-config-1.2
@@ -18,7 +21,6 @@ RDEPEND=">=virtual/jdk-1.4
app-shells/bash
>=dev-java/java-config-1.2"
PDEPEND="=dev-java/ant-optional-${PV}-r1"
-IUSE="doc"
S="${WORKDIR}/apache-ant-${PV}"
diff --git a/dev-java/ant/ant-1.6.1.ebuild b/dev-java/ant/ant-1.6.1.ebuild
index 145d7d6d9850..843be7345a7d 100644
--- a/dev-java/ant/ant-1.6.1.ebuild
+++ b/dev-java/ant/ant-1.6.1.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.1.ebuild,v 1.5 2004/03/14 01:30:26 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.1.ebuild,v 1.6 2004/04/16 02:25:57 vapier Exp $
-inherit java-pkg
+inherit java-pkg eutils
DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
+HOMEPAGE="http://ant.apache.org/"
SRC_URI="mirror://apache/ant/source/apache-${PN}-${PV}-src.tar.bz2"
-HOMEPAGE="http://ant.apache.org"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
DEPEND="virtual/glibc
>=virtual/jdk-1.4
>=dev-java/java-config-1.2
@@ -18,7 +21,6 @@ RDEPEND=">=virtual/jdk-1.4
app-shells/bash
>=dev-java/java-config-1.2"
PDEPEND="=dev-java/ant-optional-${PV}"
-IUSE="doc"
S="${WORKDIR}/apache-ant-${PV}"
diff --git a/dev-java/commons-httpclient/commons-httpclient-2.0-r1.ebuild b/dev-java/commons-httpclient/commons-httpclient-2.0-r1.ebuild
index 0426e6904636..b33d6b3e4ffe 100644
--- a/dev-java/commons-httpclient/commons-httpclient-2.0-r1.ebuild
+++ b/dev-java/commons-httpclient/commons-httpclient-2.0-r1.ebuild
@@ -1,23 +1,23 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/commons-httpclient-2.0-r1.ebuild,v 1.2 2004/03/23 02:54:11 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/commons-httpclient-2.0-r1.ebuild,v 1.3 2004/04/16 02:26:14 vapier Exp $
-inherit java-pkg
+inherit java-pkg eutils
DESCRIPTION="The Jakarta Commons HttpClient provides an efficient, up-to-date, and feature-rich package implementing the client side of the most recent HTTP standards and recommendations."
HOMEPAGE="http://jakarta.apache.org/commons/httpclient/index.html"
SRC_URI="mirror://apache/jakarta/commons/httpclient/source/${P/_/-}-src.tar.gz"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/log4j-1.2.5
- >=dev-java/ant-1.4
- dev-java/commons-logging"
-RDEPEND=">=virtual/jdk-1.3"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc"
IUSE="doc jikes"
-S=${WORKDIR}/${P}
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/log4j-1.2.5
+ >=dev-java/ant-1.4
+ dev-java/commons-logging"
+RDEPEND=">=virtual/jdk-1.3"
src_unpack() {
unpack ${A}
diff --git a/dev-java/jsch/jsch-0.1.12.ebuild b/dev-java/jsch/jsch-0.1.12.ebuild
index 0bb77352bfbe..95b24e32d79d 100644
--- a/dev-java/jsch/jsch-0.1.12.ebuild
+++ b/dev-java/jsch/jsch-0.1.12.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jsch/jsch-0.1.12.ebuild,v 1.3 2004/03/18 22:31:22 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jsch/jsch-0.1.12.ebuild,v 1.4 2004/04/16 02:26:36 vapier Exp $
+
+inherit eutils
DESCRIPTION="JSch is a pure Java implementation of SSH2."
HOMEPAGE="http://www.jcraft.com/jsch/"
@@ -20,10 +22,7 @@ src_compile() {
epatch ${FILESDIR}/build.xml-dstamp.patch.gz
local myc
-
- if [ -n "`use jikes`" ] ; then
- myc="${myc} -Dbuild.compiler=jikes"
- fi
+ use jikes && myc="${myc} -Dbuild.compiler=jikes"
ANT_OPTS=${myc} ant || die "Failed Compiling"
}
diff --git a/dev-java/jswat/jswat-2.21.ebuild b/dev-java/jswat/jswat-2.21.ebuild
index 39c16ee67c90..3c8a3fef4304 100644
--- a/dev-java/jswat/jswat-2.21.ebuild
+++ b/dev-java/jswat/jswat-2.21.ebuild
@@ -1,19 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jswat/jswat-2.21.ebuild,v 1.2 2004/02/29 01:14:26 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jswat/jswat-2.21.ebuild,v 1.3 2004/04/16 02:27:08 vapier Exp $
-inherit java-pkg
+inherit java-pkg eutils
-S="${WORKDIR}/${PN}-${PV}"
DESCRIPTION="Extensible graphical Java debugger"
HOMEPAGE="http://www.bluemarsh.com/java/jswat"
SRC_URI="mirror://sourceforge/jswat/${PN}-src-${PV}.tar.gz"
+
LICENSE="GPL-2"
SLOT="2"
KEYWORDS="x86 sparc -ppc amd64"
+IUSE="doc jikes junit"
+
DEPEND=">=dev-java/ant-1.5"
RDEPEND=">=virtual/jdk-1.4"
-IUSE="doc jikes junit"
src_compile() {
epatch ${FILESDIR}/${P}.diff
@@ -25,16 +26,14 @@ src_compile() {
if [ -f "/usr/share/junit/lib/junit.jar" ] ; then
export CLASSPATH="/usr/share/junit/lib/junit.jar"
export DEP_APPEND="junit"
- if [ `use junit` ]
- then
- einfo "Running JUnit tests, this may take awhile ..."
- ant ${antopts} test || die "Junit test failed"
+ if use junit ; then
+ einfo "Running JUnit tests, this may take awhile ..."
+ ant ${antopts} test || die "Junit test failed"
fi
fi
-
}
-src_install () {
+src_install() {
# install jswat classes
java-pkg_dojar \
build/dist/*/*.jar \