summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2008-05-25 11:14:18 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2008-05-25 11:14:18 +0000
commitf472bc6e0140f9ba5185960bcb3a8921aa0f31f1 (patch)
tree86d7c81da2e5f09da6c8f65ac226e18038964c64 /dev-haskell/x11/x11-1.4.1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-f472bc6e0140f9ba5185960bcb3a8921aa0f31f1.tar.gz
gentoo-2-f472bc6e0140f9ba5185960bcb3a8921aa0f31f1.tar.bz2
gentoo-2-f472bc6e0140f9ba5185960bcb3a8921aa0f31f1.zip
Add USE="xinerama" to most recent dev-haskell/x11 versions. This fixes bug #223377.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-haskell/x11/x11-1.4.1.ebuild')
-rw-r--r--dev-haskell/x11/x11-1.4.1.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/dev-haskell/x11/x11-1.4.1.ebuild b/dev-haskell/x11/x11-1.4.1.ebuild
index 831cd4a147d2..09aebf0597b9 100644
--- a/dev-haskell/x11/x11-1.4.1.ebuild
+++ b/dev-haskell/x11/x11-1.4.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/x11-1.4.1.ebuild,v 1.1 2007/12/15 23:11:47 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/x11-1.4.1.ebuild,v 1.2 2008/05/25 11:14:18 kolmodin Exp $
CABAL_FEATURES="lib profile haddock"
-CABAL_MIN_VERSION=1.1.6
-inherit haskell-cabal
+CABAL_MIN_VERSION=1.2.3.0
+inherit haskell-cabal eutils autotools
MY_PN="X11"
MY_P="${MY_PN}-${PV}"
@@ -16,9 +16,23 @@ SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~sparc ~x86"
-IUSE=""
+IUSE="xinerama"
DEPEND=">=dev-lang/ghc-6.4.2
- x11-libs/libX11"
+ x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )"
S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack $A
+
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.4.2-with-xinerama.patch"
+ eautoreconf
+}
+
+src_compile() {
+ CABAL_CONFIGURE_FLAGS="--configure-option=$(use_with xinerama)"
+ cabal_src_compile
+}