summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2008-05-25 11:14:18 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2008-05-25 11:14:18 +0000
commitf472bc6e0140f9ba5185960bcb3a8921aa0f31f1 (patch)
tree86d7c81da2e5f09da6c8f65ac226e18038964c64 /dev-haskell
parentVersion bump. (diff)
downloadgentoo-2-f472bc6e0140f9ba5185960bcb3a8921aa0f31f1.tar.gz
gentoo-2-f472bc6e0140f9ba5185960bcb3a8921aa0f31f1.tar.bz2
gentoo-2-f472bc6e0140f9ba5185960bcb3a8921aa0f31f1.zip
Add USE="xinerama" to most recent dev-haskell/x11 versions. This fixes bug #223377.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/x11/ChangeLog12
-rw-r--r--dev-haskell/x11/x11-1.2.1.ebuild6
-rw-r--r--dev-haskell/x11/x11-1.4.0.ebuild26
-rw-r--r--dev-haskell/x11/x11-1.4.1.ebuild26
4 files changed, 53 insertions, 17 deletions
diff --git a/dev-haskell/x11/ChangeLog b/dev-haskell/x11/ChangeLog
index b299414d1c43..b393f84c1d42 100644
--- a/dev-haskell/x11/ChangeLog
+++ b/dev-haskell/x11/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-haskell/x11
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/ChangeLog,v 1.6 2007/12/15 23:11:47 kolmodin Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/ChangeLog,v 1.7 2008/05/25 11:14:18 kolmodin Exp $
+
+ 25 May 2008; Lennart Kolmodin <kolmodin@gentoo.org> x11-1.2.1.ebuild,
+ x11-1.4.0.ebuild, x11-1.4.1.ebuild:
+ Add IUSE="xinerama" and add missing dependency on libXinerama.
+ This requires >=cabal-1.2.3.0.
+ Reported by Prashanth Mundkur <prashanth.mundkur@gmail.com>.
+ This fixes bug #223377.
+ Fix minor repoman issue with x11-1.2.1.
*x11-1.4.1 (16 Dec 2007)
diff --git a/dev-haskell/x11/x11-1.2.1.ebuild b/dev-haskell/x11/x11-1.2.1.ebuild
index c226a1745a6d..141613c8d422 100644
--- a/dev-haskell/x11/x11-1.2.1.ebuild
+++ b/dev-haskell/x11/x11-1.2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/x11-1.2.1.ebuild,v 1.3 2007/12/13 17:34:10 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/x11-1.2.1.ebuild,v 1.4 2008/05/25 11:14:18 kolmodin Exp $
CABAL_FEATURES="lib profile haddock"
inherit haskell-cabal
@@ -24,6 +24,6 @@ S="${WORKDIR}/ghc-${GHC_PV}/libraries/${MY_PN}"
# Sadly Setup.hs in the ghc-6.6.1 extralibs was not tested with Cabal-1.1.6.x
src_unpack() {
- unpack "${A}"
+ unpack ${A}
sed -i -e "/type Hook/ s/UserHooks/Maybe UserHooks/" "${S}/Setup.hs"
}
diff --git a/dev-haskell/x11/x11-1.4.0.ebuild b/dev-haskell/x11/x11-1.4.0.ebuild
index 473014deebca..eb868cbe1ee2 100644
--- a/dev-haskell/x11/x11-1.4.0.ebuild
+++ b/dev-haskell/x11/x11-1.4.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/x11-1.4.0.ebuild,v 1.2 2007/12/15 16:38:04 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/x11-1.4.0.ebuild,v 1.3 2008/05/25 11:14:18 kolmodin Exp $
CABAL_FEATURES="lib profile haddock"
-CABAL_MIN_VERSION=1.1.6
-inherit haskell-cabal
+CABAL_MIN_VERSION=1.2.3.0
+inherit haskell-cabal eutils autotools
MY_PN="X11"
MY_P="${MY_PN}-${PV}"
@@ -16,9 +16,23 @@ SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~sparc ~x86"
-IUSE=""
+IUSE="xinerama"
DEPEND=">=dev-lang/ghc-6.4.2
- x11-libs/libX11"
+ x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )"
S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack $A
+
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.4.2-with-xinerama.patch"
+ eautoreconf
+}
+
+src_compile() {
+ CABAL_CONFIGURE_FLAGS="--configure-option=$(use_with xinerama)"
+ cabal_src_compile
+}
diff --git a/dev-haskell/x11/x11-1.4.1.ebuild b/dev-haskell/x11/x11-1.4.1.ebuild
index 831cd4a147d2..09aebf0597b9 100644
--- a/dev-haskell/x11/x11-1.4.1.ebuild
+++ b/dev-haskell/x11/x11-1.4.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/x11-1.4.1.ebuild,v 1.1 2007/12/15 23:11:47 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/x11-1.4.1.ebuild,v 1.2 2008/05/25 11:14:18 kolmodin Exp $
CABAL_FEATURES="lib profile haddock"
-CABAL_MIN_VERSION=1.1.6
-inherit haskell-cabal
+CABAL_MIN_VERSION=1.2.3.0
+inherit haskell-cabal eutils autotools
MY_PN="X11"
MY_P="${MY_PN}-${PV}"
@@ -16,9 +16,23 @@ SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~sparc ~x86"
-IUSE=""
+IUSE="xinerama"
DEPEND=">=dev-lang/ghc-6.4.2
- x11-libs/libX11"
+ x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )"
S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack $A
+
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.4.2-with-xinerama.patch"
+ eautoreconf
+}
+
+src_compile() {
+ CABAL_CONFIGURE_FLAGS="--configure-option=$(use_with xinerama)"
+ cabal_src_compile
+}